Results 1 to 6 of 6

Thread: E: Couldn't find package pstack

  1. #1
    Join Date
    Sep 2013
    Beans
    1

    E: Couldn't find package pstack

    Hello, this is my first post.

    I have problem installing pstack on Lucid 10.04.4 64-bit (TC 2012 x86_64 GNU/Linux | Ubuntu 10.04.4 LTS)

    I did sudo apt-get install pstack and the output is:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package pstack

    I tried to find the solution on the internet, but I couldn't find one, at least a step-by-step procedure to solve this issue.

    So, thanks for any answer or references about the solution. Thank you.

    PS: the purpose of this installation is to be able to create zmdiaglog (Zimbra log requested by Zimbra support regarding our company login issue)

  2. #2
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: E: Couldn't find package pstack

    This package is only offered as a 32bit package in 10.04.

    http://packages.ubuntu.com/lucid/pstack

  3. #3
    Join Date
    Jan 2009
    Location
    Santander, Spain
    Beans
    1,751
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: E: Couldn't find package pstack

    As 10.04 has reached its EOL support, when you want to install any software package, you have to write the correct address where the repositories have been moved, i.e.: http://old-releases.ubuntu.com/

    Please, read the following link: http://askubuntu.com/questions/91815...ported-release in order to know how

    I recommend you to install a supported ubuntu as 12.04, 12.10 or 13.04 since you are at security risk using lucid lynx, also you cannot expecto to receive any security update

  4. #4
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: E: Couldn't find package pstack

    If this is a server release, EOL is April 2015

    https://wiki.ubuntu.com/Releases

    As ibjsb4 says - the package is there for 32bit - http://packages.ubuntu.com/lucid/pstack

  5. #5
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,461

    Re: E: Couldn't find package pstack

    Quote Originally Posted by ibjsb4 View Post
    This package is only offered as a 32bit package in 10.04.

    http://packages.ubuntu.com/lucid/pstack
    pstack's man page says it's a 32-bit only program, so independent of the Ubuntu version:

    RESTRICTIONS
    pstack currently works only on Linux, only on an x86 machine running 32 bit ELF binaries (64 bit not supported).
    The weird thing is that I installed and run it on my 64-bit Ubuntu (without any useful output, I must say). So, why make a program installable on a 64-bit system if the man page says it does not work? Or is the man page out of date?


    Code:
    sander@flappie:~$ sudo pstack 2623
    
    2623: chromium-browser --type=plugin --plugin-path=/usr/lib/flashplugin-installer/libflashplayer.so --lang=en-US --channel=2339.7....
    (No symbols found)
    crawl: Input/output error
    Error tracing through process 2623
    0x7f577ca2f3cd: ????sander@flappie:~$ 
    sander@flappie:~$ 
    sander@flappie:~$ uname -a
    Linux flappie 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    sander@flappie:~$

  6. #6
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: E: Couldn't find package pstack

    [QUOTE=sanderj;12788325]The weird thing is that I installed and run it on my 64-bit Ubuntu (without any useful output, I must say). So, why make a program installable on a 64-bit system if the man page says it does not work? Or is the man page out of date?

    Don't know whats up with the man page, but 12.04 carries the 64bit version.

    EDIT: found this

    https://bugs.launchpad.net/ubuntu/+s...ck/+bug/532000
    Last edited by ibjsb4; September 14th, 2013 at 04:04 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •