Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: kill not working

  1. #1
    Join Date
    Dec 2007
    Beans
    370

    kill not working

    Since upgrading to 12.04, evolution keeps freezing. I have tried the forcequit icon, which does nothing for it. I have tried switching to a new terminal window and running either 'killall evolution -v' or 'kill xxxxx'. Both commands report that the process has been terminated, but that is not the case. Evolution is still running and locked up. I haven't had any other programs lock up, but both kill commands work fine with other programs that are actively running and not locked up, evolution included.

    Why? Why does evolution keep locking up and why does kill not kill?

  2. #2
    Join Date
    Aug 2011
    Location
    52° N 6° E
    Beans
    2,422
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kill not working

    Kill by default sends the terminate signal, which is a request to terminate, allowing the applications to do some cleanup, make backups of files and things like that. If a program has a signal handler for SIGTERM and has completely locked up, it may not respond. In this case, try SIGKILL
    Code:
    kill -9 <ID>
    As to why evolution is freezing, I've got no idea.

  3. #3
    Join Date
    Aug 2009
    Location
    Makati City, Philippines
    Beans
    1,137
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kill not working

    Code:
    pgrep evolution
    Then use this number for the kill -9 command.
    The Philippine Team
    The best Ubuntu derivative: Linux Mint
    Relax. Head to the Community Cafe.

  4. #4
    Join Date
    Dec 2007
    Beans
    370

    Re: kill not working

    Thanks guys. When it locks up again, I will try those. I wish I knew why it kept locking up though. It NEVER did that with 10.04!

  5. #5
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    1,682

    Re: kill not working

    My evolution locks up, too.

    From my long experience with this problem, -9 works. -1 also works. I use:
    Code:
    pkill -1 evolution

  6. #6
    Join Date
    Dec 2007
    Beans
    370

    Re: kill not working

    Thanks guys... That worked when firefox locked up today. I would really like to know why my system NEVER locked up running 10.04, but when I upgraded to 12.04 it locks up as much as that OS that we are trying to avoid?

  7. #7
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: kill not working

    Hello!

    Did you upgrade or do a fresh installation?

  8. #8
    Join Date
    Dec 2007
    Beans
    370

    Re: kill not working

    Quote Originally Posted by QIII View Post
    Hello!

    Did you upgrade or do a fresh installation?
    I did an upgrade.... Please don't tell me I need to do a fresh install... I have way too many programs and settings to redo everything!

  9. #9
    Join Date
    Dec 2007
    Beans
    370

    Re: kill not working

    Can I ask why I should have done a fresh install instead of an upgrade? If Ubuntu works correctly, shouldn't an upgrade work just fine?

  10. #10
    Join Date
    Aug 2009
    Location
    Makati City, Philippines
    Beans
    1,137
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kill not working

    I don't know why, but I'm not lucky on performing in-place distro upgrades. I usually update from one version to another by reinstalling the system. It's almost a ritual.
    I think some applications and binaries and settings are very dependent on the current version which can cause some weird errors etc.
    The Philippine Team
    The best Ubuntu derivative: Linux Mint
    Relax. Head to the Community Cafe.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •