Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: unable to install Libreoffice

  1. #1
    Join Date
    Jun 2013
    Beans
    113

    Unhappy unable to install Libreoffice

    Libreoffice is kind of important since I do a lot of writing, but my Ubuntu 12.10 synpatic/apt will not let me install libreoffice. Getting unmet dependency issues, even after I run 'apt-get -f install'
    Any help solving this greatly appreciated; frustrating to get the unmet dependencies issues. Seems like I am caught in unmet dependency hell, Hotel California, no way out.

    Code:
    beowulf@hexacore:~$ sudo apt-get install libreoffice
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     libreoffice : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
                   Depends: libreoffice-writer but it is not going to be installed
                   Depends: libreoffice-calc but it is not going to be installed
                   Depends: libreoffice-impress but it is not going to be installed
                   Depends: libreoffice-draw but it is not going to be installed
                   Depends: libreoffice-math but it is not going to be installed
                   Depends: libreoffice-base but it is not going to be installed
                   Recommends: libreoffice-gnome but it is not going to be installed or
                               libreoffice-kde but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$ sudo apt-get install libreoffice-gnome
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
                         Depends: libreoffice-gtk but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$ sudo apt-get install libreoffice-gtk
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$ sudo apt-get install libreoffice-kde
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     libreoffice-kde : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$ 
    beowulf@hexacore:~$ sudo apt-get install libreoffice-core
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     libreoffice-core : Depends: libexttextcat-1.0-0 (>= 2.2-8) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$
    beowulf@hexacore:~$ sudo apt-get install libexttextcat-1.0-0
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     libexttextcat-1.0-0 : Depends: libexttextcat-data (= 3.3.1-2) but 3.4.0-1~quantal1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    beowulf@hexacore:~$ 
    beowulf@hexacore:~$ sudo apt-get install libexttextcat-data
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libexttextcat-data is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
    beowulf@hexacore:~$

  2. #2
    Join Date
    Sep 2006
    Beans
    7,017
    Distro
    Lubuntu Development Release

    update

    I didn't see a refresh of the package database in your output there. Have you tried an update first?

    Code:
    sudo apt-get update

  3. #3
    Join Date
    Jun 2013
    Beans
    113

    Re: update

    Quote Originally Posted by Lars Noodén View Post
    I didn't see a refresh of the package database in your output there. Have you tried an update first?
    Code:
    sudo apt-get update
    So I thought after doing apt-get updated, apt-get -f install, apt-get dist-upgrade that I successfully installed libreoffice using apt-get install libreoffice-common but then when I try to run libreoffice there is no joy.
    Code:
    $ libreoffice
    /usr/bin/libreoffice: 181: exec: /usr/lib/libreoffice/program/oosplash: not found
    $

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: help needed: i am unable to install Libreoffice

    Why do you need to install libreoffice? 12.10 has it in the default install, unless you are using Lubuntu or Xubuntu, or maybe even Kubuntu (I'm not sure what comes with that).

    I suggest you purge all applications related to libreoffice using synaptic, then enable the ppa for the newer version of LO and try installing that, which should give you LO 4.0.4.2 if not a newer version in 12.10.
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  5. #5
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,165
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: help needed: i am unable to install Libreoffice

    Quote Originally Posted by ajgreeny View Post
    Why do you need to install libreoffice? ....
    +1 to that. I wonder what is meant by "12.10".
    de gustibus et coloribus non est disputandum -- Wiktionary

  6. #6
    Join Date
    Jun 2013
    Beans
    113

    Re: help needed: i am unable to install Libreoffice

    Quote Originally Posted by ajgreeny View Post
    Why do you need to install libreoffice? 12.10 has it in the default install, unless you are using Lubuntu or Xubuntu, or maybe even Kubuntu (I'm not sure what comes with that).

    I suggest you purge all applications related to libreoffice using synaptic, then enable the ppa for the newer version of LO and try installing that, which should give you LO 4.0.4.2 if not a newer version in 12.10.
    I was using ArtistX linux (built on Ubuntu 12.10). I decided to just scrap ArtistX and I just installed Ubuntu 13.04 AMDx64 on my desktop. Was not too painful, preserved /home, preserved my Thunderbird email accounts and Firefox addons and Dropbox and wallpaper, etc. Just had to install a couple of non-synaptic apps (Trelby, FadeIn Pro).

    So now I have Libreoffice!

  7. #7
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: help needed: i am unable to install Libreoffice

    That is one way to solve it

  8. #8
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,165
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: help needed: i am unable to install Libreoffice

    Quote Originally Posted by Coder88 View Post
    I was using ArtistX linux (built on Ubuntu 12.10). I decided to just scrap ArtistX and I just installed Ubuntu 13.04 AMDx64 on my desktop. Was not too painful, preserved /home, preserved my Thunderbird email accounts and Firefox addons and Dropbox and wallpaper, etc. Just had to install a couple of non-synaptic apps (Trelby, FadeIn Pro).

    So now I have Libreoffice!
    This is the second time you haven't clearly stated the distro you've been using. Next time, please be clear. People will still try to help but it will be easier for all concerned.
    de gustibus et coloribus non est disputandum -- Wiktionary

  9. #9
    Join Date
    Jun 2013
    Beans
    113

    Re: help needed: i am unable to install Libreoffice

    Quote Originally Posted by vasa1 View Post
    This is the second time you haven't clearly stated the distro you've been using. Next time, please be clear. People will still try to help but it will be easier for all concerned.
    Well I did start out this thread saying "Libreoffice is kind of important since I do a lot of writing, but my Ubuntu 12.10 synpatic/apt will not let me install libreoffice." because ArtistX is built on Ubuntu, and when I clicked 'About this Computer' it said Ubuntu 12.10 and ArtistX is not available as a distro prefix here on the forums. Regardless, I now have 'pure' Ubuntu 13.04 installed on my desktop.

  10. #10
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: help needed: i am unable to install Libreoffice

    Quote Originally Posted by Coder88 View Post
    ArtistX is built on Ubuntu,
    It may be built on Ubuntu but, as you have discovered, distros built on Ubuntu sometimes do things that the parent Ubuntu does not - hence the need to be clear in your OP about what you are running. Good luck with using real Ubuntu 13.04, but in future if you need help with one of the derivative distros, please use the Other OS/Distro support forum here:

    http://ubuntuforums.org/forumdisplay.php?f=401

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •