Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: [Temporary solved] Asus X201E wifi Fn+F2 toogle doesn't work

  1. #1
    Join Date
    Sep 2013
    Beans
    12

    [Temporary solved] Asus X201E wifi Fn+F2 toogle doesn't work

    Hi,

    I've just install Ubuntu 13.04 in dual boot beside W8 on a Asus X201E netbook.
    I noticed that the wifi Fn+F2 toogle doesn't work.
    The wifi is always active and I can't switch it off.
    The wifi led is off even if wifi connection is on.
    I looked on the net and it seem's to be an old bug with asus laptop.

    Notes : I installed yesterday 3.11 kernel but it has not solved the issue.
    It is fine with W8.

    Any workaround ?
    Last edited by dupont2; September 13th, 2013 at 12:14 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,961
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Perhaps there is a workaround. Please open a terminal and run and post:
    Code:
    rfkill list all
    lsmod | grep asus
    lspci -nn | grep 0280
    The pipe symbol | is on the right side of my US keyboard on the same key with \.

    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Sep 2013
    Beans
    12

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Hi Chili 555, This is what I get,

    Code:
    rfkill list all
    0: asus-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Code:
    lsmod | grep asus
    asus_nb_wmi            16990  0 
    asus_wmi               24794  1 asus_nb_wmi
    sparse_keymap          13890  1 asus_wmi
    wmi                    19256  1 asus_wmi
    video                  19574  2 i915,asus_wmi
    Code:
    lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Last edited by dupont2; September 10th, 2013 at 06:57 PM.

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Welcome to the forums dupont2 !

    You might wish to use 'Code' tags instead of 'Quote' tags for posting command outputs. It preserves the formatting of the output, thus making it more readable.

    Please follow the "Using Code tags" link in my signature below to see how to use it. You may then wish to edit your above post to change the tags.

    PS:
    As mentioned in this thread : http://ubuntuforums.org/showthread.php?t=2172434 , does your wifi get enabled if you send the laptop to sleep, then wake it up again? Just confirming, can't dare to step over Dr. Chili's approaches
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  5. #5
    Join Date
    Sep 2013
    Beans
    12

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Quote Originally Posted by varunendra View Post
    Welcome to the forums dupont2 !

    PS:
    As mentioned in this thread : http://ubuntuforums.org/showthread.php?t=2172434 , does your wifi get enabled if you send the laptop to sleep, then wake it up again? Just confirming, can't dare to step over Dr. Chili's approaches
    Thanks Varunendra,

    Wifi is always enable even after waking up.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,961
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Oh, boy! New, unknown problems! We are pioneers! I love it!

    I notice this module is loaded:
    lsmod | grep asus
    asus_nb_wmi 16990 0
    asus_wmi 24794 1 asus_nb_wmi
    sparse_keymap 13890 1 asus_wmi
    wmi 19256 1 asus_wmi
    video 19574 2 i915,asus_wmi
    modinfo for that module says:
    Code:
    $ modinfo asus_nb_wmi
    filename:       /lib/modules/3.11.0-4-generic/kernel/drivers/platform/x86/asus-nb-wmi.ko
    alias:          wmi:0B3CBB35-E3C2-45ED-91C2-4C5A6D195D1C
    license:        GPL
    description:    Asus Notebooks WMI Hotkey Driver
    author:         Corentin Chary <corentin.chary@gmail.com>
    srcversion:     67514DF02FC4A206C47D0F5
    depends:        asus-wmi
    intree:         Y
    vermagic:       3.11.0-4-generic SMP mod_unload modversions 686 
    parm:           wapf:WAPF value (uint)
    And the C code says:
    43 /*
    44 * WAPF defines the behavior of the Fn+Fx wlan key
    45 * The significance of values is yet to be found, but
    46 * most of the time:
    47 * Bit | Bluetooth | WLAN
    48 * 0 | Hardware | Hardware
    49 * 1 | Hardware | Software
    50 * 4 | Software | Software
    51 */
    Wow! Just what we are looking for, hopefully. Let's see what we can do. Please open a terminal and do:
    Code:
    sudo -i
    echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
    exit
    Since the writers of the C code are not sure the exact correct value, we will have to experiment a bit. Now do:
    Code:
    sudo modprobe -rf asus-wmi
    sudo modprobe -rf asus-nb-wmi
    sudo modprobe asus-nb-wmi
    Any improvement? If not, we'll try another value for wapf.
    Last edited by chili555; February 13th, 2014 at 08:36 PM. Reason: typo
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Sep 2013
    Beans
    12

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Hi Chili555, It says :

    Code:
    fred@fred-X201EP:~$ sudo -i
    [sudo] password for fred: 
    root@fred-X201EP:~# echo "options asus_nb_wmi wapf=0" > /etcmodprobe.d/asus.conf
    -bash: /etcmodprobe.d/asus.conf: Aucun fichier ou dossier de ce type
    root@fred-X201EP:~#

    Aucun fichier ou dossier de ce type
    in French which means not such file found.

    You forgot the / after etc =>
    Code:
    echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
    Code:
    root@fred-X201EP:~# echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
    root@fred-X201EP:~# exit
    déconnexion
    fred@fred-X201EP:~$ sudo modprobe -rf asus-wmi
    [sudo] password for fred: 
    FATAL: Module asus_wmi is in use.
    fred@fred-X201EP:~$ ^C
    Fatal, so I stopped here.
    Last edited by dupont2; September 11th, 2013 at 06:58 PM.

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Quote Originally Posted by dupont2 View Post
    Code:
    root@fred-X201EP:~# echo "options asus_nb_wmi wapf=0" > /etcmodprobe.d/asus.conf
    ...in French which means not such file found.
    Because there is a minor typo in the command. It is /etc/modprobe.d. Please correct to that and try again -
    Code:
    echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
    EDIT:
    So you already got it before I could post and take the credit
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  9. #9
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    You should post the updates in new posts, otherwise people can't notice there is an update, and thus may not reply (I revisited for another reason and noticed your 2nd update) -
    Quote Originally Posted by dupont2 View Post
    Code:
    fred@fred-X201EP:~$ sudo modprobe -rf asus-wmi
    [sudo] password for fred: 
    FATAL: Module asus_wmi is in use.
    fred@fred-X201EP:~$ ^C
    Fatal, so I stopped here.
    ..because asus-wmi is being used by asun-nb-wmi. Just go ahead with the second command
    Code:
    sudo modprobe -rfv asus-nb-wmi
    sudo modprobe -v asus-nb-wmi
    (I added -v just out of habit. It makes the command verbose, so you can see what is happening in the background)

    It will automatically remove-reload asus-wmi as well, since it is a dependency. Go ahead and let us know if there's a progress. I'm just filling in until dr.chilli comes back.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  10. #10
    Join Date
    Sep 2013
    Beans
    12

    Re: Asus X201E wifi Fn+F2 toogle doesn't work

    Varunenedra,

    the result,

    Code:
    fred@fred-X201EP:~$ sudo modprobe -rfv asus-nb-wmi
    [sudo] password for fred: 
    rmmod asus_nb_wmi
    rmmod asus_wmi
    rmmod wmi
    rmmod sparse_keymap
    fred@fred-X201EP:~$ sudo modprobe -v asus-nb-wmi
    insmod /lib/modules/3.11.0-031100-generic/kernel/drivers/platform/x86/wmi.ko 
    insmod /lib/modules/3.11.0-031100-generic/kernel/drivers/input/sparse-keymap.ko 
    insmod /lib/modules/3.11.0-031100-generic/kernel/drivers/platform/x86/asus-wmi.ko 
    insmod /lib/modules/3.11.0-031100-generic/kernel/drivers/platform/x86/asus-nb-wmi.ko wapf=0 
    fred@fred-X201EP:~$

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •