Results 1 to 9 of 9

Thread: Key functions mysteriously switched

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Beans
    5

    Exclamation Key functions mysteriously switched

    The " and @ keys on my Dell laptop have mysteriously switched functions. They continue to work as before for the number 2 and single quotation mark, but the double quotation mark and @ functions have been switched. Also, the hash key, though still a functioning number 3, gives me a £ sign instead of a hash sign. I suspect it's a hardware problem, but I can't be sure of this. Any help would be much appreciated. Thanks in advance.

  2. #2
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,051

    Re: Key functions mysteriously switched

    Welcome to the Ubuntu Forums

    I suspect you have another keyboard setting (for example another language). What is the output of the following command in a terminal window?

    Code:
    setxkbmap -print

  3. #3
    Join Date
    Sep 2013
    Beans
    5

    Re: Key functions mysteriously switched

    The output is

    xkb_keymap {
    xkb_keycodes { include "evdev+aliases(qwerty)" };
    xkb_types { include "complete" };
    xkb_compat { include "complete" };
    xkb_symbols { include "pc+gb+inet(evdev)" };
    xkb_geometry { include "pc(pc105)" };
    };

    I'm a newbie, so I have absolutely no idea what this means.

  4. #4
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Key functions mysteriously switched

    What you describe sounds like the UK layout. In UK keyboards, " is shift-2, @ is shift-', £ is shift-3, and # is just to the left of the return key.

    Which desktop are you using? If Unity, see what your default is in System settings -> Keyboard layout.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  5. #5
    Join Date
    Sep 2013
    Beans
    5

    Re: Key functions mysteriously switched

    Quote Originally Posted by coffeecat View Post
    What you describe sounds like the UK layout. In UK keyboards, " is shift-2, @ is shift-', £ is shift-3, and # is just to the left of the return key.

    Which desktop are you using? If Unity, see what your default is in System settings -> Keyboard layout.
    I checked -- my default is indeed English (UK). However, I have no idea how this switch happened (I am assuming I had the US layout earlier). Strange!

  6. #6
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,051

    Re: Key functions mysteriously switched

    You can change back to US English keyboard with
    Code:
    setxkbmap us
    in a terminal window.

  7. #7
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Key functions mysteriously switched

    Or if you prefer the GUI, simply System Settings -> Keyboard Layout and change the default to whichever layout you wish.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  8. #8
    Join Date
    Sep 2013
    Beans
    5

    Re: Key functions mysteriously switched

    Quote Originally Posted by coffeecat View Post
    Or if you prefer the GUI, simply System Settings -> Keyboard Layout and change the default to whichever layout you wish.
    Thank you! Phew, I was a bit worried initially, but a simple enough solution!

  9. #9
    Join Date
    Sep 2013
    Beans
    5

    Re: Key functions mysteriously switched

    Quote Originally Posted by sudodus View Post
    You can change back to US English keyboard with
    Code:
    setxkbmap us
    in a terminal window.
    Worked. Thanks a lot!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •