Results 1 to 3 of 3

Thread: Lenovo S10 netbook 13.04 blank video issue (Intel 945GMS Express). 12.04 LTS works.

  1. #1
    Join Date
    Sep 2013
    Beans
    1

    Lenovo S10 netbook 13.04 blank video issue (Intel 945GMS Express). 12.04 LTS works.

    Hello there,

    I am having difficulties getting Ubuntu 13.04 to work with my 6-years old Lenovo S10 netbook. LiveCD worked well, if I do a lspci -k, I can see the i195 module was loaded automatically. But after I installed to HDD, I was greeted with a blank screen after the grub loader and after the HDD led stopped blinking (should be at the login screen now). Backlight was on, so it was not pitch black on the screen.

    I did some research and tried different kernel options. The one that works is "nomodeset" - this guarantees a working login and desktop, but using a funny resolution (native resolution is 1024x600) and 0.0 Hz refresh rate.

    Also tried to set kernel option "i915 modeset=1", this gave me about 40% success rate.... I have to pray for a good boot each time, which is really annoying (have to hard-shutdown if I see blank screen). But if this worked, everything (resolution and refresh rate, etc) works well as it should be.

    Then I tried to use 12.04 LTS and it just worked every time without me hacking anything...

    I suspect the it might be a kernel issue, but if you have any insight into this please let me know!

    Thanks for your help.

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    9,267
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Lenovo S10 netbook 13.04 blank video issue (Intel 945GMS Express). 12.04 LTS work

    Hi, welcome to the fora.

    How does it work in a fresh install of the development version (13.10)?
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  3. #3
    Join Date
    Jan 2013
    Beans
    12

    Re: Lenovo S10 netbook 13.04 blank video issue (Intel 945GMS Express). 12.04 LTS work

    Do you already fixed your Problem?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •