Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: shared-folders hangup in VBox installation of 13.10 beta1

  1. #11
    Join Date
    Apr 2005
    Location
    Boston MA
    Beans
    14
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    Quote Originally Posted by Morbius1 View Post
    May I ask why you are mounting something with a "sudo mount -t vboxsf [sharename] [mountpoint]" when it's already mounted for you at /media/sf_sharename.
    Uh -- it isn't. I believe that happens only when one requests 'auto-mount' for a shared folder. I don't usually do that.

    I just now tried configuring it that way, to see whether it makes any difference in the behavior I'm reporting.

    It doesn't.

  2. #12
    Join Date
    Oct 2005
    Beans
    15

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    I am seeing the same issue. Can mount the shared folder but not able to list anything in there as root or my own user. And I am part of the vboxsf group.
    # df -h | grep DATA
    DATA 239G 226G 13G 95% /media/sf_DATA

    And yes we all understand it's beta and not supposed to work. Just reporting it so we can help get ahead of the problem before released.

  3. #13
    Join Date
    Oct 2005
    Beans
    15

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    Update: I can actually see and even copy a single file. So the problem is related to expanding the list of files / dirs. Be carefull leaving your system trying to access that shared folder, I think its in a loop at that stage and may affect performance.

    $ ls -lh /media/sf_DATA/dell_warranty.py
    -rwxrwx--- 1 root vboxsf 1.6K May 21 08:06 /media/sf_DATA/dell_warranty.py

  4. #14
    Join Date
    Mar 2005
    Location
    Christchurch, England
    Beans
    153
    Distro
    Ubuntu Development Release

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    I agree rooijan. I have kubuntu 13.10 b1 installed on virtualbox 4.2.18 r88780 on my iMac.
    I can set up a shared folder, and it auto mounts, but I can't list files or folders inside a folder. I can 'ls' a single file, as long as I give ls the full path.
    I noticed the automount sets gid=1001 (an unknown group), whereas my user has gid=1000.
    I have tried a manual mount at /mnt/share, using gid=1000. No different.
    The same shared folder works well from Arch, also running in another virtual image on the same machine, but not simultaneously. This implies the mac side of things is OK.
    One of us should report this bug. It could be for virtualbox or for ubuntu, but also the 3.11 kernel was just introduced, so...?
    Do you know how this bug should be raised?
    Windows is cheap, but linux is free

  5. #15
    Join Date
    May 2008
    Beans
    1

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    Same issue here with Ubuntu 13.10b1 guest on osx, VBOX 4.2.18r88780, I'm going to try with a 12.04 guest and report back.

  6. #16
    Join Date
    Apr 2011
    Beans
    8

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    I can confirm that this issue happens with Lubuntu 13.10 but works correctly with Lubuntu 13.04 both with VirtualBox 4.2.18

    is there a bug report on this ?

    I'm a noob when it comes to linux, so I'm probably not the best person to report this.

    it appears that this may be related to VirtualBox, see the link below

    https://forums.virtualbox.org/viewto...267725#p267725

    it appears to be fixed with virtualbox 4.3 beta3
    Last edited by chaat; October 3rd, 2013 at 12:14 AM. Reason: found additional information

  7. #17
    Join Date
    Oct 2005
    Beans
    15

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    As people mentioned its a bug for the 3.11 kernels. If you absolutely can't wait for virtualbox to be patched you can try temporarily fixing it by updating dirops.c source and recompiling. I saw the patch here https://www.virtualbox.org/changeset/48529/vbox

    root@rrosso-VirtualBox:/opt/VBoxGuestAdditions-4.2.18/src/vboxguest-4.2.18/vboxsf# diff dirops.c dirops.c.orig
    285,289c285
    < if (!dir_emit(ctx, d_name, strlen(d_name), fake_ino, DT_UNKNOWN))
    < {
    < LogFunc(("dir_emit failed\n"));
    < return 0;
    < }
    ---
    > err = dir_emit(ctx, d_name, strlen(d_name), fake_ino, DT_UNKNOWN);
    291a288
    > #endif
    299c296
    < #endif
    ---
    >

    root@rrosso-VirtualBox:~# /etc/init.d/vboxadd setup
    ...
    Removing existing VirtualBox non-DKMS kernel modules ...done.
    Building the VirtualBox Guest Additions kernel modules ...done.
    Doing non-kernel setup of the Guest Additions ...done.
    You should restart your guest to make sure the new modules are actually used

  8. #18
    Join Date
    Mar 2005
    Location
    Christchurch, England
    Beans
    153
    Distro
    Ubuntu Development Release

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    If you happen to be using Arch the problem has been fixed already in the rolling update of virtualbox_guest_modules_4.2.18-4.
    Windows is cheap, but linux is free

  9. #19
    Join Date
    Oct 2013
    Beans
    2

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    Virtualbox 4.3 is out, which resolves this issue on Ubuntu 13.10. "Check for updates" doesn't indicate 4.3 available, but grab it from the downloads page.

  10. #20
    Join Date
    Oct 2013
    Beans
    1

    Re: shared-folders hangup in VBox installation of 13.10 beta1

    what DbhTPnx said. New Virtualbox 4.3 fixes it

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •