Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Ratel wireless issue

  1. #1
    Join Date
    Sep 2013
    Beans
    9

    Ratel wireless issue

    I've had a System76 Ratel box for most of the year now and it's worked as expected. When updates are available I'll download them. A few weeks ago I began to start having issues with my wireless. Sometimes it will perform as expected for a few hours at a time. Other times it will begin to slow greatly or stop working outright. Disconnecting and reconnecting the wireless connection to my router doesn't seem to really help. I haven't been able to notice any patterns or certain circumstances that exacerbate the connection degradation and loss. Last weekend I figured perhaps it was something that had been fixed with 13.04. So I upgraded. No dice.

    A few more things. I've tried to use a Belkin N300 USB WiFi Adapter. It was overall more slow, and still exhibited the connection degradation/loss issues. When plugged directly into my router the internet is fast as expected, with no performance drop off. So I'm thinking it's not the hardware per se, but still a wireless issue. I've also attached the output of lscpi, but the network controller is the Intel Advanced-N 6235 rev24.

    Thanks for the help,
    K
    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: Ratel wireless issue

    The fact that it's happening with two unrelated cards leads me to suspect a problem with the router. Have you tried unplugging it for a few minutes, then plugging it back in.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  3. #3
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ratel wireless issue

    Welcome to the forums kevin21 !
    Quote Originally Posted by kevin21 View Post
    Disconnecting and reconnecting the wireless connection to my router doesn't seem to really help.
    Does removing and reloading the driver with a parameter help? -
    Code:
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi swcrypto=1
    (don't reboot after above, it is a temporary change that will be lost at next boot)

    If it returns any errors, please post the output of -
    Code:
    lsmod | grep iwlwifi
    Make sure the USB adapter is not plugged in when you try above (better reboot before trying above if you had it plugged in the current session). The presence of two wireless adapters at the same time may confuse network manager.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  4. #4
    Join Date
    Sep 2013
    Beans
    9

    Re: Ratel wireless issue

    Isantop, I have tried that. I've also replaced the router (I was due for an upgrade). I have not experienced these type of issues on other devices connected to the router. Thank you for the feedback though.

  5. #5
    Join Date
    Sep 2013
    Beans
    9

    Re: Ratel wireless issue

    Varun, I will try this the next time I experience the issue, and will post back the results. Thank you.

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ratel wireless issue

    So did it start to drop with the changing of router or before it?

    Please follow the "Wireless Script" link in my signature, download and run the script as instructed in the linked post and post back the report generated by the script. Thanks.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  7. #7
    Join Date
    Sep 2013
    Beans
    9

    Re: Ratel wireless issue

    Quote Originally Posted by varunendra View Post
    So did it start to drop with the changing of router or before it?

    Please follow the "Wireless Script" link in my signature, download and run the script as instructed in the linked post and post back the report generated by the script. Thanks.
    Varun, the dropping had occurred before I got the new router.

    Also, I was unable to successfully run the command
    sudo modprobe -rfv iwlwifi
    When I tried I received the output "FATAL: Module iwlwifi is in use." I tried to run this both when connected and disconnected from my wifi.

    Also attached is the output from the wireless script. Well a zip of it, as the tarball isn't a valid file format o_O

    Thanks,
    Kevin
    Attached Files Attached Files

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ratel wireless issue

    Quote Originally Posted by kevin21 View Post
    Also, I was unable to successfully run the command
    sudo modprobe -rfv iwlwifi
    Obviously, since it was in use by "iwldvm" - the name I forgot when making the original post (hence the hint about "if it returns any errors"). So the correct way to remove - reload it would be -
    Code:
    sudo modprobe -rfv iwldvm
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    sudo modprobe -v iwldvm
    You won't need the 2nd and 3rd commands if iwlwifi is a dependency of iwldvm (which it apparently is, but I'm not sure). If it is, the 2nd one may return error which you can safely ignore (thus the above sequence will work in all cases).

    Anyway, if loading with the "swcrypto=1" parameter alone doesn't help, you can also try a compromising parameter - "11n_disable=1". That is -
    Code:
    sudo modprobe -v iwlwifi swcrypto=1 11n_disable=1
    This new parameter will disable the N channel, thus a compromise with speed. But better than nothing.

    One more thing you may try (not all cards support it) is increasing Tx power on the card -
    Code:
    sudo iwconfig wlan0 txpower 20
    Then run "iwconfig" again to check if the value sticks (currently it is 15 dBm).

    However, given the nature of the problem (initially good, slowing down after some time), I am most hopeful with the "swcrypto=1" parameter.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  9. #9
    Join Date
    Sep 2013
    Beans
    9

    Re: Ratel wireless issue

    Varun,

    It seems as if you have helped me solve the issue. iwlwifi does seem to be a dependency of iwldvm. That is, attempting to reload iwlwifi doesn't work. What I've ended up running is just the two lines
    Code:
    sudo modprobe -rfv iwldvm
    sudo modprobe -v iwldvm
    Doing so has left my internet working all day once again. Sorry I didn't respond right away, but I didn't want to jump the gun in declaring it fixed.

    Would you advise me running this and setting swcrypto to 1, or should I just leave that be? Also is there a proper way to reload this module on startup?

    And lastly, mostly just out of curiosity, why do you think it's not loading correctly initially?

    Thank you very much,
    Kevin

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,178
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ratel wireless issue

    Quote Originally Posted by kevin21 View Post
    What I've ended up running is just the two lines
    Code:
    sudo modprobe -rfv iwldvm
    sudo modprobe -v iwldvm
    Great job !! Congratulations on learning your way around.

    Would you advise me running this and setting swcrypto to 1, or should I just leave that be? Also is there a proper way to reload this module on startup?
    If it worked all day long without the parameter, you may leave it at defaults. If the parameter was used and/or seems to help, make it permanent by creating a conf file for it -
    Code:
    echo "options iwlwifi swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    I'd suggest you create this file anyway and reboot to see if it helps connecting automatically. If not, either we may try to dig deeper to find out the reason (currently, I have no idea, only some baseless guesses), or we can try a workaround, like adding a code snippet to startup script to unload the module, then reload it some time after startup.

    For example, to make it load after a certain delay (say 30 seconds after startup), open your /etc/rc.local file with root access -
    Code:
    gksu gedit /etc/rc.local
    Then add the following line just above the last line "exit 0" :
    Code:
    modprobe -rf iwldvm && sleep 30 && modprobe iwldvm
    The first part will remove the driver as soon as the script is executed, the second part (after "&&") will make it wait for 30 seconds, the last part (after 2nd "&&") will load it again. Since this script (/etc/rc.local) is run as root, you don't need to add "sudo" before the commands. You can change the value of sleep from 30 to anything that suits you best.

    And lastly, mostly just out of curiosity, why do you think it's not loading correctly initially?
    Like I said above, I currently have no idea. If you are interested in finding out (and hopefully avoid the above workaround), please run a different version of wireless_script and post back its output : http://dl.dropboxusercontent.com/s/q...ireless_script

    If even the extended parts in the above script don't give any hints, we may need more outputs, logs to look at. It's up to you how much you are interested in knowing the reason and how far you are willing to go to find it. For me, this would be fun trip, but be forewarned, my success rate in unknown areas is very little.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •