This computer I got recently can only seem to handle up to Ubuntu version 11.10 (it was super cheap and the hard drive isn't recognized) and therefore I cannot install the Steam (gaming social network) software from the Ubuntu Software Center. WHen I was installing Steam, it told me that it depended on a newer version of libc6 and curl. I was able to easily install curl, but when I tried installing a newer version of libc6, I got this:

Code:
(Reading database ... 154106 files and directories currently installed.)
Preparing to replace libc6 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: dependency problems prevent configuration of libc6:
 libc6 depends on libc-bin (= 2.15-0ubuntu10.2); however:
  Version of libc-bin on system is 2.13-20ubuntu5.3.
dpkg: error processing libc6 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6
So, it needs itself to install itself...what do I do?