Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Synaptic / apt-get broken packages problem (?)

  1. #11
    Join Date
    Aug 2013
    Beans
    11

    Re: Synaptic / apt-get broken packages problem (?)

    Hello:

    Thanks for your input.

    ... but both apt-get and synaptic report 0 broken packages.
    You read right.
    The thing is that SPM lists 1683 in the 'Broken' filter screen.
    Should be none listed there. (?) (see the screenshot)

    ... may be just an error in the number of packages listed in the broken filter ...
    Could be.

    The thing is that after a complete removal of SPM and reinstallation, the list survived.
    Shouldn't it have been done away with?

    ... left overs from your upgrade. Just a guess.
    Could be ...

    But then it could be something else.
    Re:

    What I did find interesting/strange was that in the course of removing SPM (using SPM, of course) I noticed that the number of packages listed by SPM as 'broken' was suddenly reduced to five or six packages. The application dissapeared from screen as I intended to delve further.
    Makes me wonder ...

    Cheers,

    CIV

  2. #12
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Synaptic / apt-get broken packages problem (?)

    Yes, I agree it looks curious. Have you tried the housekeeping (clean & autoremove) ?
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  3. #13
    Join Date
    Aug 2013
    Beans
    31

    Re: Synaptic / apt-get broken packages problem (?)

    as above, or Synaptic does a great job of fixing broken packages

  4. #14
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Synaptic / apt-get broken packages problem (?)

    OK, something close to what I was looking for. Maybe some config file :
    http://ubuntuforums.org/showthread.php?t=1976309
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  5. #15
    Join Date
    Aug 2013
    Beans
    11

    Re: Synaptic / apt-get broken packages problem (?)

    Hello:

    Thanks for your input.

    Have you tried the housekeeping (clean & autoremove) ?
    Yes, I did.
    There was nothing to clean or remove.

    Still looking ...

    Cheers,

    CIV

  6. #16
    Join Date
    Aug 2013
    Beans
    11

    Re: Synaptic / apt-get broken packages problem (?)

    Hello:

    OK, something close to what I was looking for. Maybe some config file :
    I'll check it out and post when I get back home.

    Thanks for the link. =-)

    Cheers,

    CIV

  7. #17
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Synaptic / apt-get broken packages problem (?)

    Sure, it may not be that exact config file, but one in the same folder.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  8. #18
    Join Date
    Aug 2013
    Beans
    11

    Thumbs up Re: Synaptic / apt-get broken packages problem (?)

    Good morning:

    First of all, thanks a lot to all who replied.
    Second, good news: it was much ado about nothing.

    So, just 'why' did the 'broken' filter list 1683 packages files while at the same time telling me that there were no broken files?
    And with 1683 being the exact number of 'installed' files?

    Well ...
    The answer is quite simple: because it SPM was configured to do exactly that.

    Settings --> Filters --> Broken --> Current had the 'Installed' box ticked.

    I'm sure it is not a default setting and since I'm the only one playing with it, the 'reason' for the box being ticked is quite evident. =-/

    So ...
    SPM works as intended and this was intended behaviour.

    Cheers,

    CIV

  9. #19
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Synaptic / apt-get broken packages problem (?)

    Oh cool, I was kind of scratching my head to be honest. Did not think about that, thanks
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •