Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: Take ownership of a drive

  1. #1
    Join Date
    Jul 2009
    Beans
    471

    Take ownership of a drive

    Using Ubuntu 13.04

    I have an internal hard drive that when i click permissions, it says ROOT. I am trying to change ownership so that they show up in Plex. i have tried "chown -R tim /media/tim/Media" (this is the name of the drive), and it just wont change.
    Also, i have another drive, and the permissions say "Owner: Me" "Group: Tim" access says none. I click the dropdown arrow to change where it says NONE, i can choose an option, but the second i click one, it goes right back to none. Any suggestions?

    sudo blkid
    Code:
    /dev/sdb: LABEL="Miscellaneous" UUID="10a6fa16-fdbc-40cd-8759-d8d22094d250" TYPE="ext4" 
    /dev/sda1: LABEL="Media" UUID="F2ACF216ACF1D557" TYPE="ntfs" 
    /dev/sdc1: LABEL="500gb" UUID="0CBE3F0CBE3EEE38" TYPE="ntfs" 
    /dev/sdd1: LABEL="Movies" UUID="86CEFEB2CEFE9A1F" TYPE="ntfs" 
    /dev/sde1: UUID="caf7e20c-a0ed-46aa-a264-a7611c34a711" TYPE="ext4" 
    /dev/sde5: UUID="b0eae91a-301f-4f28-b770-1dd2705f75df" TYPE="swap" 
    /dev/sdf1: LABEL="Backup" UUID="c00e434f-d2fa-4f72-a74e-7bed424b3188" TYPE="ext4" 
    /dev/sr1: LABEL="Utility_HD-CXU2" TYPE="iso9660" 
    /dev/sdg1: LABEL="Buffalo 1.5tb" UUID="A8508E6E508E4354" TYPE="ntfs" 
    /dev/sdm1: LABEL="Buffalo 3.0" UUID="7955F50022718F29" TYPE="ntfs" 
    /dev/sr2: LABEL="HPLAUNCHER" TYPE="iso9660" 
    /dev/sdn1: LABEL="HP SimpleSave" UUID="7C5632EA5632A534" TYPE="ntfs" 
    /dev/sdo1: LABEL="NewVolume" UUID="0E48C80248C7E715" TYPE="ntfs"
    please let me know if you need further info.
    PC Specs: Asus P6X58D Premium - Intel Core i7 930 - XFX Radeon 5750 HD Video Card - 12gb DDR3 Corsair XMS3 - (internal)750gb WD 6.0gbps - 1tb WD Green Caviar - NZXT Tempest Case - Dell 24" 1080p HD Monitor - Dell Stereo Soundbar.

  2. #2
    squakie is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Take ownership of a drive

    I'm probably wrong, but here goes:

    What you are seeing is not just a disk, it's the file system on that disk. It is actually the file systems that get mounted. As far as I know, ALL file systems are owned by root. There is something you can do, but I don't know if it will help you or not:

    • create a new folder, such as /home/mydisk
    • sudo chmod xxx /home/mydisk, where "xxx" is one of the access settings such as 777 for everyone to have all access.
    • sudo chown <a userid goes here - perhaps yours?> /home/mydisk
    • now create an entry in fstab to mount your disk to that folder (mount point)


    For your second question, unless you are running as root you will not be able to change permissions on a file/folder with a different owner because you don't own it. You must have super user priviledges to do so. From the command line (terminal) you would use sudo chmod xxx <file or folder name>. To do it from a GUI, you would use the command line and type sudo nautilus. This will open the file manager but with super user priviledges. At this point you could then click to see the permissions and then change them. A VERY BIG CAUTION: be EXTREMELY CAREFUL when using either method. If you do so on any system file you could screw up you linux installation.

    Somebody will correct me if I'm wrong, but that is what I've done in the past.

  3. #3
    Join Date
    Jul 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Take ownership of a drive

    Quote Originally Posted by TimEnid View Post
    Using Ubuntu 13.04

    I have an internal hard drive that when i click permissions, it says ROOT. I am trying to change ownership so that they show up in Plex. i have tried "chown -R tim /media/tim/Media" (this is the name of the drive), and it just wont change.
    Also, i have another drive, and the permissions say "Owner: Me" "Group: Tim" access says none. I click the dropdown arrow to change where it says NONE, i can choose an option, but the second i click one, it goes right back to none. Any suggestions?

    sudo blkid
    Code:
    /dev/sdb: LABEL="Miscellaneous" UUID="10a6fa16-fdbc-40cd-8759-d8d22094d250" TYPE="ext4" 
    /dev/sda1: LABEL="Media" UUID="F2ACF216ACF1D557" TYPE="ntfs" 
    /dev/sdc1: LABEL="500gb" UUID="0CBE3F0CBE3EEE38" TYPE="ntfs" 
    /dev/sdd1: LABEL="Movies" UUID="86CEFEB2CEFE9A1F" TYPE="ntfs" 
    /dev/sde1: UUID="caf7e20c-a0ed-46aa-a264-a7611c34a711" TYPE="ext4" 
    /dev/sde5: UUID="b0eae91a-301f-4f28-b770-1dd2705f75df" TYPE="swap" 
    /dev/sdf1: LABEL="Backup" UUID="c00e434f-d2fa-4f72-a74e-7bed424b3188" TYPE="ext4" 
    /dev/sr1: LABEL="Utility_HD-CXU2" TYPE="iso9660" 
    /dev/sdg1: LABEL="Buffalo 1.5tb" UUID="A8508E6E508E4354" TYPE="ntfs" 
    /dev/sdm1: LABEL="Buffalo 3.0" UUID="7955F50022718F29" TYPE="ntfs" 
    /dev/sr2: LABEL="HPLAUNCHER" TYPE="iso9660" 
    /dev/sdn1: LABEL="HP SimpleSave" UUID="7C5632EA5632A534" TYPE="ntfs" 
    /dev/sdo1: LABEL="NewVolume" UUID="0E48C80248C7E715" TYPE="ntfs" 
    please let me know if you need further info.
    If you can't change the ownership (or change permissions) of a partition, mostlikely it is due to that partition's not having a compatible file system (FS) type to the local OS. File system types such as TYPE="ntfs" or TYPE="vfat" are not compatible. These FS do not have a Linux configurable ownership or permissions table (chown, chmod).

    The partitions in red (above) are what I am talking about. The partitions in blue are CD/DVD and are read only and nothing can be changed on them. The NTFS partitions have the ownership set at mount time via a driver (ntfs-3g). This means if you want to mount them as owned by a specific user and group you can do that at mount time. You can't change this once the partition is mounted as the chown, chgrp and chmod tools for ext partitions don't work with NTFS.

    It would be a help to see the specific mounts you are using with /media/tim/Media" and the other drive you have mentioned. Post the output of these 3 terminal commands please
    Code:
    getent passwd tim
    
    mount
    
    df -h
    Quote Originally Posted by squakie
    ... the file systems that get mounted. As far as I know, ALL file systems are owned by root.
    By default only root can mount a partition. This can be overridden when configuring a mount directive in /etc/fstab.

    The root user does not own all file systems by default. The Linux ownership scheme (ext for the present time) is set by the leftmost bit in the scheme. This is the extended bit This bit is to the left of the commonly shown 3 bits (e.g. 755) for the default UID/GID it is set to 0 (e.g. 0755). This scheme uses the logged in user as the owner of the file of folder at creation (UID) and the users primary group to be the group owner (GID). By default Debian and Ubuntu use user private groups (UPG).


    There is something you can do, but I don't know if it will help you or not:

    create a new folder, such as /home/mydisk
    sudo chmod xxx /home/mydisk, where "xxx" is one of the access settings such as 777 for everyone to have all access.
    sudo chown <a userid goes here - perhaps yours?> /home/mydisk
    now create an entry in fstab to mount your disk to that folder (mount point)
    This will not help the OP. In fact, any directory in the system can have a subdirectory that is user readable and writable. It does not have to be under /home. That is what /srv is for. You could create a /srv/data directory and chown and chmod that directory for the user to use. Mounting a partition on that /srv/data directory in no way affects or enhances a users ownership or permissions. These are set at mount time. When you mount ext partitions the ownership and permissions are auto-magically configured.

    For your second question, unless you are running as root you will not be able to change permissions on a file/folder with a different owner because you don't own it. You must have super user priviledges to do so. From the command line (terminal) you would use sudo chmod xxx <file or folder name>. To do it from a GUI, you would use the command line and type sudo nautilus. This will open the file manager but with super user priviledges. At this point you could then click to see the permissions and then change them. A VERY BIG CAUTION: be EXTREMELY CAREFUL when using either method. If you do so on any system file you could screw up you linux installation.

    Somebody will correct me if I'm wrong, but that is what I've done in the past.
    I'll bet you have only used ext formatted partitions to do this. You will not be able to use chmod, chown or chgrp on NTFS and VFAT formatted partitions as I said before. If you read some of the forum posts re: ownership and permissions of USB connected HDD's and USB connected flash drives, you will see this topic covered time and time again.

    Super user (root) or not, you can't change the owner or group for any directory or file on any mounted VFAT or NTFS partition.

  4. #4
    Join Date
    Mar 2008
    Beans
    88
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Take ownership of a drive

    Couldn't he just edit the /etc/fstab and add the uid/gid?
    for example
    `UUID=xxxxxxxxxxx /media/tim/Media ntfs rw,auto,users,uid=1000,gid=1000,permissions 0 2`
    changing the red to the correct values.
    Your first step, learn the command line man intro man man man bash

  5. #5
    squakie is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Take ownership of a drive

    I guess I should have been more specific: of course you can't do this with NTFS; the /home/mydisk was only a sample, not a "rule"; I mount my NTFS partitions to a folder (where ever) and change the permissions on that folder to dictate access along with changes to fstab - that's why I mentioned doing what I did . Sorry I wasn't more specific.

  6. #6
    Join Date
    Jul 2009
    Beans
    471

    Re: Take ownership of a drive

    Code:
    tim@tim:~$ getent passwd tim
    tim:x:1000:1000:tim,,,:/home/tim:/bin/bash
    tim@tim:~$ mount
    /dev/sde1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/cgroup type tmpfs (rw)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    /dev/sdc1 on /media/tim/WD type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sda1 on /media/tim/Home type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    gvfsd-fuse on /run/user/tim/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=tim)
    /dev/sr1 on /media/floppy0 type iso9660 (ro,nosuid,nodev,utf8)
    /dev/sdm1 on /media/tim/Buffalo 3.02 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdg1 on /media/tim/Buffalo 1.5tb1 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdd1 on /media/tim/Movies type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    tim@tim:~$ df  -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sde1       106G   20G   81G  20% /
    none            4.0K     0  4.0K   0% /sys/fs/cgroup
    udev            5.9G  4.0K  5.9G   1% /dev
    tmpfs           1.2G  1.3M  1.2G   1% /run
    none            5.0M     0  5.0M   0% /run/lock
    none            5.9G  676K  5.9G   1% /run/shm
    none            100M   20K  100M   1% /run/user
    /dev/sdc1       466G  261G  206G  56% /media/tim/WD
    /dev/sda1       466G  101G  366G  22% /media/tim/Home
    /dev/sr1        198M  198M     0 100% /media/floppy0
    /dev/sdm1       597G  121G  477G  21% /media/tim/Buffalo 3.02
    /dev/sdg1       1.4T  303G  1.1T  22% /media/tim/Buffalo 1.5tb1
    /dev/sdd1       932G  696G  237G  75% /media/tim/Movies
    PC Specs: Asus P6X58D Premium - Intel Core i7 930 - XFX Radeon 5750 HD Video Card - 12gb DDR3 Corsair XMS3 - (internal)750gb WD 6.0gbps - 1tb WD Green Caviar - NZXT Tempest Case - Dell 24" 1080p HD Monitor - Dell Stereo Soundbar.

  7. #7
    Join Date
    Jul 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Take ownership of a drive

    Quote Originally Posted by TimEnid View Post
    Code:
    tim@tim:~$ getent passwd tim
    tim:x:1000:1000:tim,,,:/home/tim:/bin/bash
    Code:
    tim@tim:~$ mount
    /dev/sde1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/cgroup type tmpfs (rw)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    /dev/sdc1 on /media/tim/WD type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sda1 on /media/tim/Home type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    gvfsd-fuse on /run/user/tim/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=tim)
    /dev/sr1 on /media/floppy0 type iso9660 (ro,nosuid,nodev,utf8)
    /dev/sdm1 on /media/tim/Buffalo 3.02 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdg1 on /media/tim/Buffalo 1.5tb1 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sdd1 on /media/tim/Movies type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    Code:
    tim@tim:~$ df  -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sde1       106G   20G   81G  20% /
    none            4.0K     0  4.0K   0% /sys/fs/cgroup
    udev            5.9G  4.0K  5.9G   1% /dev
    tmpfs           1.2G  1.3M  1.2G   1% /run
    none            5.0M     0  5.0M   0% /run/lock
    none            5.9G  676K  5.9G   1% /run/shm
    none            100M   20K  100M   1% /run/user
    /dev/sdc1       466G  261G  206G  56% /media/tim/WD
    /dev/sda1       466G  101G  366G  22% /media/tim/Home
    /dev/sr1        198M  198M     0 100% /media/floppy0
    /dev/sdm1       597G  121G  477G  21% /media/tim/Buffalo 3.02
    /dev/sdg1       1.4T  303G  1.1T  22% /media/tim/Buffalo 1.5tb1
    /dev/sdd1       932G  696G  237G  75% /media/tim/Movies
    Mounting in /media is usually reserved for media that can be unmounted and removed. In this case most likely using a USB interface. I my guess is that the partitions (e.g. sda1, sdc1, sdm1, sdg1 and sdd1) are auto-mounted and auto detected. Am I correct on this? All the partitions we are talking about are mounted in /meda and they all used fuseblk. The use of fuseblk indicates the auto detection of partition format and guessing NTFS, but not using ntfs-3g as the driver.

    All the mounted partitions have permissions and ownership is set as the default (e.g. (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096). Let's see what the default ownership and permissions really look like. Post the output these commands. Let's do that in separate [code] blocks please.
    Code:
    ls -ld /meda
    
    ls -l /media/tim/WD
    
    ls -l /meda/tim/Home
    
    ls -l /media/tim/"Buffalo 3.02"
    
    ls -l /media/tim/"Buffalo 1.5tb1"
    
    ls -l /meda/tim/Movies
    Note the " " surrounding the 2 Buffalo entries.

    Do you want these partitions to have you as the owner and group ( i.e. tim:x:1000:1000)?

  8. #8
    Join Date
    Jul 2009
    Beans
    471

    Re: Take ownership of a drive

    Quote Originally Posted by redmk2 View Post
    Mounting in /media is usually reserved for media that can be unmounted and removed. In this case most likely using a USB interface. I my guess is that the partitions (e.g. sda1, sdc1, sdm1, sdg1 and sdd1) are auto-mounted and auto detected. Am I correct on this?
    correct


    Quote Originally Posted by redmk2 View Post
    Do you want these partitions to have you as the owner and group ( i.e. tim:1000:1000)?
    Yes


    ls -ld /media
    Code:
    drwxr-xr-x 7 root root 4096 Aug 23 17:54 /media
    ls -l /media/tim/Movies
    Code:
    tim@tim:~$ ls -l /media/tim/Movies
    total 3143604
    -rw------- 1 tim tim 3218972709 Nov 15  2011 11-11-11 (2012).mkv
    drwx------ 1 tim tim      20480 Aug 26 19:40 DVD Movies
    drwx------ 1 tim tim      24576 May 25 20:06 Misc
    drwx------ 1 tim tim      28672 Aug 29 19:07 plexmedialibrary
    drwx------ 1 tim tim          0 May 14  2010 System Volume Information
    ls -l /meda/tim/Home
    Code:
    tim@tim:~$ ls -l /media/tim/Home
    total 304
    drwxrwxrwx 1 root root      0 Feb 19  2013 DCIM
    drwxrwxrwx 1 root root   4096 May 25 20:51 Documents
    drwxrwxrwx 1 root root 294912 Aug 27 19:29 Music
    drwxrwxrwx 1 root root      0 Feb 18  2012 PDF
    drwxrwxrwx 1 root root  12288 Jul 21 20:11 Pictures
    drwxrwxrwx 1 root root      0 Oct  2  2011 $RECYCLE.BIN
    drwxrwxrwx 1 root root      0 May 25 20:02 Videos
    I provided the output for the drive i want to change.
    Thanks
    PC Specs: Asus P6X58D Premium - Intel Core i7 930 - XFX Radeon 5750 HD Video Card - 12gb DDR3 Corsair XMS3 - (internal)750gb WD 6.0gbps - 1tb WD Green Caviar - NZXT Tempest Case - Dell 24" 1080p HD Monitor - Dell Stereo Soundbar.

  9. #9
    Join Date
    Jul 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Take ownership of a drive

    Quote Originally Posted by TimEnid View Post
    ls -ld /media
    Code:
    drwxr-xr-x 7 root root 4096 Aug 23 17:54 /media
    ls -l /media/tim/Movies
    Code:
    tim@tim:~$ ls -l /media/tim/Movies
    total 3143604
    -rw------- 1 tim tim 3218972709 Nov 15  2011 11-11-11 (2012).mkv
    drwx------ 1 tim tim      20480 Aug 26 19:40 DVD Movies
    drwx------ 1 tim tim      24576 May 25 20:06 Misc
    drwx------ 1 tim tim      28672 Aug 29 19:07 plexmedialibrary
    drwx------ 1 tim tim          0 May 14  2010 System Volume Information
    ls -l /meda/tim/Home
    Code:
    tim@tim:~$ ls -l /media/tim/Home
    total 304
    drwxrwxrwx 1 root root      0 Feb 19  2013 DCIM
    drwxrwxrwx 1 root root   4096 May 25 20:51 Documents
    drwxrwxrwx 1 root root 294912 Aug 27 19:29 Music
    drwxrwxrwx 1 root root      0 Feb 18  2012 PDF
    drwxrwxrwx 1 root root  12288 Jul 21 20:11 Pictures
    drwxrwxrwx 1 root root      0 Oct  2  2011 $RECYCLE.BIN
    drwxrwxrwx 1 root root      0 May 25 20:02 Videos
    I provided the output for the drive i want to change.
    Thanks
    You will need to edit the /etc/fstab file as the root user. Let's start with the obvious one ( /media/tim/Home). You can try this line at the bottom of the file
    Code:
    UUID="0E48C80248C7E715" /media/tim/Home ntfs-3g rw,uid=1000,gid=1000,fmask=002,dmask=002	   0      0
    ...This makes the user tim owner with rw permissions for the partition mounted at /media/time/Home.

    Edit: the dmask and fmask have been corrected to 002. See above
    Last edited by redmk2; August 31st, 2013 at 08:52 AM. Reason: Error corrections

  10. #10
    Join Date
    Jul 2009
    Beans
    471

    Re: Take ownership of a drive

    Quote Originally Posted by redmk2 View Post
    You will need to edit the /etc/fstab file as the root user. Let's start with the obvious one ( /media/tim/Home). You can try this line at the bottom of the file
    Code:
    UUID="0E48C80248C7E715" /media/tim/Home ntfs-3g rw,uid=1000,gid=1000,fmask=664,dmask=775       0      0
    ...This makes the user tim owner with rw permissions for the partition mounted at /media/time/Home.
    did that. now fstab reads
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sdd1 during installation
    UUID=caf7e20c-a0ed-46aa-a264-a7611c34a711 /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sdd5 during installation
    UUID=b0eae91a-301f-4f28-b770-1dd2705f75df none            swap    sw              0       0
    /dev/sr1        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    /dev/sdc1 /media/tim/WD ntfs defaults 0 0
    /dev/sda1 /media/tim/Home ntfs defaults 0 0
    UUID="0E48C80248C7E715" /media/tim/Home ntfs-3g rw,uid=1000,gid=1000,fmask=664,dmask=775	   0      0
    also, after typing in sudo gedit /etc/fstab, i get
    Code:
    ** (gedit:3551): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist
    
    
    ** (gedit:3551): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist
    I checked the drive after making that change, and its still the same. Owner: Root - with everything grayed out.
    PC Specs: Asus P6X58D Premium - Intel Core i7 930 - XFX Radeon 5750 HD Video Card - 12gb DDR3 Corsair XMS3 - (internal)750gb WD 6.0gbps - 1tb WD Green Caviar - NZXT Tempest Case - Dell 24" 1080p HD Monitor - Dell Stereo Soundbar.

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •