Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Java working on browsers only

  1. #11
    Join Date
    Jul 2010
    Beans
    101
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Java working on browsers only

    There are like 2233 Java packets available through Synaptic Package Manager.
    Could anyone of them fix my problem? Maybe I'm missing something from this list, but how to find out which one?

  2. #12
    Join Date
    Oct 2011
    Beans
    15

    Re: Java working on browsers only

    it is complaining about that the libjwgl is 32bit and i am suspecting you are on 64bit
    if that is the case then you can
    1. install ia32-libs, openjdk-7-jre:i386 and openjdk-7-jre-headless:i386
    or
    2. rename the bin folder inside $HOME/.minecraft (renaming it so incase it doesnt work you can just rename it back and use option 1 which should work anyway)

    also another issue with java7 (and openjdk7) is that java cant find libjawt.so
    so you have to run java with LD_LIBRARY_PATH=/usr/lib/jvm/"javafolder that is used"/jre/lib/"amd64 for option 2 and i386 for option 1"/ java

    or ofcourse we can go the automatic route and install the wrapper i wrote for java to fix an issue for those that played runescape through the browser and wanted opengl to work but refused to use a client.

    perl source:
    https://dl.dropbox.com/u/11631899/op...r/java-wrapper

    tar.gz download:
    https://dl.dropbox.com/u/11631899/op...wrapper.tar.gz

    usage:
    Code:
    sudo ./java-wrapper -install
    it will then look through your system for all java installs and give you a list of them, you then enter the number for the one you want the wrapper to install inside which will make it rename the java binary to "java-bin" and then make itself take the "java" executables place and forward calls to java-bin with the correct LD_LIBRARY_PATH which it will automatically locate.

    if you want to configure overrides for parameters you can do that through $HOME/.config/java-wrapper/overrides.pm
    here is the default one it creates on first run
    Code:
    package overrides;
    
    # This is a collection of programmable overrides for the java parameters
    # _if_overridename is set to(=>) "value",
    # _set_overridename set it to(=>) "value",
    
    
    # NOTE: you can add any if statements if you follow the method above!
    $overrides = {
    	_if_maxmem => "-Xmx256m",
    	_set_maxmem => "-Xmx512m",
    	_if_stacksize => "-Xss1m",
    	_set_stacksize => "-Xss2m",
    };
    ## END OF OVERRIDES
    
    
    #
    #---------------------------------------- *** ----------------------------------------
    #
    
    
    # Callback, DO NOT TOUCH!
    sub get_overrides
    {
    	return $overrides;
    }
    1;

  3. #13
    Join Date
    Jul 2010
    Beans
    101
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Java working on browsers only

    Quote Originally Posted by HikariKnight View Post
    it is complaining about that the libjwgl is 32bit and i am suspecting you are on 64bit
    if that is the case then you can
    1. install ia32-libs, openjdk-7-jre:i386 and openjdk-7-jre-headless:i386
    1. DONE (before)

    Quote Originally Posted by HikariKnight View Post
    2. rename the bin folder inside $HOME/.minecraft (renaming it so incase it doesnt work you can just rename it back and use option 1 which should work anyway)

    also another issue with java7 (and openjdk7) is that java cant find libjawt.so
    so you have to run java with LD_LIBRARY_PATH=/usr/lib/jvm/"javafolder that is used"/jre/lib/"amd64 for option 2 and i386 for option 1"/ java
    It stops here with a message:
    ~$ java LD_LIBRARY_PATH=/usr/lib/jvm
    Error: Could not find or load main class LD_LIBRARY_PATH=.usr.lib.jvm

  4. #14
    Join Date
    Jul 2010
    Beans
    101
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Java working on browsers only

    How to get rid of all Java versions from Ubuntu (+ ensure that it's all out) and reinstall it correctly to get everything working as it should?
    Could I get step-by-step assistance, please?

  5. #15
    Join Date
    Oct 2011
    Beans
    15

    Re: Java working on browsers only

    no you run it wrong, you need to have the LD_LIBRARY_PATH=/usr/lib/jvm/"java_youre_using_here"/lib/i386 before the java command.
    honestly using the automatic script would be easier as you need to point LD_LIBRARY_PATH to your java native library folder

  6. #16
    Join Date
    Jul 2010
    Beans
    101
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Java working on browsers only

    Quote Originally Posted by HikariKnight View Post
    LD_LIBRARY_PATH=/usr/lib/jvm/"java_youre_using_here"/lib/i386
    Done. It's there, but no improvement.
    Maybe it's because I have amd64 instead of i386?

    Java worked before, so I just need to get previous settings. I have some problems to reset it and I don't know why.

  7. #17
    Join Date
    Oct 2011
    Beans
    15

    Re: Java working on browsers only

    openjdk is installed in

    /usr/lib/jvm/java-6-openjdk-amd64
    /usr/lib/jvm/java-6-openjdk-i386
    /usr/lib/jvm/java-7-openjdk-amd64
    /usr/lib/jvm/java-7-openjdk-i386

    for me if i want opengl i need to run java like this (java7 only though as it works fine by default in java6)

    LD_LIBRARY_PATH=/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/ java

    you can uninstall java with (assuming you used the commands i posted to install 32bit java)

    sudo apt-get purge openjdk-7-jre:i386 openjdk-7-jre-headless:i386

  8. #18
    Join Date
    Jul 2010
    Beans
    101
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Java working on browsers only

    [SOLVED] because another problem forced me to reinstall whole Ubuntu system.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •