I'd like to use a newer version of the AWS EC2 API Tools on an Ubuntu Precise or Raring server.


In particular, I want the relatively new ec2-copy-image command.


Even looking at Saucy multiverse, the version of ec2-api-tools is prior to the March release of ec2-copy-image.


When I remove the packages and install the current AWS tools by hand, I run into some weird problems.


What is the recommended procedure for getting these tools upgraded ?


Thanks


mark