Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: No HDMI Sound

  1. #1
    Join Date
    Apr 2013
    Beans
    262

    No HDMI Sound

    Hello All,
    I have a desktop with two hard drives:
    Drive 1: Windows 7
    Drive 2: Ubuntu 13.04

    Problem: I'm not getting any sound through my HDMI hookup TV, which I use as my monitor. Windows 7 sound works fine.
    Thanks for the help!

    Edit: I just checked my headphone connection, and the sound works fine, just no TV Speaker sound through HDMI hookup
    Last edited by GUZZLR; August 17th, 2013 at 10:06 PM.

  2. #2
    Join Date
    Aug 2013
    Beans
    4

    Re: No HDMI Sound

    I have the exact same problem with Ubuntu 13.04 on a Sony Vaio VPCCW23FD laptop using a GeForce 310m video chip. The NVIDIA 310.xx video driver was enabled, ALSAmixer was executed and the SPDIF modules (all four of them) were unmuted but there's still no sound. In the Sound settings, while the HDMI cable is connected to the TV, only 'Built-In Audio' is available as an option. It seems to completely ignore the possibility of HDMI sound despite the fact that video works fine.

    This is the ONE problem I have left to have a fully-functioning Ubuntu laptop. Any help would be tremendously appreciated.

  3. #3
    Join Date
    Feb 2008
    Beans
    4,428
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No HDMI Sound

    Guzzlr: is HDMI selected in Sound Settings, Output?

  4. #4
    Join Date
    Feb 2008
    Beans
    4,428
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No HDMI Sound

    Andre: do you dual-boot? Does HDMI output work in Windows?

  5. #5
    Join Date
    Apr 2013
    Beans
    262

    Re: No HDMI Sound

    Code:
    Guzzlr: is HDMI selected in Sound Settings, Output?
    In Sound settings, I dont have the HDMI option, only Digital & Analog. I've tried both, and both will work throught the headhone jack (lime green colored one) but no HDMI audio through either.

    Screenshot from 2013-08-18 14:18:13.jpg

  6. #6
    Join Date
    Apr 2013
    Beans
    262

    Re: No HDMI Sound

    I now have sound on HDMI. I downloaded the latest X.org drivers for the newer AMD APU's (which mine is) and I now have an AMD Catalyst Control Center. I have done this before, but the problem is I have very little control inside the control panel because I am not logged in with administrative rights...which I dont know how to do. The other problem is I cant get two screens to work, which I suspect is because I cant get into the AMD control center to acces multiple screens.
    Also, with these drivers installed, I cant no longer upload screenshots to this forum, the upload manager will not allow it.
    Thanks for the help

  7. #7
    Join Date
    Feb 2008
    Beans
    4,428
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No HDMI Sound

    If you can figure out what command starts the Catalyst Control Center, you can start it with administrative rights by entering the command: sudo [catalyst command]

    It's probably: sudo amdcccle

    I suspect this will also let you set up two screens.

    As a comment, when I clicked on the dash in Ubuntu 13.04, and typed "cata," I was given the option to run Catalyst Control Centre with administrative rights. If that did not happen for you, it might not be installed properly.

  8. #8
    Join Date
    Jun 2007
    Beans
    11,619

    Re: No HDMI Sound

    It's probably: sudo amdcccle
    Code:
    gksu amdcccle
    @guzzlr: Can you give more info?
    https://wiki.ubuntu.com/Audio/AlsaInfo
    https://wiki.ubuntu.com/PulseAudio/Log

  9. #9
    Join Date
    Apr 2013
    Beans
    262

    Re: No HDMI Sound

    Code:
    gksu amdcccle,sudo amdcccle, cata
    I've tried all the following codes, and none have worked. when I click on Catalyst Control Center to open, it gives me a small black rectangle box to type the passwords in. I type the passwords, but never see any letters, or the white curser move. After a short time, the white curser jumps to the line below the word "Password" and the log in rectangle dissapears. I do have a smal box in the lower right corner of the screen which states "AMD Unsupported Hardware", so all though AMD says it's supported, in reality it isnt, and AMD has made a mistake.

  10. #10
    Join Date
    Feb 2008
    Beans
    4,428
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No HDMI Sound

    If you enter the command: lspci
    one of the lines of output will include "VGA." Please copy/paste that line here.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •