Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: gnome flashback sessions black screen

  1. #1
    Join Date
    Mar 2009
    Beans
    292
    Distro
    Ubuntu

    gnome flashback sessions black screen

    Is it just me? I have tested this on an old install(partially broken due to dbus and systemd issues), a semi new install(installed yesterday) and a brand new install, logging into flashback sessions hangs at a black screen.
    This behavior started about this morning.
    I lay down on my bed, looking at the stars, and starting to wonder............................................ .where the **** is my roof..

  2. #2
    Join Date
    Aug 2009
    Beans
    3,151
    Distro
    Ubuntu Development Release

    Re: gnome flashback sessions black screen

    This happens to me after today's update. I thought it was Grub2 as it was updated.
    Code:
    cavsfan@cavsfan-MS-7529:~$ grub-install -v
    grub-install (GRUB) 2.00-18ubuntu1
    But, I can confirm it is not caused by that that I can see. I am in Unity now which is unaffected.

    I cannot login to flashback though all I have is a black screen too. I can bring up a terminal with ALT+TAB+t but that is about all.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  3. #3
    Join Date
    Jun 2007
    Beans
    12,946

    Re: gnome flashback sessions black screen

    I believe this is from the upgrade of upstart to 1.9.1-0ubuntu5
    (not the only issue with upstart but certainly significant for flashback users

  4. #4
    Join Date
    Jun 2007
    Beans
    12,946

    Re: gnome flashback sessions black screen

    Pretty easy to fix --
    Code:
    sudo nano /etc/upstart-xsessions
    change
    gnome-fallback
    gnome-fallback-compiz
    to
    gnome-flashback
    gnome-flashback-compiz

    Or maybe install the dummy fallback packages to match this dummy upgrade

    https://bugs.launchpad.net/ubuntu/+s...t/+bug/1217991
    Last edited by mc4man; August 28th, 2013 at 06:00 PM.

  5. #5
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    90
    Distro
    Ubuntu Development Release

    Re: gnome flashback sessions black screen

    Quote Originally Posted by mc4man View Post
    Pretty easy to fix --
    Code:
    sudo nano /etc/upstart-xsessions
    change
    gnome-fallback
    gnome-fallback-compiz
    to
    gnome-flashback
    gnome-flashback-compiz

    Or maybe install the dummy fallback packages to match this dummy upgrade

    https://bugs.launchpad.net/ubuntu/+s...t/+bug/1217991
    Thanks!

  6. #6
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,435
    Distro
    Ubuntu Development Release

    Re: gnome flashback sessions black screen

    I installed ..
    Code:
    sudo apt-get install gnome-session-fallback
    eary thismorning while doing some overclocking on one of my systems. I was not able to get Unity to work in full screen mode so I used gnome fallback. It worked just fine with (no effects). It worked for a while @ 4.002GHz in gnome-flashback (classic) but eventually became unstable during an upgrade. ( the upgrade process [unpacking/installing] caused a heavier than normal load on the cpu).
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  7. #7
    Join Date
    Aug 2013
    Beans
    1

    Re: gnome flashback sessions black screen

    I'm having the same problem as of 2 days ago. The suggested fixes above didn't work for me. But logging into tty1 and running the following got things up and running:
    sudo service lightdm restart
    gnome-session-flashback
    Not sure why that works though.

  8. #8
    Join Date
    Jun 2007
    Beans
    12,946

    Re: workarounds till fixed

    They'll get this fixed up sooner than later
    As mentioned in report the maintainer says not to change the names in /etc/upstart-xsessions as they should match what's in /usr/share/xsessions
    (though if running a dev one can do as they please to workaround released issues..

    Installing gnome-session-fallback would have no effect as it doesn't install any .session files anymore like it did in 13.04

    Another 'workaround' in lieu of editing that upstart file would be to create a symlink(s), ex. for flashback (no effects
    Code:
    sudo ln -s /usr/share/gnome-session/sessions/gnome-flashback.session /usr/share/gnome-session/sessions/gnome-fallback.session
    (I do find the tendency of upgrades being approved/released without the reviewer/maintainer/uploader actually using them first to see how they work out interesting, I guess they sometimes don't have the time

  9. #9
    Join Date
    Aug 2009
    Beans
    3,151
    Distro
    Ubuntu Development Release

    Re: gnome flashback sessions black screen

    I believe my problem is a bit more serious. Today I cannot get into either flashback or unity.
    Unity freezes and ALT+TAB+F1 to get to CLI mode and attempt the updates there yields some odd errors about dpkg and will not update.
    I believe it is time for a fresh install. But, I don't have time for that now.

    In Precise at present and glad I have more than one install so I can copy stuff from my Saucy partition to my USB drive.
    Not sure why my situation is different but, I think it is borked.

    Oh, and I seen another option to login something like NVIDIA Persistent *something*. Don't know where that came from or why.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  10. #10
    Join Date
    Mar 2009
    Beans
    292
    Distro
    Ubuntu

    Re: gnome flashback sessions black screen

    Quote Originally Posted by mc4man View Post
    Pretty easy to fix --
    Code:
    sudo nano /etc/upstart-xsessions
    change
    gnome-fallback
    gnome-fallback-compiz
    to
    gnome-flashback
    gnome-flashback-compiz

    Or maybe install the dummy fallback packages to match this dummy upgrade

    https://bugs.launchpad.net/ubuntu/+s...t/+bug/1217991
    Thank you for this..
    I was playing with gnome3 ppa and gnome3-staging ppa(oh noes)...that.did.not.go.well.
    After ppa-purge I was left blackscreen, and thats when I thought my whole year of tweaking on this install is done for..
    I started fresh, and encountered this problem(After I installed, I tried to chroot & upgrade, so the old install got this problem as well).
    After 2 days of endless log reading, file diffing, I magically fixed my old friend

    Yay for Thursday!
    I lay down on my bed, looking at the stars, and starting to wonder............................................ .where the **** is my roof..

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •