Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: I cant make ACPI=OFF permanent in grub

  1. #1
    Join Date
    Aug 2013
    Beans
    11

    I cant make ACPI=OFF permanent in grub

    Hi folks, i'm a beginner on Ubuntu and i'm experiencing some dificulties.

    I have installed Ubuntu 12.043. LTS on an Asus Laptop with a live cd.

    board: X71SL (Pegatron corporation ATI)
    bios: 09/24/2008 American Megatrends Inc version 204
    proc: 2x Intel Core 2 Duo T5800 @ 2.00GHz 1999.00MHz
    gc: geforce 9300M GS (Que je ne vois pas dans le report systinfo)

    I've made some research on different forums and it turns out that i can only make Ubuntu works by adding the command ACPI=OFF into the grug during the boot. In this case Ubuntu works nicely.
    Turning on the pc without modifying the ACPI results in a black or purple screen.

    Now i want to edit definitively the /etc/default/grub file, but none of the commands i've found works. (Editing and updating grub is ok and when i restart, the grub display the changes)

    Heres the command i have tryied so far:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi"

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off" (this one works only when i do it manualy)

    I may need a bit of help here.

    If you need any imformation, just ask.

    Thanks in advance.

  2. #2
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,206
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: I cant make ACPI=OFF permanent in grub

    After you included acpi=off after the qiet splash entry did you then run
    Code:
    sudo update-grub
    in the terminal?
    That should make the change permanent.
    MacBook Pro 10,1 retina

  3. #3
    Join Date
    Apr 2012
    Location
    Scotland, UK
    Beans
    150
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: I cant make ACPI=OFF permanent in grub

    Try editing the line in the etc/default/grub

    note: This is not the line 'GRUB_CMDLINE_LINUX_DEFAULT'

    GRUB_CMDLINE_LINUX=""

    to

    GRUB_CMDLINE_LINUX= "acpi=off"

    Then do as above in a terminal

    sudo update-grub

    hope this helps
    Last edited by Boab1993; August 25th, 2013 at 10:50 AM.
    Boab1993

  4. #4
    Join Date
    Aug 2013
    Beans
    11

    Re: I cant make ACPI=OFF permanent in grub

    Yes, i have done the updating grub command. I'm making another try now.

    Thx for answering anyway.

  5. #5
    Join Date
    Aug 2013
    Beans
    11

    Re: I cant make ACPI=OFF permanent in grub

    I will try again with a fresh install. I am messing with the etc/default/grub file for two days now and may have accidentaly change something wrong.

  6. #6
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,206
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: I cant make ACPI=OFF permanent in grub

    That's possible - it gets difficult to remember what was original and what you've changed.
    Good luck!
    MacBook Pro 10,1 retina

  7. #7
    Join Date
    Apr 2012
    Location
    Scotland, UK
    Beans
    150
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: I cant make ACPI=OFF permanent in grub

    It can be changed via command line on boot. No need for a fresh install.

    Either hold down shift on boot to edit the grub before start up or when in a position of black screen after startup try pressing ctrl+alt+f1 and login via your details.

    Then just type : gksudo gedit /etc/default/grub

    And you can edit the grub
    Last edited by Boab1993; August 25th, 2013 at 07:29 PM. Reason: missed a forward slash
    Boab1993

  8. #8
    Join Date
    Aug 2013
    Beans
    11

    Re: I cant make ACPI=OFF permanent in grub

    good to know, thx.

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,690
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: I cant make ACPI=OFF permanent in grub

    Did you try nomodeset first because acpi=off turns of several things, it is different from computer to computer but in many cases the fans and wireless will not work.

  10. #10
    Join Date
    Apr 2012
    Location
    Scotland, UK
    Beans
    150
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: I cant make ACPI=OFF permanent in grub

    Quote Originally Posted by Wild Man View Post
    Did you try nomodeset first because acpi=off turns of several things, it is different from computer to computer but in many cases the fans and wireless will not work.
    This is actually a good time to ask because you seem to know what your doing.

    Disabling acpi in this way, does that just disable it for the period of booting or is it permanent?

    One person says one thing, the other says another, just wondering if you had a clear answer.
    Boab1993

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •