Page 164 of 203 FirstFirst ... 64114154162163164165166174 ... LastLast
Results 1,631 to 1,640 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #1631
    Join Date
    Oct 2005
    Beans
    152

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    mv: preserving times for `/media/hdb3/finished/Angel\'s Egg (1985)/Angel\'s Egg.iso': Operation not permitted
    mv: setting permissions for `/media/hdb3/finished/Angel\'s Egg (1985)/Angel\'s Egg.iso': Operation not permitted
    [yes i own it]
    any clue what would fix that?

  2. #1632
    Join Date
    Aug 2005
    Location
    Mid-Michigan
    Beans
    22
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by dannyboy79 View Post
    T-one, this is probably because you wrote to the drive and it's not done writing the journal. you'll need to wait until it says it umounts ok. or, there may be an option you can add in the fstab to get it to write the changes to the disk immediately. I think it's "async" or "atime" add that before or after the options for your ntfs-3g partition.

    silent,nonempty,async,atime,noexec,uid=1000,gid=10 00,umask=007,locale=en_US.UTF-8

    you can look at

    man mount

    if you're not sure what you're enabling. good luck
    This happens whenever I write to the drive or not. And this is a clean, fresh install of Feisty using the release ISO, as well as a fresh format of the disk There is no data on the drive at all. "sudo umount /media/Pocket" dismounts just fine. Did I mention this is an EXTERNAL REMOVABLE USB DRIVE (meaning, there's no /etc/fstab entry for it, so all that info above is moot)?

    "noatime" is one of the options of the ntfs-3g mount, but I would assume that is the default, since I haven't played with ANY of the settings after installing.

    Here's what I did: installed Feisty from the Desktop ISO, changed the repos to a closer mirror to me, "sudo apt-get update", "sudo apt-get upgrade", sudo apt-get install ntfs-config".

    libntfs-3g0 and ntfs-3g are both v1.1.328-1. HAL is v0.5.8.4-ubuntu12, pmount isn't installed (as Feisty supposedly does not need it.) There are no errors of note in either /var/log/messages, dmesg, or /var/log/daemon.log.

    Also, if I use NTFS-config and disable "write support for external device", I still get the same error, even though the drive is mounted read only. (the mount shows it as mounted with NTFS). Also, the drive just remounts after I clear both errors popups.

    Is there something I'm missing? Is this a HAL/DBUS/Gnome-Volume-Manager problem?
    Last edited by T-One; April 21st, 2007 at 08:37 AM.

  3. #1633
    Join Date
    Nov 2005
    Beans
    522
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by myke View Post
    Hey, I have no problem with this at all and will try it. My only question is ... should I substitute "feisty" in the repository name or leave it with edgy. I'm not sure how to know if they have an actual feisty repo at the ntfs3g site.
    From the first post in the thread, Step 1;;
    Feisty users don't have to deal with additionnal repository, all is already in ubuntu repo.
    I just went straight to Step 3 , Automatic Configuration;

    Code:
    sudo apt-get install ntfs-config
    ...and it's working for me...
    Last edited by techstop; April 22nd, 2007 at 01:07 PM.

  4. #1634
    Join Date
    Jun 2006
    Location
    /Earth/Asia/Vietnam
    Beans
    211
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by T-One View Post
    This happens whenever I write to the drive or not. And this is a clean, fresh install of Feisty using the release ISO, as well as a fresh format of the disk There is no data on the drive at all. "sudo umount /media/Pocket" dismounts just fine. Did I mention this is an EXTERNAL REMOVABLE USB DRIVE (meaning, there's no /etc/fstab entry for it, so all that info above is moot)?

    "noatime" is one of the options of the ntfs-3g mount, but I would assume that is the default, since I haven't played with ANY of the settings after installing.

    Here's what I did: installed Feisty from the Desktop ISO, changed the repos to a closer mirror to me, "sudo apt-get update", "sudo apt-get upgrade", sudo apt-get install ntfs-config".

    libntfs-3g0 and ntfs-3g are both v1.1.328-1. HAL is v0.5.8.4-ubuntu12, pmount isn't installed (as Feisty supposedly does not need it.) There are no errors of note in either /var/log/messages, dmesg, or /var/log/daemon.log.

    Also, if I use NTFS-config and disable "write support for external device", I still get the same error, even though the drive is mounted read only. (the mount shows it as mounted with NTFS). Also, the drive just remounts after I clear both errors popups.

    Is there something I'm missing? Is this a HAL/DBUS/Gnome-Volume-Manager problem?
    Yes, I have exactly the same problem with T-ONE, and I would like to know how to fix it also...This is kinda annoying when you can't just right-click and eject the external USB disk, other than that the ntfs-3g driver works fine with file read/write/permission...
    .:.:.[)[@[)|2.:.:.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side-effect." -- Linus Torvald.

  5. #1635
    Join Date
    Nov 2005
    Location
    Hungary
    Beans
    146

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by DC@DR View Post
    Yes, I have exactly the same problem with T-ONE, and I would like to know how to fix it also...This is kinda annoying when you can't just right-click and eject the external USB disk, other than that the ntfs-3g driver works fine with file read/write/permission...
    Something is probably still using the NTFS volume so umount is denied because it could cause data loss. Try either of the below commands to figure out what software uses still the volume:
    Code:
    sudo fuser -vma ntfs_mount_point
    sudo lsof ntfs_mount_point

  6. #1636
    Join Date
    Apr 2007
    Beans
    25

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Total newb here. Bear with me.

    Trying to go from XP to Ubuntu. It is going on a single hard drive and it installs fine. I also have a 5 disk raid 5 array with a lot of stuff I don't want to lose. It is backed up however so into it I went.

    Tried to go Ubuntu only. Cleaned off windows (in Ubuntu installer made everything into clean space then created the root and swap partitions). Ubunto installed fine. I tried to use ntfs-3g to mount my 5 disk raid 5 array. Could not mount the raid array because of an error like the following:

    Code:
    $MFT has invalid magic.
    Failed to load $MFT: Input/output error
    Failed to startup volume: Input/output error
    Failed to mount '/dev/sdb1': Input/output error
    NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
    The usage of the /f parameter is very IMPORTANT! No modification was
    made to NTFS by this software.
    I decided I would try and dual boot. This is a whole other story but after two days I got it dual booting. So now I go in, run chkdsk /f on the drive in windows. I reboot twice. I shutdown, boot into ubuntu and try the process again (both automatic and manual at the first page of this thread) and I get the same error.

    Code:
    $MFT has invalid magic.
    Failed to load $MFT: Input/output error
    Failed to startup volume: Input/output error
    Failed to mount '/dev/sdb1': Input/output error
    NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
    The usage of the /f parameter is very IMPORTANT! No modification was
    made to NTFS by this software.
    I can see it when I grep for NTFS:

    Code:
    jeff@enghlol:~$ sudo fdisk -l | grep NTFS
    /dev/sdb1               1      155653  1250282691    7  HPFS/NTFS
    Disk /dev/sdc doesn't contain a valid partition table
    Disk /dev/sdd doesn't contain a valid partition table
    Disk /dev/sde doesn't contain a valid partition table
    /dev/sdf1   *           1        5100    40960048+   7  HPFS/NTFS
    When I try to umount, I get the following:

    Code:
    jeff@enghlol:~$ sudo umount /dev/sdb1
    umount: /dev/sdb1: not mounted
    When I try to mount it, I get the following:

    Code:
    jeff@enghlol:~$ sudo mount /dev/sdb1
    $MFT has invalid magic.
    Failed to load $MFT: Input/output error
    Failed to startup volume: Input/output error
    Failed to mount '/dev/sdb1': Input/output error
    NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
    The usage of the /f parameter is very IMPORTANT! No modification was
    made to NTFS by this software.
    What am I doing wrong? Is this supported with RAID 5 at all? Why when I grep for NTFS do I only see 4 of the 5 drives in this array? The fifth above is the same drive that Ubuntu is on, it is not in this array. There are 5 in it, /dev/sdb1, /dev/sdc, /dev/sdd, /dev/sde and some other missing one.

    Any help would be helpful here. I've already lost 50 Gigs of flac music that will take me weeks to re rip. I don't want to have to restore 7 years worth of family pictures from my backups. But I desperately want to use Ubuntu after my trial run this week. I share a lot of stuff off of this raid array to my xbox and home audio system. I also use it as a development drive for my java development job.

    THANKS!

  7. #1637
    Join Date
    Apr 2007
    Beans
    25

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    I'm guessing installing dmraid would be the first step according to this:

    http://forum.ntfs-3g.org/viewtopic.p...461387574e69b2

    Standby

  8. #1638
    Join Date
    Aug 2005
    Beans
    42
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Can someone help me out?

    I have a 160GB external LaCie usb drive. It worked fine in Edgy. I just reinstalled Kubuntu for Feisty. And now when I plug in the hard drive it doesn't mount. If I use konqueror and go to Service -> Storage Media and right click and select mount I get this error message.

    hal-storage-removable-mount-all-options refused uid 1000

    I have installed ntfs-config and have selected the "Enable write support for external devices"


    Thanks

  9. #1639
    Join Date
    Nov 2005
    Beans
    522
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    I think I have jinxed myself. I have an external USB hard drive (NTFS) that worked fine under edgy using the custom ntfs-3g repos. I did a clean install of Feisty and used the default repos. When I plug in the drive it is detected and mounted automatically. When I eject by right-clicking the desktop icon and selecting "eject" it does so briefly, then a new nautilus window opens again as if it has just been plugged in again and I get an error "unable to unmount volume" or something like that. If I run "sudo umount /media/WD_USB" the disk unmounts properly and I can turn it off. Maybe I should try using a later version of ntfs-3g from an unofficial repo?

  10. #1640
    Join Date
    Apr 2007
    Beans
    1

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    I've windows xp and ubuntu 7.04. I installed ntfs-config 0.5.5. When i turn on a write support program gave me an information that my windows drive is fragmented or sth like that. Later I wanted to start xp but it crashed so I had to run chkdsk which repair my XP. In XP I run defrag on each partition and back to ubuntu. Turn on ntfs-config and now its ok, but I think that user have to run defrag in windows before run ntfs-config in ubuntu.

Page 164 of 203 FirstFirst ... 64114154162163164165166174 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •