Page 161 of 203 FirstFirst ... 61111151159160161162163171 ... LastLast
Results 1,601 to 1,610 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #1601
    Join Date
    Nov 2005
    Location
    Hungary
    Beans
    146

    Re: HOWTO: NTFS with read/write support using ntfs-3g - BIG PROBLEMS WITH USB HD

    Quote Originally Posted by jiminycricket View Post
    Code:
    $ sudo ntfsfix /dev/sdc1
    Mounting volume... $MFT has invalid magic.
    ntfs_mft_load(): Failed.
    Failed to load $MFT: Input/output error
    This means that the signature of the NTFS superbock doesn't match the expected value. There can be several reasons for this:

    1) Media/hardware error, for instance bad sectors.

    2) Something modified it. At the present there isn't any NTFS software on Linux which would modify this value. Only commercial partitioners/imagers/backup softwares do.

    3) If the disk is external then it must be unmounted first, only afterwards can be safely detached from the hardware. Otherwise when the disk loses power anything can happen. This is not NTFS specific, it's basically true for all file systems on all OSes (usually no problem happens if the rule is not followed but in such cases there isn't guarantee and it's basically a lottery with the data to lose).

    4) The partition was accidentally formatted.

    5) The NTFS superblock is somewhere else. This information is stored in the NTFS bootsector. Ntfs-3g never modifies the bootsector but there are quite many softwares on Linux and Windows which do. For example, partitioners, boot managers, boot loaders, backup softwares, imagers, recovery and rescue softwares.
    Last edited by szaka; April 15th, 2007 at 01:54 PM.

  2. #1602
    Join Date
    Apr 2007
    Beans
    4

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    anyone that can help me? got the a partition mounted., where i have linux and xp. the xp part shows 1 folder named lost+found and no files inside. should be load of stuff in that partition...... i got one hd (sata type) and 2 partitions.... one xp ntfs and 1 ext3 to ubuntu....... any idea how i can rescue some important files from the xp partition?

  3. #1603
    Join Date
    Nov 2006
    Beans
    23

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by lilnerd View Post
    Ok..that was quick reply..Thanks..First i haev installed the ntfs config tool. Next when i was using fat32 i Couldn't copy anything to it because it was giving me error that there was Invaild Parameters. If you want, I can switch back to FAT32 but if you know what the problem is. Right now I can put things on the hard drive but i can't access it on windows. I ran the tool and now when i check the permssions tabs in properties i see that the permissions don't change at all....When i go to windows and try to open or copy the files it gives me an error. I think Lastly.. my ipod doesnt show up in "Computer'.

    ***EDIT!! I jst formated the drive back to fat32. So when i try to put something on the drive it gives me this message. Screenshot attached. Also the music im trying to put is music that was ripped from cds. I can put regular files like word docs and stuff... ALso I cant cange the permissions for the folder that the music in to write. The option is there, but doesnt save. Please help. Is the music copyrighted or somthing. If so is there a way. PLEASE HELP...Thanks for the quick reply btw again.
    Anyone?...is it the ripper im using? (the one that pops up when you put in a CD)

  4. #1604
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    5,926
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by kingofbadluck View Post
    anyone that can help me? got the a partition mounted., where i have linux and xp. the xp part shows 1 folder named lost+found and no files inside. should be load of stuff in that partition...... i got one hd (sata type) and 2 partitions.... one xp ntfs and 1 ext3 to ubuntu....... any idea how i can rescue some important files from the xp partition?
    you can find out if it's really mounted by using this command at the cli

    mount

    or even

    df -h

    i am pretty sure your drive just isn't mounting or it's not mounting where you're looking. let's see your fstab file. and then the results from the above commands when you "think" your ntfs partition is mounted.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  5. #1605
    Join Date
    Jun 2006
    Location
    Gwangju, Korea
    Beans
    3,479

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by lilnerd View Post
    Ok..that was quick reply..Thanks..First i haev installed the ntfs config tool. Next when i was using fat32 i Couldn't copy anything to it because it was giving me error that there was Invaild Parameters. If you want, I can switch back to FAT32 but if you know what the problem is. Right now I can put things on the hard drive but i can't access it on windows. I ran the tool and now when i check the permssions tabs in properties i see that the permissions don't change at all....When i go to windows and try to open or copy the files it gives me an error. I think Lastly.. my ipod doesnt show up in "Computer'.

    ***EDIT!! I jst formated the drive back to fat32. So when i try to put something on the drive it gives me this message. Screenshot attached. Also the music im trying to put is music that was ripped from cds. I can put regular files like word docs and stuff... ALso I cant cange the permissions for the folder that the music in to write. The option is there, but doesnt save. Please help. Is the music copyrighted or somthing. If so is there a way. PLEASE HELP...Thanks for the quick reply btw again.
    You probably have the incorrect parameters in /etc/fstab. Here's an example line from mine:
    Code:
    UUID=3C57-1E06 /win/c vfat defaults,utf8,umask=007,gid=46 0 1
    If that doesn't work for you, please post the relevant portion of your /etc/fstab. You may also benefit from reading How to fstab.

    The reason you can't change the permissions on some folders is because windows filesystem types (FAT32, NTFS, etc.) don't support Linux permissions. So Linux assigns the same permissions to every file in the partition so it can access it. That's that the umask and gid stuff is about. If your machine is a single-user machine (meaning a single login name), you might also want to specify a uid along with the other mount options which will determine which account owns the files. If your uid is the default, specify uid=1000. To discover your uid, type id.

  6. #1606
    Join Date
    Apr 2007
    Location
    Burke, VA
    Beans
    9
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Exclamation Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    $logfile indicates unclean shutdown (0, 0)

    failed to mount '/dev/sda1': operation not supported

    mount is denied because ntfs logfile is unclean. choose one action:

    boot windows and shutdown it cleanly, or if you have a removable

    device then click the 'safely remove hardware' icon in the windows

    taskbar notification area before disconnecting it.

    or

    run 'ntfsfix' on linux unless you have vista, then mount ntfs with

    the 'force' option read-write, or with the 'ro' option read-only.

    or

    mount the ntfs volume with the 'ro' option in read-only mode.

    error: could not execute pmount
    I'm running Ubuntu edgy 6.10 i386 (Pentium III) and trying to mount my external 250 GB HD from Western Digital. I installed ntfs-3g properly and checked to mount external hard drives in ntfs-config. I can see "250 GB Hard Drive" listed under Computer, but it won't mount when I right clicked mount volume. And I can't find the ntfsfix or ntfsprogs that was briefly mentioned at the beginning of this thread. It had mentioned something about dual booting, which I am. I have an internal 40 GB with Ubuntu on it as my primary boot, and then I have a separate 20GB internal with Windows 98SE on it. I think it said something about doing something in Windows, which I can't do because Windows 98SE can't read the hard drive at all (though I might be able to use my father's Windows XP computer...). I really don't know where to get them either... I looked on the support page for ntfs-3g and it didn't mention them. Before I installed ntfs-3g I could read only and access my files from Ubuntu. Now I can do neither read nor write, but the computer does recognize the drive.
    Quite annoyed. Can you help? If you do know how, make sure your instructions are simple with copy paste stuff, I'm really a n00b when it comes to Linux and the terminal. Thanks.

    edit: i uninstalled ntfs-3g and ntfsconfig from the synaptic package manager, and now my computer doesn't recognize the drive at all. It doesn't even give me the icon in Computer... is there a good way to uninstall?
    Last edited by setheey; April 16th, 2007 at 05:55 PM. Reason: more info needed

  7. #1607
    Join Date
    Nov 2005
    Location
    Hungary
    Beans
    146

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    @setheey: you don't need ntfsfix or ntfsprogs. The latest ntfs-3g, version 1.417, supports already your situation

  8. #1608
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    5,926
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by setheey View Post
    I'm running Ubuntu edgy 6.10 i386 (Pentium III) and trying to mount my external 250 GB HD from Western Digital. I installed ntfs-3g properly and checked to mount external hard drives in ntfs-config. I can see "250 GB Hard Drive" listed under Computer, but it won't mount when I right clicked mount volume. And I can't find the ntfsfix or ntfsprogs that was briefly mentioned at the beginning of this thread. It had mentioned something about dual booting, which I am. I have an internal 40 GB with Ubuntu on it as my primary boot, and then I have a separate 20GB internal with Windows 98SE on it. I think it said something about doing something in Windows, which I can't do because Windows 98SE can't read the hard drive at all (though I might be able to use my father's Windows XP computer...). I really don't know where to get them either... I looked on the support page for ntfs-3g and it didn't mention them. Before I installed ntfs-3g I could read only and access my files from Ubuntu. Now I can do neither read nor write, but the computer does recognize the drive.
    Quite annoyed. Can you help? If you do know how, make sure your instructions are simple with copy paste stuff, I'm really a n00b when it comes to Linux and the terminal. Thanks.

    edit: i uninstalled ntfs-3g and ntfsconfig from the synaptic package manager, and now my computer doesn't recognize the drive at all. It doesn't even give me the icon in Computer... is there a good way to uninstall?
    calm down. linux trys to provide error messages for a reason, so that newbies can solve the issue's if they arise. if you read the error message it gave you more than just one option. if you're dual booting all you'd have to do follow solution 1 to the error message. which is, "boot windows and shutdown it cleanly, or if you have a removable device then click the 'safely remove hardware' icon in the windows taskbar notification area before disconnecting it." this will solve your problem. You shouldn't have ever uninstalled it. Reinstall and you should be ok.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  9. #1609
    Join Date
    Nov 2006
    Beans
    23

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by mssever View Post
    You probably have the incorrect parameters in /etc/fstab. Here's an example line from mine:
    Code:
    UUID=3C57-1E06 /win/c vfat defaults,utf8,umask=007,gid=46 0 1
    If that doesn't work for you, please post the relevant portion of your /etc/fstab. You may also benefit from reading How to fstab.

    The reason you can't change the permissions on some folders is because windows filesystem types (FAT32, NTFS, etc.) don't support Linux permissions. So Linux assigns the same permissions to every file in the partition so it can access it. That's that the umask and gid stuff is about. If your machine is a single-user machine (meaning a single login name), you might also want to specify a uid along with the other mount options which will determine which account owns the files. If your uid is the default, specify uid=1000. To discover your uid, type id.
    I dont understand what ur tellin to do. Attached is another message i get when copying things. Please explain to me what you were trying to tell me to try. Do you think i need to reformat my hard drive. (IT external by the way if i didnt tell you b4) Last, when i go to change the properies i can't change the file access. I can but it doesnt change. Please help.
    P.S its NTFS.
    Attached Images Attached Images

  10. #1610
    Join Date
    Apr 2007
    Location
    Burke, VA
    Beans
    9
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Cool Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    ok i hooked it up to my dad's windows xp computer and it read it just fine, and then i safely removed hardware from the system tray. so everything was fine and dandy.

    but linux still doesn't recognize that there is a drive plugged in at all. before, it seemed all i had to do was just safely shut the drive down, but now i seem to have done a number on it by removing ntfs-3g from synaptic. I have uninstalled and reinstalled it from synaptic, getautomatix, and the command line terminal at the beginning of this thread. it said that it was already the latest version and nothing happened. still my drive is not recognized at all...

    how do i undo what i screwed up? thanks for being patient.

    edit: ok, now i can't see any peripherals - 3 flashdrives, ipod, and external hd
    Last edited by setheey; April 17th, 2007 at 11:41 AM. Reason: more messed up

Page 161 of 203 FirstFirst ... 61111151159160161162163171 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •