Page 152 of 203 FirstFirst ... 52102142150151152153154162202 ... LastLast
Results 1,511 to 1,520 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #1511
    Join Date
    Jan 2007
    Beans
    38

    Re: HOWTO: NTFS with read/write support using ntfs-3g - BIG PROBLEMS WITH USB HD

    I installed NTFS-3G on Feisty: It runs great with internals HD. However, it screwed up my USB external HD. I recovered it using chkdsk, then the external USB HD was correctly mounted and I could even write on it. But when I logged out something went wrong and the USB HD was unreadable again. I tried again to run chkdsk, but did not work. I tried to run ntfsfix and I get the error "...Failed to load $MFT".

    Any hint?

    My question is is ntfs-3g reliable on USB Hard Disks? Many people is using these devices as backup under Windows, it would be nice to have the same possibility under Ubuntu.

  2. #1512
    Join Date
    Mar 2007
    Beans
    9

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    hi there!!!

    well, i recieved this error:

    Mounting /media/sda5 failed.

    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/disk/by-uuid/122F5FD2DA475539': Operation not supported
    Mount is denied because NTFS logfile is unclean. Choose one action:
    Boot Windows and shutdown it cleanly, or if you have a removable
    device then click the 'Safely Remove Hardware' icon in the Windows
    taskbar notification area before disconnecting it.
    Or
    Run 'ntfsfix' on Linux unless you have Vista, then mount NTFS with
    the 'force' option read-write, or with the 'ro' option read-only.
    Or
    Mount the NTFS volume with the 'ro' option in read-only mode.

    but i'm unsure of how to perform these steps:

    "If you don't dual boot, get ntfsfix from the ntfsprogs package, run it on the windows device, and add the 'force' option in /etc/fstab for your windows device"

    any help would be awesome!!!!

    oh and this NTFS partition has data on it already. is it still going to be there after i can access it?

    thanks in advance!!!

  3. #1513
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    kinemagician, be sure to unmount external device properly when you are in both windows & linux, and it should be as reliable as with other NTFS formated device.

    bob dylan, install ntfsprogs, run 'ntfsfix /dev/[your partition]' and add the force option to the entry of your NTFS partition in /etc/fstab
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  4. #1514
    Join Date
    Mar 2007
    Beans
    81
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by givré View Post
    Are you sure you have ntfs-3g install ?
    Hi there,

    Yes you were right. I don't know why I had to install it, from your HOWTO I thought ntfs-3g was already installed for amd64 edgy users...
    Well now it works perfectly well, so this is all good, thank you very much for this good tutorial.

  5. #1515
    Join Date
    Mar 2007
    Beans
    5

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    hey guys
    i can not write in my ntfs external hard drive, but in my internal hard drive which is ntfs too i can easily write

    anyone knows how to fix it

    by the way, i get this :

    prince@Prince-Vaio:~$ pmount-hal /dev/sdb
    mount: wrong fs type, bad option, bad superblock on /dev/sdb,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    mount: wrong fs type, bad option, bad superblock on /dev/sdb,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

  6. #1516
    Join Date
    Mar 2007
    Beans
    5

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by OP_Prince_of_Persia View Post
    hey guys
    i can not write in my ntfs external hard drive, but in my internal hard drive which is ntfs too i can easily write

    anyone knows how to fix it

    by the way, i get this :

    prince@Prince-Vaio:~$ pmount-hal /dev/sdb
    mount: wrong fs type, bad option, bad superblock on /dev/sdb,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    mount: wrong fs type, bad option, bad superblock on /dev/sdb,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    thanx for ur easy guide, i searched and found my answer :

    http://ubuntuforums.org/showthread.p...95#post1647295

  7. #1517
    Join Date
    Mar 2007
    Beans
    268

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    OK, I installed ntfs-3g, put the commands into my fstab, created directories for the partitions in /media. Rebooted and bingo, there's my Windows drives. Nothing wrong there...

    I had to do some things with windows, so I hibernated the machine and rebooted into windows, where I moved some files, wrote some new ones...

    Then I shutdown windows and rebooted into the hibernated ubuntu. When I went to access my NTFS drives, I found that linux didn't know about the filesystem changes I had made in windows. I am assuming this was because the drives were never unmounted and sync-ed when I went into hibernation.

    While I think this is broken, I can understand it. However, I need a workaround. Is there a way to leave the ntfs-3g commands in the fstab and not have the drives be permanently mounted? I would really like to use some automount that would dismount the drives after a few seconds of inactivity.

    Being a linux noob, I'm not sure how to do this. Can someone help?
    Thanks,
    -J

  8. #1518

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Hi there, i just bought 2 External 500Gig USB drives. They are Maxtor, and come formated NTFS. I was thinking to format them ext3, but then i couldn't share files with my laptop of friends easily. I am glad to see this driver out for NTFS partitions. My installation went well as expected per how to. I plug in one of my USB drives and it shows up on the desktop as i expect called "usbdrive" this is not so convenient, so i hooked it up to the windows xp computer my girlfriend uses and changed the label on the drive to "Data" and apply, and unmount the drive. When i plugged it back in to Ubuntu, i get nothing on my desktop. I checked logs for syslog, and it shows the drive is detected as /dev/sdc, and sees the partition. i could force mount the drive with mount in readonly, but it wouldn't auto mount. So, i removed it, and plugged in my 2nd drive. shows up on desktop "usbdisk" great, so, i tried the other again just to be sure. Nothing. I plugged it back into the xp system and cleared the label and applied it, and back to ubuntu with it. Shows right up on the desktop. Any thoughts on why this is? My need is to name these drives uniquely so i can tell whats what easily. My fat32 mybook drive is labeled "myBook" which it came that way, and when auto mounted shows up as "mybook" on the desktop. Please help with this. thanks!

    --Dave

  9. #1519
    Join Date
    Dec 2006
    Location
    Mumbai, India
    Beans
    625
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    There must be something wrong in your fstab file, here is a link to understanding fstab http://ubuntuforums.org/showthread.php?t=283131
    Ignorance is the parent of fear . . . MobyDick

  10. #1520
    Join Date
    Apr 2005
    Location
    York -- UK
    Beans
    6

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    hi there, i followed all steps described and everything is working perfect except that the NTFS partition is not mounted automatically on start up. If i want it to be mounted, i have to manually do 'sudo ntfs-3g /dev/sda1 /media/my_ntfs' or 'sudo mount -a'. The last line of my fstab is as following:
    /dev/sda1 /media/my_ntfs ntfs-3g defaults,locale=en_US.utf8 0 0

    Anyone knows how to overcome this problem?

    Best regards

Page 152 of 203 FirstFirst ... 52102142150151152153154162202 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •