Page 13 of 203 FirstFirst ... 311121314152363113 ... LastLast
Results 121 to 130 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #121
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Ok, i made some improvement, we while still have one problem, but i don't think we can't manage it (the /dev/fuse thing).
    I'll finish it tomarrow (i'll sleep a bit right now )
    @domino:
    1.Yeah there will be one, but one which already exist, because since everything is mount on /dev/fuse, the only way to unmount one device is to unmount all of them. That's bad, but that's how work fuse and we can't do nothing against it.
    2.Real backdoor would be to use the official one. But if you want to mount via ntfs, i plan to made an option that i'll call ntfs-old to mount it with ntfs, so you'll be able to mount it like that: pmount -t ntfs-old /dev/sd*.
    3.I'm not developper.

    @Poka64:You mean, auto mount with ntfs and manually mount with ntfs-3g ? that's an option. What do other guys think? An other idea could be to create a nautilus-script which could unmount an NTFS device mounted automaticly with ntfs, to mount it with ntfs-3g. An 'mount it with Full write access' option.
    Last edited by givré; July 22nd, 2006 at 01:43 AM.
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  2. #122
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    92
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    givré: no, I mean, when the the drive is connected you would be presented with an option either using ntfs or nfts-3g, but I know that is hard to get to work (maybe impossible to accomplish with the recent work being done in this thread?)

    Your nautilus script thing could work out fine.

    (I'm not an expert on these things)

  3. #123
    Join Date
    Apr 2005
    Location
    montreal
    Beans
    26

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    anybody can help me with the input/output problem ?

  4. #124
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    As a "safe" method, I would have to agree to auomount using ntfs driver. the advanced/daring users can always manual mount ntfs-3g. Then that would cover your @ss as it doesn't damage anyting by default.

    If the drive is automounted using the ntfs driver, anyone can easily umount it from the desktop. Then use the right-click nautilus script to mount using ntfs-3g drivers.

  5. #125
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    @stack,

    can you be more discriptive with the problem or maybe post the error?

  6. #126
    Join Date
    Apr 2005
    Location
    montreal
    Beans
    26

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    sorry, here is my first post concerning this issue....:

    --------------------------------------------------------------------------------

    i'm also stuck with the problem of: Couldn't mount device '/dev/hda1': Input/output error
    Mount failed.


    Disk /dev/hda: 60.0 GB, 60011642880 bytes
    255 heads, 63 sectors/track, 7296 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 6511 52299576 7 HPFS/NTFS
    /dev/hda2 6512 7240 5855692+ 83 Linux
    /dev/hda3 7241 7296 449820 82 Linux swap / Solaris
    root@cerebrum:/#


    it is mounting corretly with the default ntfs driver. i do a umount /dev/hda1, and try to mount it in the command line with :

    root@cerebrum:/# ntfs-3g /dev/hda1 /media/hda1 -o silent,umask=0,locale=en_US.utf8
    Couldn't mount device '/dev/hda1': Input/output error
    Mount failed.
    root@cerebrum:/#

    i've try putting it in the fstab with the same result. Does someone know the reason for this error. It not creating any error log either. ( or i dont know wich one )

  7. #127
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Sorry, stack. AFter the board went to maint. mode, I went to bed.

    Post your fdisk -l. Also did you partition using a 3rd pary application? Because even the slightest error in the file system will not mount the partition using ntfs-3g drivers. You might be able to get away with it with ntfs drivers. Anothering thing you can try is to do a "chkdsk /f" or scandisk/fix the ntfs partition in windows.

  8. #128
    Join Date
    Mar 2006
    Location
    Perth, Western Australia
    Beans
    24
    Distro
    Hardy Heron (Ubuntu Development)

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by kbunsie View Post
    Problem here. When I mount the drives only the first one shows up on my desktop. Also, when I do "umount -a" and then "mount -a" my external drive does not remount. Even after I power it off and on again. Any help?
    Same here .
    When I try to access it through nautilus I get this error:
    mount: according to mtab, /dev/fuse is already mounted on /media/320gb

    mount failed
    My fstab is as follows
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda2       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hda5       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    /dev/sdb1	/media/36GB	ntfs-3g     silent,umask=0,locale=en_US.utf8    0    0
    /dev/sda1	/media/320GB	ntfs-3g     silent,umask=0,locale=en_US.utf8    0    0
    /dev/hda1	/media/120GB	ntfs-3g     silent,umask=0,locale=en_US.utf8    0    0
    /dev/sdc1	/media/250GB	ntfs-3g     silent,umask=0,locale=en_US.utf8    0    0
    ||||----SOLUTION (edit)----||||
    I made a folder in /home/jaymo names .drives and changed my mountpoints to point to that directory. Worked a charm.
    I even have the folders in "Places" because I turned them into nautilus bookmarks .
    Last edited by Jaymo; July 22nd, 2006 at 01:05 PM.

  9. #129
    Join Date
    Jun 2005
    Beans
    145

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Hi and thanx for this guide! (works great)

    I do have a insignificant problem. When I copy a file to my ntfs-partition, Konqueror complains about it cannot change "file protection" (freely translated from Swedish ), but it works anyway. Is there any way to remove this error message? Its quite annoying

  10. #130
    Join Date
    Jul 2006
    Beans
    2
    Distro
    Ubuntu 6.06

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Sorry to interupt the current run of troubleshooting - but i wanted to say this is working for me - I am an absolute noob to Ubuntu/Linux in general and though I didn't understand a lick of what i was copying in to terminal the end result is perfect
    This issue was the reason i flat out dropped suse 10.0 - it would some times find my drives but i could never do anything with them - being a noob - this has seemed to work flawlessly - now i can actually get my old junk off the drives

    Suggestions:
    1. make this a sticky - somewhere
    2. make this automatic in future versions
    3. alot of noobs might know that if it is anoying to only get one partition on your desktop you can have it show none by putting the drives somewhere besides the media directories then just do the short cuts in nautilis which is better for me anyway - the following link is were I figured that out
    http://www.ubuntuforums.org/showthre...mounts+desktop
    4. sombody add this to the desktop guideshttps://help.ubuntu.com/

    thanks for working this out

Page 13 of 203 FirstFirst ... 311121314152363113 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •