Page 104 of 203 FirstFirst ... 45494102103104105106114154 ... LastLast
Results 1,031 to 1,040 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

  1. #1031
    Join Date
    Nov 2006
    Beans
    10

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by givré View Post
    gvm call pmount-hal, which will choose the fs according to what suggest hal.
    Since my patched package provide an hal rule to choose ntfs-3g for ntfs, pmount-hal would choose ntfs-3g automatically. What give u :
    Code:
    pmount-hal /dev/sda1
    Also, cheek that the hal rule is there :
    For dapper : /usr/share/hal/fdi/policy/10osvendor/15-ntfs-policy.fdi
    For edgy : /etc/hal/fdi/policy/15-ntfs-policy.fdi
    Thanks for the pointers givré. I have /etc/hal/fdi/policy/15-ntfs-policy.fdi in place, content looks fine:

    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <deviceinfo version="0.2">
    
    <!-- mount ntfs volume with the ntfs-3g driver. If you want to change this policy to
    use the read only ntfs driver for default instead, just replace ntfs-3g by ntfs -->
    
            <device>
    
            <match key="volume.fstype" string="ntfs">
            <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
                    </match>
    
            </device>
    
    
    <!-- if ntfs-3g, we need some special option (don't touch this policy if you change
    the default policy to ntfs above. In any way, **don't touch this policy**)-->
    
            <device>
    
            <match key="volume.fstype" string="ntfs-3g">
            <append key="volume.mount.valid_options" type="strlist">nonempty</append>
            <merge key="storage.policy.mount_option.nonempty" type="bool">true</merge>
            <merge key="volume.policy.mount_option.nonempty" type="bool">true</merge>
            </match>
    
            </device>
    </deviceinfo>
    And everything works fine, when I don't use LUKS. Then, ntfs-3g is used to mount ntfs-formatted volumes, both automatically and when I manually call pmount.

    However, as soon as I use LUKS, another path in the program must be used and transparency breaks (using LUKS should be transparent). When I unmount the automatic mount (that uses ntfs) and say "pmount /dev/sdb1", I get the output shown in http://ubuntuforums.org/showthread.php?p=1029, pmount asks me for the passphrase and mounts with ntfs, not ntfs-3g. When I use pmount-hal I get

    Code:
    $ pmount-hal /dev/sdc1 -d
    resolved /dev/sdc1 to device /dev/sdc1
    mount point to be used: /media/usbdisk
    no iocharset given, current locale encoding is UTF-8
    locale encoding uses UTF-8, setting iocharset to 'utf8'
    Cleaning lock directory /var/lock/pmount_dev_sdc1
    device_whitelist: checking /etc/pmount.allow...
    device_whitlisted(): nothing matched, returning 0
    find_sysfs_device: looking for sysfs directory for device 8:33
    find_sysfs_device: checking whether /dev/sdc1 is on /sys/block/sdc (8:32)
    find_sysfs_device: major device numbers match
    find_sysfs_device: minor device numbers do not match, checking partitions...
    find_sysfs_device: checking whether device /dev/sdc1 matches partition 8:32
    find_sysfs_device: checking whether device /dev/sdc1 matches partition 8:33
    find_sysfs_device: -> partition matches, belongs to block device /sys/block/sdc
    device_removable: corresponding block device for /dev/sdc1 is /sys/block/sdc
    get_blockdev_attr: value of /sys/block/sdc/removable == 1
    policy check passed
    spawnv(): executing /sbin/cryptsetup '/sbin/cryptsetup' 'isLuks' '/dev/sdc1'
    spawn(): /sbin/cryptsetup terminated with status 0
    spawnv(): executing /sbin/cryptsetup '/sbin/cryptsetup' 'luksOpen' '/dev/sdc1' '_dev_sdc1'
    Enter LUKS passphrase: 
    spawn(): /sbin/cryptsetup terminated with status 0
    locking mount point directory
    mount point directory locked
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'udf' '-o' 'nosuid,nodev,user,async,atime,exec,uid=1000,gid=1000,umask=000,iocharset=utf8' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'udf' '-o' 'nosuid,nodev,user,async,atime,exec,uid=1000,gid=1000,umask=000' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'iso9660' '-o' 'nosuid,nodev,user,async,atime,exec,uid=1000,gid=1000,iocharset=utf8' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'iso9660' '-o' 'nosuid,nodev,user,async,atime,exec,uid=1000,gid=1000' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'vfat' '-o' 'nosuid,nodev,user,quiet,shortname=mixed,async,atime,exec,uid=1000,gid=1000,umask=077,iocharset=utf8' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'vfat' '-o' 'nosuid,nodev,user,quiet,shortname=mixed,async,atime,exec,uid=1000,gid=1000,umask=077' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 32
    spawnv(): executing /bin/mount '/bin/mount' '-t' 'ntfs' '-o' 'nosuid,nodev,user,async,atime,exec,uid=1000,gid=1000,umask=077,iocharset=utf8' '/dev/mapper/_dev_sdc1' '/media/usbdisk'
    spawn(): /bin/mount terminated with status 0
    unlocking mount point directory
    mount point directory unlocked
    So pmount-hal also uses ntfs, not ntfs-3g (the only difference seems to be that I get a better mountpoint). It seems to me that pmount(?, pmount-hal?, ...?) does not look at the volume's filesystem (again) _after_ "cryptsetup luksOpen" but it should. So is that a bug or could I tweak some other configuration anywhere?

  2. #1032
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Ok, see the point.
    It's seams that pmount-hal can't get the fs from hal (probably because it's encypted, don't really know much on that) so it use the classical pmount method : mount with different fs until it works.
    I put ntfs-3g after ntfs in the list, so it's why it use ntfs.
    I'll prepare a package with the change so you could test to know if it make it work.
    Do you use edgy or dapper ?
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  3. #1033
    Join Date
    Nov 2006
    Beans
    93

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    First of all excuse me for my bad english. I want to be able to read and write my two ntfs partitions, but the instructions given in the first post of the thread didn't work for me. The drive disappears and cannot be accessed, please give me a hand with my config
    Here's how my fstab looks like:
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/hda3
    UUID=1b2b4efd-197e-442e-8d8d-4d5062408ae8 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/hda1
    UUID=E844661E4465F02C /media/hda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    # /dev/hda5
    UUID=E60096EE0096C549 /media/hda5     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    # /dev/hda4
    UUID=8f26cd14-92ba-4160-85e0-5a5f7901a4d2 none            swap    sw              0       0
    /dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/           /media/floppy0  auto    rw,user,noauto  0       0
    How should i modify it?
    Last edited by jdarias; December 2nd, 2006 at 04:39 PM.

  4. #1034
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Change that
    Code:
    # /dev/hda1
    UUID=E844661E4465F02C /media/hda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    # /dev/hda5
    UUID=E60096EE0096C549 /media/hda5     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    to
    Code:
    # /dev/hda1
    UUID=E844661E4465F02C /media/hda1     ntfs-3g    defaults,locale=en_US.utf8 0       1
    # /dev/hda5
    UUID=E60096EE0096C549 /media/hda5     ntfs-3g    defaults,locale=en_US.utf8 0       1
    You can also adjust the locale to your need by looking at the output of locale -a to know which one are supported by your system.
    Save the change and reboot.
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  5. #1035
    Join Date
    Nov 2006
    Beans
    93

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Thank you very much!
    I enabled both partitions. I tried before enabling just the hda5 but it didn't work. That's weird.

  6. #1036
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Nice How-to



    This thread has been added to the UDSF wiki.



    bodhi.zazen
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  7. #1037
    Join Date
    Nov 2006
    Beans
    10

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by givré View Post
    Ok, see the point.
    It's seams that pmount-hal can't get the fs from hal (probably because it's encypted, don't really know much on that) so it use the classical pmount method : mount with different fs until it works.
    I put ntfs-3g after ntfs in the list, so it's why it use ntfs.
    I'll prepare a package with the change so you could test to know if it make it work.
    Do you use edgy or dapper ?

    Hi givré, wow, thanks, I am on edgy. What are you planning to do? Just swap ntfs and ntfs-3g in the list of file systems that pmount tries? Is this hardcoded or is there a config file that can be changed (trying to take the burden to produce a package off you)? Regards, Thomas.

  8. #1038
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Quote Originally Posted by thm View Post
    Hi givré, wow, thanks, I am on edgy. What are you planning to do? Just swap ntfs and ntfs-3g in the list of file systems that pmount tries? Is this hardcoded or is there a config file that can be changed (trying to take the burden to produce a package off you)? Regards, Thomas.
    Ok, i'll do it right now. It's hardcoded.
    Hang On 8)
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  9. #1039
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Ok, So i just put ntfs-3g before ntfs.
    Test it, and it seams to work.
    Tell me how it works for you. If it's ok, i'll put in the repo.

    Thanks
    Attached Files Attached Files
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

  10. #1040
    Join Date
    Nov 2006
    Beans
    93

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    Yesterday worked fine after reboot.
    Today none of both partitions appear.
    What a grief
    my fstab:
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/hda3
    UUID=1b2b4efd-197e-442e-8d8d-4d5062408ae8 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/hda1
    UUID=E844661E4465F02C /media/hda1     ntfs-3g    defaults,locale=es_CO.utf8 0       1
    # /dev/hda5
    UUID=E60096EE0096C549 /media/hda5     ntfs-3g    defaults,locale=es_CO.utf8 0       1
    # /dev/hda4
    UUID=8f26cd14-92ba-4160-85e0-5a5f7901a4d2 none            swap    sw              0       0
    /dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/           /media/floppy0  auto    rw,user,noauto  0       0
    Last edited by jdarias; December 2nd, 2006 at 09:00 PM.

Page 104 of 203 FirstFirst ... 45494102103104105106114154 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •