Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Wireless problem on dell n4010

  1. #1
    Join Date
    Aug 2013
    Beans
    12

    Wireless problem on dell n4010

    Hello all, I'm new to Linux (sort of) and I'm having some problems with my wireless. My drivers are not proprietary, and the controller is broadcom BCM4313. I know there is a sticky about said controller in another thread, but its in a different version of Ubuntu. I'm running 12.04 LTS. Any help will be greatly appreciated.

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,682
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless problem on dell n4010

    Welcome to the forums jaycen2 !

    Please post the outputs of -
    Code:
    uname -mr
    lspci -nnk | grep -iA2 net
    iwconfig
    rfkill list all
    apt-cache show bcmwl-kernel-source | grep -i version
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #3
    Join Date
    Aug 2013
    Beans
    12

    Re: Wireless problem on dell n4010

    Thanks for the welcome!

    Outputs are as follows:
    3.8.0-29-generic x86_64

    Network controller: Broadcom BCM4313 [14e4:4727]
    Kernel modules: bcma
    Ethernet controller: Atheros communications inc AR8152 [1028:0456]
    Kernel driver in use: atl1c

    eth0 no wireless extensions
    lo no wireless extensions

    Version: 6.20.155.1+bdcom-0ubuntu0.0.1

    Sorry for the slow response, I'm on a smartphone right now due to only having one computer available right now

  4. #4
    Join Date
    Aug 2013
    Beans
    12

    Re: Wireless problem on dell n4010

    Forgot to mention I'm also dual-booting with windows 7

  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,682
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless problem on dell n4010

    Quote Originally Posted by jaycen2 View Post
    Outputs are as follows:
    3.8.0-29-generic x86_64
    Have you manually installed the above kernel ? Because as much as I am aware, 12.04 doesn't use kernel 3.8x yet. But since 12.04.3 is out, I may be wrong.

    Also, you did not post the output of "rfkill list all". Please do so now. For now, I am assuming your wifi is NOT hard blocked (if it is, post back without following the suggestion below).

    Network controller: Broadcom BCM4313 [14e4:4727]
    Kernel modules: bcma
    As a test, please try (without rebooting) -
    Code:
    sudo modprobe -rfv bcma
    sudo modprobe -v brcmsmac
    Does it activate your wireless?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #6
    Join Date
    Aug 2013
    Beans
    12

    Re: Wireless problem on dell n4010

    Well the sudo commands have indeed brought my wireless back, but I'm not sure if it will stay when I reboot.
    Nothing happened when I did the killall, it just created a new command line under it.
    As for the kernel, all I did was install Ubuntu on a 15g partition. I don't think my wireless is hard blocked, because when I boot into windows, wireless does indeed work, its only when I'm in Ubuntu.

  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,682
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless problem on dell n4010

    Quote Originally Posted by jaycen2 View Post
    Well the sudo commands have indeed brought my wireless back....
    Okay, let's just focus on that part for now. Please blacklist the driver "bcma" and see if "brcmsmac" loads automatically on next boot. To blacklist bcma -
    Code:
    echo "blacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Then reboot and see if the wireless works on next boot.

    Also, run the following command (after running above command and rebooting) and see which of the two drivers is loaded -
    Code:
    lsmod | grep -e bcma -e brcmsmac
    We want only brcmsmac in the output of above command, and NOT bcma.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #8
    Join Date
    Aug 2013
    Beans
    12

    Re: Wireless problem on dell n4010

    Okay I rebooted, and wireless is gone. I tried the second command and nothing happened. I'm guessing I don't have the package. Its "modules-init-tools"

  9. #9
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,682
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless problem on dell n4010

    Please run again-
    Code:
    sudo modprobe -v brcmsmac
    Does it connect?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  10. #10
    Join Date
    Aug 2013
    Beans
    12

    Re: Wireless problem on dell n4010

    Yes it does connect

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •