Results 1 to 5 of 5

Thread: Can't instal AMD HD 4850 drivers?

  1. #1
    Join Date
    Aug 2013
    Beans
    2

    Can't instal AMD HD 4850 drivers?

    As the thread title says i can't install hd 4850 drivers. The major problem is that i don't even know if the drivers are installed or not. First of all, in the additional drivers tab i don't have any driver and says "No proprietary drivers are in use on this system." Secondly, when i go to the System -> Details -> Graphics in the section Driver is written "Unknow" and in the Experience tab it is written "Standard". I've tried to install the driver in 2 ways. By sudo apt-get purge fglrx -> sudo apt-get install linux-headers-generic and then reboot , and also i searched another way (don't remember it very well) which, i think , is more complicated. I had to download the driver from amd.com, then i had to write something in the terminal to make a deb file i gues... Sorry if i speak non-sense but i recently switched to ubuntu and i'm a newbie...So any help is more than welcome.

    If it matters: Ubuntu version is 12.04 LTS x64

  2. #2
    Join Date
    Oct 2011
    Beans
    24

    Re: Can't instal AMD HD 4850 drivers?

    Last time I tried using ATI's graphics drivers for my HD 4870, I found out that they no longer supported graphics cards pre HD 5xxx.

    Not that the closed source drivers were very good anyway.

    Personally, I use the default open drivers on my everyday Ubuntu installation, and the xorg-edgers open driver on my gaming Ubuntu installation, which have always been pretty reliable and perform much better than 12.04's normal graphics drivers in my experience.

    But, I'm no expert.

  3. #3
    Join Date
    May 2007
    Beans
    13,085

    Re: Can't instal AMD HD 4850 drivers?

    There are two versions of 12.04 out there: 12.04.1 and 12.04.2. If you installed when 12.04 first came out or upgraded to it when it first came out, you will most likely have 12.04.1. That version uses the X-server version that is compatible with the AMD HD 2x/3x/4x-series fglrx drivers.

    If you have the 12.04.2 version, that has an X-server version that is NOT compatible with the AMD HD 2x/3x/4x-series drivers -- and in that case, you won't be able to install fglrx drivers.

    AMD dropped fglrx driver support for the HD 2x/3x/4x-series last summer and those drivers won't work with anything newer than 12.04.1.
    Ubuntu 15.04 Mate, Mint 17.1; MS Win 8.1, Win10 TP.
    Will not respond to PM requests for support -- use the forums.

  4. #4
    Join Date
    Aug 2013
    Beans
    2

    Re: Can't instal AMD HD 4850 drivers?

    The version is 12.04.2 ... So that's that... Damn. I was so excited to swich from windows 8 to ubuntu.
    Thank you Mark.

  5. #5
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Can't instal AMD HD 4850 drivers?

    You can still use Ubuntu! Just install 12.04.1 and enjoy!
    Last edited by QIII; August 23rd, 2013 at 08:56 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •