Results 1 to 7 of 7

Thread: Confirming kernel version, am I using latest kernel avaliable?

Hybrid View

  1. #1
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Confirming kernel version, am I using latest kernel avaliable?

    hi guys,

    I received an update for linux-headers-generic-lts-quantal version 3.5.0.37.43 to version 3.5.0.39.45
    thats all good but I only get kernel 3.5.0-32-generic listed in grub.

    So my question is shouldn't grub be listing 3.5.0.39 instead of 3.5.0-32?




    P.S.
    output of uname -r
    3.5.0-32-generic.
    Attached is screenshot of update history in software center
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,206
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Confirming kernel version, am I using latest kernel avaliable?

    Open a terminal window and run
    sudo update-grub
    then see if the menu entries change to include the new kernel. (Though I would have thought that should already have run by default).
    MacBook Pro 10,1 retina

  3. #3
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Confirming kernel version, am I using latest kernel avaliable?

    That was my first reaction too.
    Heres output:
    Code:
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.5.0-32-generic
    Found initrd image: /boot/initrd.img-3.5.0-32-generic
    Found linux image: /boot/vmlinuz-3.5.0-31-generic
    Found initrd image: /boot/initrd.img-3.5.0-31-generic
    Found linux image: /boot/vmlinuz-3.2.0-52-generic
    Found initrd image: /boot/initrd.img-3.2.0-52-generic
    Found linux image: /boot/vmlinuz-3.2.0-51-generic
    Found initrd image: /boot/initrd.img-3.2.0-51-generic
    Found linux image: /boot/vmlinuz-3.2.0-49-generic
    Found initrd image: /boot/initrd.img-3.2.0-49-generic
    Found memtest86+ image: /memtest86+.bin
    Found Windows 7 (loader) on /dev/sda1
    done

  4. #4
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,453
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Confirming kernel version, am I using latest kernel avaliable?

    You do notice the difference between linux-headers and linux-image?
    Do you have the linux-image-lts-quantal packages installed?
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  5. #5
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Confirming kernel version, am I using latest kernel avaliable?

    No I don't have the linux-image-lts-quantal package installed. I'm using 12.04 Precise Pangolin.
    Ah, but I do have the linux-headers-generic-lts-quantal installed.

    Should I install the linux-image-lts-quantal package?
    EDIT:I'll try it, lets see what happens...
    Last edited by jonnyboysmithy; August 21st, 2013 at 03:40 AM.

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,453
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Confirming kernel version, am I using latest kernel avaliable?

    Quote Originally Posted by jonnyboysmithy View Post
    No I don't have the linux-image-lts-quantal package installed. I'm using 12.04 Precise Pangolin.
    Ah, but I do have the linux-headers-generic-lts-quantal installed.

    Should I install the linux-image-lts-quantal package?
    EDIT:I'll try it, lets see what happens...
    Yes.
    If you have synaptic installed it'll make life easier.
    When you it install the package, I think it'll also install another package.
    I think it's something like linux-image-extra-lts-quantal.
    But searching in synaptic will make it easier, especially for correct spellings.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Confirming kernel version, am I using latest kernel avaliable?

    Excellent!
    Code:
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.5.0-39-generic
    Found initrd image: /boot/initrd.img-3.5.0-39-generic
    Found linux image: /boot/vmlinuz-3.5.0-32-generic
    Found initrd image: /boot/initrd.img-3.5.0-32-generic
    Found linux image: /boot/vmlinuz-3.5.0-31-generic
    Found initrd image: /boot/initrd.img-3.5.0-31-generic
    Found linux image: /boot/vmlinuz-3.2.0-52-generic
    Found initrd image: /boot/initrd.img-3.2.0-52-generic
    Found linux image: /boot/vmlinuz-3.2.0-51-generic
    Found initrd image: /boot/initrd.img-3.2.0-51-generic
    Found linux image: /boot/vmlinuz-3.2.0-49-generic
    Found initrd image: /boot/initrd.img-3.2.0-49-generic
    Found memtest86+ image: /memtest86+.bin
    Found Windows 7 (loader) on /dev/sda1
    done
    It worked!
    SOLVED
    It also installed another package I forgot the name, but it did the trick.
    Yes I'm using synaptic, its super handy.

    Thanks for your help everyone!
    Last edited by jonnyboysmithy; August 21st, 2013 at 03:49 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •