Results 1 to 3 of 3

Thread: Qt applications wrong system default language.

  1. #1
    Join Date
    Jul 2009
    Location
    the Netherlands
    Beans
    28
    Distro
    Ubuntu 14.04 Trusty Tahr

    Qt applications wrong system default language.

    I have Ubuntu 13.04 AMD64 on my desktop PC and everything was peachy
    until I noticed something odd that I've never had happen before:

    I live in the Netherlands, so my localization is Dutch, but because of practicality
    (e.g. tutorials and instructions from other users), my system language is English US.

    This has always worked well for me over the past 8 years and every
    application I installed has always used the correct system language.

    After installing Clementine and Bitcoin, both Qt applications, I noticed
    that the language they use is Dutch, which is my localization but not,
    like I mentioned before, my system default language, which is English US.
    This has never happened before, when using previous versions of Ubuntu.

    Does anyone know what causes this and if I can change this setting?
    I am well aware I can change this per app, but I want this Qt setting to be
    used system-wide. An OCD thing, I'm afraid...

    Bitcoin was installed from it's own PPA, but Clementine from the
    Ubuntu main repository.


    Thanks in advance,

    Richard.
    Last edited by richierich1986; May 1st, 2013 at 05:17 PM.

  2. #2
    Join Date
    Nov 2012
    Beans
    1

    Re: Qt applications wrong system default language.

    I'm having the exact same issue on Xubuntu 13.04, Qt applications' menus are in Portuguese even though I set English as the system language. I have also not experienced this on previous versions. Help?

  3. #3
    Join Date
    Mar 2007
    Beans
    Hidden!

    [SOLUTION] Qt applications wrong system default language.

    I had the same problem after a fresh Kubuntu 13.04 installation. The installer sets the locales based on the geographical location supplied by the user.

    You can see the current locales with:
    Code:
    locale
    It seems that Qt checks the LC_NUMERIC variable to set the language, but it also works with LC_ALL, change both in /etc/default/locale to the desired local, for example "en_US.UTF-8":
    Code:
    LC_NUMERIC="en_US.UTF-8"
    LC_ALL="en_US.UTF-8"
    After saving the changes, run:
    Code:
    sudo locale-gen
    to update the locales. It is necessary to log-out and log-in again.

    More information: https://help.ubuntu.com/community/Locale

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •