Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Broken Packages - need to figure out which

  1. #11
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Broken Packages - need to figure out which

    But you said that apt-get upgrade did not return any error, so in which context do you get the errors from the first post ?
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  2. #12
    Join Date
    Oct 2012
    Beans
    13

    Re: Broken Packages - need to figure out which

    In the context of apt-get install ubuntu-gnome-desktop.

  3. #13
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by tyteen4a03 View Post
    In the context of apt-get install ubuntu-gnome-desktop.
    Code:
    apt-cache show ubuntu-gnome-desktop
    Package: ubuntu-gnome-desktop
    Priority: optional
    Section: universe/metapackages
    Installed-Size: 26
    Maintainer: Ubuntu GNOME Developers <ubuntu-gnome@lists.ubuntu.com>
    Architecture: i386
    Source: ubuntu-gnome-meta
    Version: 0.11
    I'm not quite sure I understand.. ubuntu-gnome-desktop is installed on a standard raring.

    If you want gnome 3.8, you need the gnome ppa and there are quite a few problems :
    https://launchpad.net/~gnome3-team/+archive/gnome3
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  4. #14
    Join Date
    Oct 2012
    Beans
    13

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by bapoumba View Post
    Code:
    apt-cache show ubuntu-gnome-desktop
    Package: ubuntu-gnome-desktop
    Priority: optional
    Section: universe/metapackages
    Installed-Size: 26
    Maintainer: Ubuntu GNOME Developers <ubuntu-gnome@lists.ubuntu.com>
    Architecture: i386
    Source: ubuntu-gnome-meta
    Version: 0.11
    I'm not quite sure I understand.. ubuntu-gnome-desktop is installed on a standard raring.

    If you want gnome 3.8, you need the gnome ppa and there are quite a few problems :
    https://launchpad.net/~gnome3-team/+archive/gnome3
    Yes, I want GNOME 3.8 instead of Unity. I added the PPA in 13.04.

    A few regressions is fine for me.

  5. #15
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by tyteen4a03 View Post
    The same packages I listed in my first post.
    The link in your first post is broken. You need to post the errors.

  6. #16
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by ibjsb4 View Post
    The link in your first post is broken. You need to post the errors.
    Probably something on your end, here is the error from post#1:
    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
     
    The following packages have unmet dependencies:
     gnome-shell : Depends: gir1.2-clutter-1.0 (>= 1.11.11) but it is not going to be installed
                   Depends: gir1.2-mutter-3.0 (>= 3.8.3) but it is not going to be installed
                   Depends: gir1.2-telepathyglib-0.12 but it is not installable
                   Depends: gir1.2-accountsservice-1.0 but it is not installable
                   Depends: gir1.2-gkbd-3.0 but it is not installable
                   Depends: gir1.2-ibus-1.0 (>= 1.4) but it is not installable
                   Depends: gir1.2-nmgtk-1.0 but it is not installable
                   Depends: gir1.2-polkit-1.0 but it is not installable
                   Depends: gir1.2-telepathylogger-0.2 (>= 0.8.0) but it is not installable
                   Depends: gir1.2-upowerglib-1.0 but it is not installable
     ubuntu-gnome-desktop : Depends: gnome-documents but it is not going to be installed
                            Depends: gnome-sushi but it is not going to be installed
                            Depends: gnome-tweak-tool but it is not going to be installed
                            Depends: itstool but it is not installable
                            Depends: yelp-tools but it is not installable
                            Recommends: cheese but it is not going to be installed
                            Recommends: deja-dup-backend-cloudfiles but it is not going to be installed
                            Recommends: deja-dup-backend-s3 but it is not going to be installed
                            Recommends: evolution but it is not going to be installed
                            Recommends: gnome-search-tool but it is not going to be installed
                            Recommends: plymouth-theme-ubuntu-gnome-logo but it is not going to be installed
                            Recommends: plymouth-theme-ubuntu-gnome-text but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  7. #17
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: Broken Packages - need to figure out which

    What ya got in your PPAs?

    Code:
    ls /etc/apt/sources.list.d
    And thanks bapoumba

  8. #18
    Join Date
    Oct 2012
    Beans
    13

    Re: Broken Packages - need to figure out which

    Quote Originally Posted by ibjsb4 View Post
    What ya got in your PPAs?

    Code:
    ls /etc/apt/sources.list.d
    And thanks bapoumba
    gnome3-team-gnome3-raring.list
    gnome3-team-gnome3-raring.list.save
    google-chrome.list
    google-chrome.list.save
    nilarimogard-webupd8-raring.list
    private-ppa.launchpad.net_commercial-ppa-uploaders_steam_ubuntu.list
    private-ppa.launchpad.net_commercial-ppa-uploaders_steam_ubuntu.list.save
    skype-wrapper-ppa-raring.list
    skype-wrapper-ppa-raring.list.save
    steam.list
    steam.list.save

  9. #19
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: Broken Packages - need to figure out which

    I would like to see if any of the other PPAs are conflicting with gnome3 ppa.

    Open your software sources and UNcheck all PPAs except gnome3-team-gnome3 and then do another update.

  10. #20
    Join Date
    Jun 2013
    Location
    Somewhere on Earth.
    Beans
    345
    Distro
    Ubuntu 13.10 Saucy Salamander

    Exclamation Re: Broken Packages - need to figure out which

    Quote Originally Posted by tyteen4a03 View Post
    Yes, I want GNOME 3.8 instead of Unity. I added the PPA in 13.04.

    A few regressions is fine for me.
    The GNOME 3.8 PPA can break some packages (I tried it myself, broke Ubuntu-Tweak and some other packages). Try:

    Code:
    sudo apt-get install ppa-purge
    ppa-purge ppa:gnome3-team/gnome3
    In the last command, make sure you see which packages are going to be removed before you press Y (packages that should NOT be removed are stuff like 'ubuntu-desktop', 'ubuntu-branding', 'ubuntu-minimal', 'firefox', and others)!!!

    Edit: make sure you enable the gnome-3 ppa before running ppa-purge.

    @bapoumba: No, 'ubuntu-gnome-desktop' should not be on a standard ubuntu raring. 'ubuntu-desktop', 'ubuntu-branding' and 'ubuntu-minimal' should though.
    I recommend a full ubuntu installation rather than a wubi install. Ask me why.
    To migrate from wubi, click here. (by bcbc)
    Status: Online
    https://help.ubuntu.com/community/UEFI, and Buggy UEFI solution.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •