Results 1 to 8 of 8

Thread: iBus

  1. #1
    Join Date
    Sep 2008
    Beans
    526
    Distro
    Ubuntu 12.04 Precise Pangolin

    iBus

    I use iBus for switching text input to other languages. But recently i have notices i am not able to enter non latin text in Skype. Though i can type those text in leafpad and then copy paste it in skype. This problem also occurs with some websites but Skype is the main problem area for me.

  2. #2
    Join Date
    Jul 2007
    Location
    Auckland, NZ
    Beans
    3,680
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: iBus

    I believe that skype uses QT. Do you have ibus-qt4 installed? If not, install that and see if it helps.
    Please, people, remember to BACKUP before you install that new system. Same if you're upgrading.

  3. #3
    Join Date
    Sep 2008
    Beans
    526
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: iBus

    Quote Originally Posted by Irihapeti View Post
    I believe that skype uses QT. Do you have ibus-qt4 installed? If not, install that and see if it helps.
    Sorry it did not help. In fact i noticed it was also not able to type in other language in Synaptic search bar.

  4. #4
    Join Date
    Jul 2007
    Location
    Auckland, NZ
    Beans
    3,680
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: iBus

    Open a terminal (ctrl-alt-t) and enter the command:
    Code:
    im-switch
    That should open a window showing a number of choices for the input method.

    Does it show the correct language/locale setting at the top of that window? If not, you may need to change that first.

    Is "use IBus" selected? If not, select it and click OK.

    You'll need to logout and in again (or reboot) before you can check if it's made any difference.

    If this doesn't work, I'm out of ideas, unfortunately. Maybe someone else can help.
    Please, people, remember to BACKUP before you install that new system. Same if you're upgrading.

  5. #5
    Join Date
    Sep 2008
    Beans
    526
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: iBus

    Quote Originally Posted by Irihapeti View Post
    Open a terminal (ctrl-alt-t) and enter the command:
    Code:
    im-switch
    That should open a window showing a number of choices for the input method.

    Does it show the correct language/locale setting at the top of that window? If not, you may need to change that first.

    Is "use IBus" selected? If not, select it and click OK.

    You'll need to logout and in again (or reboot) before you can check if it's made any difference.

    If this doesn't work, I'm out of ideas, unfortunately. Maybe someone else can help.

    This does not seems to be a solution as i can type in most of other applications. Just a few of them are not able to do so.

  6. #6
    Join Date
    Jul 2007
    Location
    Auckland, NZ
    Beans
    3,680
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: iBus

    It looks as though other people have been having problems with IBus and skype: https://code.google.com/p/ibus/issues/detail?id=613

    It deals with an older version of Ubuntu but may still be helpful.

    http://askubuntu.com/questions/24733...skype-4-1-0-20 may also be helpful.
    Please, people, remember to BACKUP before you install that new system. Same if you're upgrading.

  7. #7
    Join Date
    Sep 2008
    Beans
    526
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: iBus

    As i see now, using i-bus i can not input non english text even in the synaptic search bar. Well i know you might ask me, why would anyone do that but technically, just like skype, it is not possible both in 12.04 and 13.04.

  8. #8
    Join Date
    Sep 2008
    Beans
    526
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: iBus

    I have also noticed, i am not able to type in non-english characters in the text box of many websites.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •