Results 1 to 7 of 7

Thread: Time is not updated Correctly in Dual OS

  1. #1
    Join Date
    Aug 2012
    Beans
    76

    Talking Time is not updated Correctly in Dual OS

    Hi,

    I installed Dual OS are Ubuntu and Windows 8, when ever I using this OS simultaneously or not simultaneously both the OS time is not up to date. Please guide me how to fix this small issue and what is the root cause of this issue.

  2. #2
    Join Date
    Jul 2008
    Location
    U.S.A
    Beans
    1,331
    Distro
    Ubuntu Development Release

    Re: Time is not updated Correctly in Dual OS

    You probably did not set your location when, at least on Ubuntu, when you did the install.

    Just clock on the time at the top right of your Ubuntu Taskbar and click "Time and Date Settings". you can choose your correct time zone there.
    If i remember correctly, It's the same with Windows. Just click on the time and you can change your settings.

  3. #3
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    8,040
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Time is not updated Correctly in Dual OS

    Sometimes there is a setting in your computer's BIOS to set the time to UTC (universal time). Also, there is a switch within Windows to set time to UTC, but you will have to search for it. Linux uses UTC as the time base and offsets it with your timezone to display the correct time.

    If you log into Windows and local time base is used then when you shut down the local time base is stored to BIOS time. When you then boot into linux, the local time is read and treated as UTC which then incorrectly displays your time as + or - your timezone offset. Annoying but fixable.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  4. #4
    Join Date
    Aug 2012
    Beans
    76

    Talking Re: Time is not updated Correctly in Dual OS

    Quote Originally Posted by tgalati4 View Post
    Sometimes there is a setting in your computer's BIOS to set the time to UTC (universal time). Also, there is a switch within Windows to set time to UTC, but you will have to search for it. Linux uses UTC as the time base and offsets it with your timezone to display the correct time.

    If you log into Windows and local time base is used then when you shut down the local time base is stored to BIOS time. When you then boot into linux, the local time is read and treated as UTC which then incorrectly displays your time as + or - your timezone offset. Annoying but fixable.
    I did not get U. How to Fix, please guide how to update this in BIOS setting.
    I already selected my Home Country in Ubuntu and Windows 8. But I did not find out where the problem raised.

  5. #5
    Join Date
    Jul 2008
    Location
    U.S.A
    Beans
    1,331
    Distro
    Ubuntu Development Release

    Re: Time is not updated Correctly in Dual OS

    Just enter your BIOS and look around if there is a way to edit the time.

  6. #6
    Join Date
    May 2007
    Beans
    12,490

    Re: Time is not updated Correctly in Dual OS

    Change Ubuntu to use localtime.

    To make the change in Ubuntu, edit edit /etc/default/rcS and change

    UTC=yes to no, like this:

    Code:
    # assume that the BIOS clock is set to UTC time (recommended)
    UTC=no
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  7. #7
    Join Date
    Aug 2012
    Beans
    76

    Re: Time is not updated Correctly in Dual OS

    Quote Originally Posted by Mark Phelps View Post
    Change Ubuntu to use localtime.

    To make the change in Ubuntu, edit edit /etc/default/rcS and change

    UTC=yes to no, like this:

    Code:
    # assume that the BIOS clock is set to UTC time (recommended)
    UTC=no
    Thanks for your help.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •