Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: No brightness control at all? (No slider)

  1. #1
    Join Date
    Aug 2013
    Beans
    33

    No brightness control at all? (No slider)

    After finally getting my correct resolution, I'm now trying the simple matter of changing the brightness level. The problem, as mentioned in the subject line, there is no brightness control. I looked up and down in the forums and Googled it and there seems to be multiple solutions, none of which really appeal to me, which is that I want my brightness and lock settings to show up and work.

    (Simple resolution fix for those who may want to know: log into Guest Session, hopefully resolution is correct there or you can choose it, if so, save xorg.conf and copy contents and paste into YOUR session's xorg.conf file.)

    Thanks!

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No brightness control at all? (No slider)

    Can you provide some more information? Specifically (enter the commands below in a terminal window):
    1. The make and model of your computer.
    2. Your video card(s):
      Code:
      lspci -k | grep -A3 VGA
    3. Your current kernel command line:
      Code:
      cat /proc/cmdline
    4. Your backlight interfaces and some of their settings:
      Code:
      for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/max_brightness; done

  3. #3
    Join Date
    Aug 2013
    Beans
    33

    Re: No brightness control at all? (No slider)

    1. It's custom built. Bought the parts on Newegg and put it together myself. I'm happy to tell you what you need to know regarding the set-up.

    2. 2 EVGA GeForce 460 GTX in SLI configuration, but not enabled. - http://paste.ubuntu.com/5982990/

    3. http://paste.ubuntu.com/5982994/

    4. http://paste.ubuntu.com/5983001/

    Interesting...apparently I have no backlight according to #4?

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No brightness control at all? (No slider)

    Quote Originally Posted by gabe2 View Post
    Interesting...apparently I have no backlight according to #4?
    Indeed. This would be the reason that you have no brightness slider. Can you try a couple of kernel parameters? See the "Kernel Boot Parameters" link in my signature for information on how. I would suggest trying:

    1. acpi_osi=\"!Windows 2012\"
      The relevant lines in /etc/default/grub should look like this:
      Code:
      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
      GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
      ...make sure to run "sudo update-grub" and reboot.


    2. acpi_backlight=vendor
      The relevant lines in /etc/default/grub should look like this:
      Code:
      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
      GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

    With each attempt, post back the results of:
    Code:
    cat /proc/cmdline
    ...and
    Code:
    for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/max_brightness; done
    If you get a backlight interface, check your brightness slider.

  5. #5
    Join Date
    Aug 2013
    Beans
    33

    Re: No brightness control at all? (No slider)

    Thanks, I'll have to try that tomorrow when I'm not so tired and heading for bed. Will update.

  6. #6
    Join Date
    Aug 2013
    Beans
    33

    Re: No brightness control at all? (No slider)

    No luck, the brightness slider remains missing...

    Here are the results of those commands: http://paste.ubuntu.com/5986671/

    What could cause it to go missing? Thanks for your help so far.

  7. #7
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No brightness control at all? (No slider)

    That really is odd. Can you pastebin back your /var/log/Xorg.0.log and /var/log/dmesg log files?

    Anything in the bios about brightness?

    Can I also which modules are loaded:
    Code:
    lsmod
    ...and
    Code:
    xrandr -q

  8. #8
    Join Date
    Aug 2013
    Beans
    33

    Re: No brightness control at all? (No slider)

    I can't say I saw anything for brightness in the BIOS, I'll have to look, but I doubt it.
    *EDIT* Confirmed, I couldn't find anything in BIOS with regards to brightness.

    Xorg.0.log file: http://paste.ubuntu.com/5987302/

    dmesg file: http://paste.ubuntu.com/5987306/

    lsmod: http://paste.ubuntu.com/5987309/

    xrandr -q: http://paste.ubuntu.com/5987310/
    Last edited by gabe2; August 15th, 2013 at 03:33 AM.

  9. #9
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No brightness control at all? (No slider)

    Do the following commands change brightness:
    Code:
    xrandr --output  DVI-I-2 --brightness 0.5
    xrandr --output  DVI-I-2 --brightness 0.8
    xrandr --output  DVI-I-2 --brightness 1.0
    Can you post back /etc/X11/xorg.conf?

    And can you remove the "acpi_backlight=vendor" kernel parameter and try the "acpi_osi=" kernel parameter instead? After boot, check to see if you have any backligt interfaces and post back /var/log/dmesg again.

    Now this is interesting. The i915 driver is loaded. Do you have an onbaord intel graphics chip? If so, can you disable it in the bios?
    Last edited by Toz; August 15th, 2013 at 02:07 PM.

  10. #10
    Join Date
    Aug 2013
    Beans
    33

    Re: No brightness control at all? (No slider)

    Quote Originally Posted by Toz View Post
    Do the following commands change brightness:
    Code:
    xrandr --output  DVI-I-2 --brightness 0.5
    xrandr --output  DVI-I-2 --brightness 0.8
    xrandr --output  DVI-I-2 --brightness 1.0
    Yes, they do. I have it currently set at 0.8, that's about right for me.


    Can you post back /etc/X11/xorg.conf?
    Here: http://paste.ubuntu.com/5990583/


    And can you remove the "acpi_backlight=vendor" kernel parameter and try the "acpi_osi=" kernel parameter instead? After boot, check to see if you have any backligt interfaces and post back /var/log/dmesg again.
    Nope, no backlight interface
    dmesg file: http://paste.ubuntu.com/5990661/

    Now this is interesting. The i915 driver is loaded. Do you have an onbaord intel graphics chip? If so, can you disable it in the bios?
    Yes, I have onboard VGA, and it is disabled.

    Would I have to set the brightness in the terminal every time I boot? Is there a way to make the change permanent? Of course, I would much rather have the interface show up and work correctly as designed, but as a last resort, I can do the terminal fix if there's a persistent way to do it.
    Last edited by gabe2; August 15th, 2013 at 10:57 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •