Results 1 to 5 of 5

Thread: USB ports sometimes stop working, reboot needed

  1. #1
    Join Date
    Jul 2009
    Beans
    94

    USB ports sometimes stop working, reboot needed

    Hi all,

    Occasionally my USB ports will not recognize any device that I have plugged in to them. The only way I can remedy the problem is to do a reboot. Anyone have any ideas what may be causing this or how I can go about troubleshooting the problem?

    Thanks in advance,
    Chris

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: USB ports sometimes stop working, reboot needed

    Does it always happen with the same device or is it random ?
    What does lsusb outputs ?
    I will be off shortly (night here) but others will help you
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  3. #3
    Join Date
    Jul 2009
    Beans
    94

    Re: USB ports sometimes stop working, reboot needed

    It appears to be random. lsusb outputs:

    lsusb
    Bus 001 Device 002: ID 04f2:b272 Chicony Electronics Co., Ltd Lenovo EasyCamera
    Bus 002 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. Card reader
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: USB ports sometimes stop working, reboot needed

    I'm not on my ubuntu box so I cannot check if these are still valid :
    https://help.ubuntu.com/community/DebuggingUSBStorage
    https://wiki.ubuntu.com/DebuggingRemovableDevices

    I'll be moving this thread to the Hardware forum so that others may be able to help you troubleshoot your setup.
    Edit : moved.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  5. #5
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: USB ports sometimes stop working, reboot needed

    I'm very attentive to USB error messages. There's a problem right now with the current kernels.

    Here's something to try. open a terminal and type the following:
    Code:
    tail -f /var/log/syslog
    Then plug in your USB device and observe the outputs. If it doesn't mount right away, give it time-around 6 minutes.
    Then bring back the results.
    boot_info_script | AMD64 Athlon X2 Dual-Core - nVidia Geforce 6150 SE - 4GB DDR3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •