Results 1 to 5 of 5

Thread: Mouse Acceleration

  1. #1
    Join Date
    Aug 2012
    Beans
    5

    Mouse Acceleration

    Oukay... Before anything, I'd like to say that english is not my main language... So, uh, sorry about my grammar mistakes...

    Anyway, heres the thing: i finally decided to man up and use linux... Only linux.
    And as all newbies/windows 8 I'm having some silly adaptation issues...
    The most annoying one is related to mouse acceleration/sensitivity... I'm using a Razer Imperator, and it's quite hard to use it here... I move it a inch and the cursor flew through the screen...

    I googled for a while and found that:

    xinput set-prop 10 'Evdev Middle Button Emulation' 0
    xinput set-prop 10 'Device Accel Profile' -1
    xinput set-prop 10 'Device Accel Velocity Scaling' 1

    helps a lot, but the sensitivity still quite high... At least the acceleration is gone...
    Idk why, but xinput gave my Razer Imperator 2 ids...
    So I have to type this twice, one for id 10 and another for id 11...

    I'd like to create a start up script to run this commands...
    I tried to... I opened gedit and wrote:

    #!/bin/bash
    #wait for the desktop to settle
    sleep 5
    # turn off mouse acceleration
    xinput set-prop 10 'Evdev Middle Button Emulation' 0
    xinput set-prop 10 'Device Accel Profile' -1
    xinput set-prop 10 'Device Accel Velocity Scaling' 1
    xinput set-prop 11 'Evdev Middle Button Emulation' 0
    xinput set-prop 11 'Device Accel Profile' -1
    xinput set-prop 11 'Device Accel Velocity Scaling' 1

    saved it as noaccel.sh

    Now what? D:

  2. #2
    Join Date
    Aug 2012
    Beans
    5

    Re: Mouse Acceleration

    Bump...

    ps: sorry if posted this in the wrong forum

  3. #3
    Join Date
    Mar 2012
    Location
    /home/ubun2to
    Beans
    356
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Mouse Acceleration

    Settings>Mouse and Touchpad should help.
    You can adjust the acceleration and sensitivity of the mouse from here.
    Backups are amazing. 99% of data loss can be prevented by spending less than $100 on an external drive.
    If you have seen an error, there is a good chance someone else has, too. Google is your friend.

  4. #4
    Join Date
    Jul 2012
    Location
    somewhere on earth
    Beans
    16

    Re: Mouse Acceleration

    Quote Originally Posted by Trauer View Post
    Oukay... Before anything, I'd like to say that english is not my main language... So, uh, sorry about my grammar mistakes...

    Anyway, heres the thing: i finally decided to man up and use linux... Only linux.
    And as all newbies/windows 8 I'm having some silly adaptation issues...
    The most annoying one is related to mouse acceleration/sensitivity... I'm using a Razer Imperator, and it's quite hard to use it here... I move it a inch and the cursor flew through the screen...

    I googled for a while and found that:

    xinput set-prop 10 'Evdev Middle Button Emulation' 0
    xinput set-prop 10 'Device Accel Profile' -1
    xinput set-prop 10 'Device Accel Velocity Scaling' 1

    helps a lot, but the sensitivity still quite high... At least the acceleration is gone...
    Idk why, but xinput gave my Razer Imperator 2 ids...
    So I have to type this twice, one for id 10 and another for id 11...

    I'd like to create a start up script to run this commands...
    I tried to... I opened gedit and wrote:

    #!/bin/bash
    #wait for the desktop to settle
    sleep 5
    # turn off mouse acceleration
    xinput set-prop 10 'Evdev Middle Button Emulation' 0
    xinput set-prop 10 'Device Accel Profile' -1
    xinput set-prop 10 'Device Accel Velocity Scaling' 1
    xinput set-prop 11 'Evdev Middle Button Emulation' 0
    xinput set-prop 11 'Device Accel Profile' -1
    xinput set-prop 11 'Device Accel Velocity Scaling' 1

    saved it as noaccel.sh

    Now what? D:
    just add it to your ~/.bashrc file
    i.e.
    Code:
    echo "/path/to/noaccel.sh&">>~/.bashrc


    (i use this for my razer naga- with dpi maxed)
    and here is my script:
    Code:
    xinput set-prop 'pointer:Razer Razer Naga' 'Evdev Middle Button Emulation' 1
    xinput set-prop 'pointer:Razer Razer Naga' 'Device Accel Profile' -1
    xinput set-prop 'pointer:Razer Razer Naga' 'Device Accel Velocity Scaling' 1
    xinput set-prop 'pointer:Razer Razer Naga' 'Device Accel Constant Deceleration' 2

    hope that helps...

  5. #5
    Join Date
    Aug 2013
    Beans
    1

    Re: Mouse Acceleration

    hey sorry to up this thread but i have the same issues with my mouse aceleration + 2 time razer imperator

    i don't understand this part :

    just add it to your ~/.bashrc file
    i.e.Code:
    echo "/path/to/noaccel.sh&">>~/.bashrc

    Can you help me pls ?

    I do it in terminal wit my path and it will start up in everyboot ?

    my xinput :
    Code:
    xinput
    ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
    ⎜   ↳ Razer Razer Imperator                       id=8    [slave  pointer  (2)]
    ⎜   ↳ Razer Razer Imperator                       id=9    [slave  pointer  (2)]
    ⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
        ↳ Power Button                                id=6    [slave  keyboard (3)]
        ↳ Power Button                                id=7    [slave  keyboard (3)]
        ↳ Eee PC WMI hotkeys                          id=10    [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard                id=11    [slave  keyboard (3)]
    Last edited by vocalstatic; August 6th, 2013 at 03:25 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •