Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Strange wifi problem

  1. #1
    Join Date
    Jan 2011
    Beans
    45

    Strange wifi problem

    Im having a strange problem with my wifi. Its very slow when ever my laptop running ubuntu 13.04 is connected to it.

    My setup: asus n16 router running asuswrt-merlin fw (have also tried with dd-wrt), wifi is secured with wpa2 personal.
    Server is running ubuntu 13.04 and is connected to the router by cable.

    When I'm copying a file from the server to my android tablet via wifi im getting speeds between 20 and 40 kb/s when my laptop is connected to the same network. As soon i disconnect the laptop the transfer speed to the tablet goes up to about 3mb/s.
    When i reconnect the laptop the speed drops again.

    Any ideas why this is happening?

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,281
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Strange wifi problem

    There is a driver that is known to hog the bandwidth. Let's see if you have it. Please open a terminal and run and post:
    Code:
    lspci -nn | grep 0280
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jan 2011
    Beans
    45

    Re: Strange wifi problem

    Here you go

    Code:
    12:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,281
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Strange wifi problem

    There are two drivers that drive this device, each with varying degrees of success. Let's see which you have:
    Code:
    lsmod | grep -e wl -e brcmsmac
    ------

    EDIT: Note to chili: http://ubuntuforums.org/showthread.php?t=2131244 (Wrong way to do it, but use brcmsmac instead of wl???)
    Last edited by chili555; August 5th, 2013 at 05:15 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jan 2011
    Beans
    45

    Re: Strange wifi problem

    Code:
     lsmod | grep -e wl -e brcmsmac
    wl                   3074449  0 
    lib80211               14352  2 wl,lib80211_crypt_tkip
    cfg80211              510937  1 wl

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,281
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Strange wifi problem

    Quote Originally Posted by mbeltoft View Post
    Code:
     lsmod | grep -e wl -e brcmsmac
    wl                   3074449  0 
    lib80211               14352  2 wl,lib80211_crypt_tkip
    cfg80211              510937  1 wl
    Let's try the other driver.
    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    sudo modprobe -r wl
    sudo modprobe brcmsmac
    Any improvement? It may take a reboot.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Jan 2011
    Beans
    45

    Re: Strange wifi problem

    got at error on the second commando:

    sudo modprobe -r wl
    FATAL: Module wl not found.

    and the last one don't give me any output so don't know if it was working or not.

    rebooting now to check if its working


    EDIT: it looks like its working. I can get the expected speed on a file transfer while the laptop is connected.

    thanks for the help
    Last edited by mbeltoft; August 5th, 2013 at 08:28 PM.

  8. #8
    Join Date
    May 2007
    Beans
    29

    Re: Strange wifi problem

    Hey Chili555.

    I had the same problem as mbeltoft. My wifi was working great, but it was a bandwidth hog. I followed your instructions, and got the other driver working. But now, I am creeping along with seriously slow speeds, or it just disconnects.

    Got any ideas?

    Thanks

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,281
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Strange wifi problem

    Quote Originally Posted by Chet Hardin View Post
    Hey Chili555.

    I had the same problem as mbeltoft. My wifi was working great, but it was a bandwidth hog. I followed your instructions, and got the other driver working. But now, I am creeping along with seriously slow speeds, or it just disconnects.

    Got any ideas?

    Thanks
    Which Ubuntu version do you have?
    Code:
    lsb_release -d
    arch
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    May 2007
    Beans
    29

    Re: Strange wifi problem

    Hey.

    13.04 and x86 64

    Thanks.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •