Results 1 to 5 of 5

Thread: Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubuntu

  1. #1
    Join Date
    Feb 2008
    Beans
    6

    Question Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubuntu

    I've got a weird problem here, my new Ubuntu install can access the internet, ping other computers on the wireless LAN, ping servers outside the network (ie: google.com), and ssh into itself using its network ip (10.0.0.119 and also 127.0.0.1). The problem is that no other devices on the network can see, ping, or ssh into Ubuntu unless I ping the other computer first from Ubuntu. After I ping the second or third computer from Ubuntu, I have maybe 60 seconds to initiate some sort of network traffic from the second computer to Ubuntu, or else it disappears again. If I ssh into Ubuntu during that time, I'll remain connected until I choose to disconnect, but then a minute or so later, I can't talk to Ubuntu at all. Even weirder, if I have Computer A pinging Ubuntu indefinitely, and Computer B pinging Ubuntu indefinitely, at first neither one will get any response. If I ping Computer A from Ubuntu, then Computer A will instantly start getting a response, but Computer B will not get anything. Visa versa works too, pinging Computer B from Ubuntu results in Computer B seeing Ubuntu, but Computer A still doesn't.

    I've got Ubuntu set up with DHCP, but the router has a reservation for 10.0.0.119 set up for Ubuntu's MAC address. Also, ifconfig says that Ubuntu's IP is 10.0.0.119 throughout all my experiments, so I know I'm still pinging the right IP.

    Running nmap on Ubuntu , it can see any device on the network. I don't have another Linux machine to test to see if any other computer can see Ubuntu with nmap, but running Fing (a network mapper similar to nmap) on my Android tablet finds all the other devices, except Ubuntu.

    I'd really like to know what's making it so that Ubuntu has to initiate communication with another computer before that computer and only that computer can talk to it at all.

    Thanks.

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,655
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubu

    Did you configure a firewall? Please show
    Code:
    route -n
    cat /etc/resolv.conf
    cat /etc/network/interfaces
    lsmod
    ifconfig -a

  3. #3
    Join Date
    Feb 2008
    Beans
    6

    Re: Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubu

    Quote Originally Posted by praseodym View Post
    Did you configure a firewall? Please show
    Code:
    route -n
    cat /etc/resolv.conf
    cat /etc/network/interfaces
    lsmod
    ifconfig -a
    I don't have any configured firewall on Ubuntu. There is a firewall on my router, but it only affects traffic coming to and from the internet, not the intranet.

    Code:
    root@Hannahs-Netbook:~# route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         10.0.0.1        0.0.0.0         UG    0      0        0 eth1
    10.0.0.0        0.0.0.0         255.255.255.0   U     9      0        0 eth1
    169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
    Code:
    root@Hannahs-Netbook:~# cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 10.0.0.1
    search gateway.2wire.net
    Code:
    root@Hannahs-Netbook:~# cat /etc/network/interfaces
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    # primary network interface
    auto eth1
    iface eth1 inet dhcp
    Code:
    root@Hannahs-Netbook:~# lsmod
    Module                  Size  Used by
    michael_mic            12540  8
    arc4                   12543  4
    parport_pc             27504  0
    bnep                   17669  2
    rfcomm                 37420  0
    ppdev                  12817  0
    bluetooth             202109  10 bnep,rfcomm
    snd_hda_codec_idt      63896  1
    lib80211_crypt_tkip    17160  0
    snd_hda_intel          38307  3
    joydev                 17097  0
    wl                   2902185  0
    snd_hda_codec         117580  2 snd_hda_codec_idt,snd_hda_intel
    coretemp               13131  0
    uvcvideo               71279  0
    i915                  535544  3
    snd_hwdep              13272  1 snd_hda_codec
    snd_pcm                80890  2 snd_hda_codec,snd_hda_intel
    hp_wmi                 17712  0
    videobuf2_vmalloc      12920  1 uvcvideo
    sparse_keymap          13658  1 hp_wmi
    videobuf2_memops       13042  1 videobuf2_vmalloc
    snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
    videobuf2_core         39161  1 uvcvideo
    snd_seq_midi           13132  0
    snd_seq_midi_event     14475  1 snd_seq_midi
    snd_rawmidi            25114  1 snd_seq_midi
    videodev               95806  2 uvcvideo,videobuf2_core
    snd_seq                51280  2 snd_seq_midi_event,snd_seq_midi
    drm_kms_helper         47545  1 i915
    lib80211               14040  2 wl,lib80211_crypt_tkip
    drm                   228489  4 i915,drm_kms_helper
    snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
    snd_timer              24411  2 snd_pcm,snd_seq
    cfg80211              436177  1 wl
    microcode              18286  0
    psmouse                81038  0
    snd                    56485  15 snd_hwdep,snd_timer,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_$odec,snd_hda_intel,snd_seq_device
    i2c_algo_bit           13197  1 i915
    lpc_ich                16925  0
    serio_raw              13031  0
    soundcore              12600  1 snd
    wmi                    18590  1 hp_wmi
    mac_hid                13037  0
    video                  18894  1 i915
    lp                     13299  0
    parport                40753  3 lp,ppdev,parport_pc
    ahci                   25507  2
    libahci                26108  1 ahci
    r8169                  61543  0
    Code:
    root@Hannahs-Netbook:~# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 3c:4a:92:53:69:52
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    eth1      Link encap:Ethernet  HWaddr ac:81:12:30:9a:23
              inet addr:10.0.0.119  Bcast:10.0.0.255  Mask:255.255.255.0
              inet6 addr: fe80::ae81:12ff:fe30:9a23/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:86007 errors:80 dropped:0 overruns:0 frame:218589
              TX packets:71441 errors:13 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:107168252 (107.1 MB)  TX bytes:6227819 (6.2 MB)
              Interrupt:17
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:6283 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6283 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:282244 (282.2 KB)  TX bytes:282244 (282.2 KB)

  4. #4
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,655
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubu

    Remove anything except both lines with "lo" from the "interfaces" and reboot.

  5. #5
    Join Date
    Feb 2008
    Beans
    6

    Re: Can't ping new Ubuntu 13.04 install unless I first ping another computer from Ubu

    Quote Originally Posted by praseodym View Post
    Remove anything except both lines with "lo" from the "interfaces" and reboot.
    Originally it only contained the first 3 lines about "lo" and I was having this problem, I added the lines about "eth1" to try to fix it.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •