Results 1 to 6 of 6

Thread: User missing from KDE login screen

  1. #1
    Join Date
    May 2009
    Beans
    4

    Question User missing from KDE login screen

    I changed my uid (from 1000 to 500) to access an NFSv4 filesystem and after booting back up, my user is no longer listed as a login option on the KDE screen. Only "guest" is shown. Do I have to do something to tell KDE about the users available in the system?

    Console login works fine.


    Thanks.

  2. #2
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: User missing from KDE login screen

    By default only users with a UID of 1000+ are shown by the display manager as UID's less than 1000 are usually reserved for system accounts.

    Try editing the /etc/kde4/kdm/kdmrc file and changing the MinShowUID variable.
    Cheesemill

  3. #3
    Join Date
    May 2009
    Beans
    4

    Re: User missing from KDE login screen

    I checked, and didn't have that file, so I created it and put in MinShowUID=500, but it still only shows the guest user. (This is 13.04 kubuntu).

    Running "find / -type f -iname "*kdmrc*" didn't return anything before creating it.

  4. #4
    Join Date
    May 2009
    Beans
    4

    Re: User missing from KDE login screen

    I also tried MinShowUID=499, no luck there, either.

  5. #5
    Join Date
    Apr 2012
    Beans
    6,123

    Re: User missing from KDE login screen

    If you don't have /etc/kde4/kdm/kdmrc then likely you are not running kdm as your display manager - I think possibly kubuntu switched to lightdm as the default dm in 13.04?

    If that's the case, then the equivalent file would be /etc/lightdm/users.conf and the parameter to change is minimum-uid

    Code:
    [UserAccounts]
    minimum-uid=500
    hidden-users=nobody nobody4 noaccess
    hidden-shells=/bin/false /usr/sbin/nologin

  6. #6
    Join Date
    May 2009
    Beans
    4

    Re: User missing from KDE login screen

    That was it.

    I already had the above entries in users.conf, so I checked /etc/login.defs (saw the comment in users.conf about AccountsService) and changed the UID_MIN & GID_MIN settings down to 500 from 1000. Now my acct shows on the KDE login screen.

    Thanks!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •