Results 1 to 9 of 9

Thread: Sound not recognized by gnome

  1. #1
    Join Date
    Jul 2013
    Beans
    11

    Sound not recognized by gnome

    Hello,

    first of all, I'm pretty new to this forum and gnome3.

    I'm running Ubuntu GNOME 13.04 (raring) on my Sony Vaio VPCSE1V9E. My sound is working perfectly and I can control everything using alsamixer. However, there is no sound icon in my top bar and in System Settings -> Sound underneath where it says "Choose a device for sound output:" there is no element in the listbox. I also cannot use my volume-up and -down buttons on my keyboard which used to work on Kubuntu.

    Thank you in advance,
    doublerainbow64

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

  3. #3
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    Thanks for you help! I just tried that out. indicator-sound installs without any problems and I rebooted afterwards. However, the problem persists. Something else I'm supposed to do? In the thread, you mentioned, the guy says he cannot open gnome-volume-control-applet. I have the same problem, the command is not recognized by my system.

  4. #4
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    I tried this:

    Code:
    sudo apt-get remove --purge alsa-base
    sudo apt-get remove --purge pulseaudio
    sudo apt-get install alsa-base
    sudo apt-get install pulseaudio
    sudo alsa force-reload
    And this:

    Code:
    sudo adduser my-login-name audio
    No effect.

  5. #5
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Sound not recognized by gnome

    the logs might help you find what is wrong : /var/log/ & .xsession-errors (ctrl+h to unhide it)
    https://help.ubuntu.com/community/So...otingProcedure

  6. #6
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    I'll take a look at that.

    Another hint, that might help: When I log out from my user account, the sound-icon in the top bar reappears and is working properly. I created a new user account and logged in, the sound icon disappeared.
    In addition, when I try to open gnome-sound-applet in terminal, it says:

    Code:
    (gnome-sound-applet:5125): sound-cc-panel-WARNING **: Failed to connect context: Connection refused
    In another thread I found somebody complaining, that KDE apps cause this problem and deactivating sound notifications in KDE System Settings helped. I did so, but this did not have any effect either.

  7. #7
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    I'm still here, I hope somebody else is with me.

  8. #8
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    I think I know, what the problem might be. When I run pulseaudio in terminal it returns:

    Code:
    $ pulseaudio
    E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
    I moved my home directory to a NTFS partition after installing Ubuntu GNOME. This could have caused some trouble. Any ideas, how to fix that?

    EDIT: Seems like this is the problem. Anybody any suggestions?
    Last edited by doublerainbow64; July 31st, 2013 at 07:53 PM.

  9. #9
    Join Date
    Jul 2013
    Beans
    11

    Re: Sound not recognized by gnome

    Well, I just reinstalled my system, using an EXT4 as /home directory. Thanks for your help anyway.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •