Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Can't Connect to Wireless Networks

  1. #1
    Join Date
    Jul 2013
    Beans
    16

    Smile Can't Connect to Wireless Networks

    First of all, hi guys! i'm new to Ubuntu, used to be a Windows / Mac user for ages. So.. i wanted to try Ubuntu 12.04 (i tried also 13.04 i was curious) on an old laptop that i have before installing ubuntu as my primary OS in my desktop. i have a Toshiba Satellite M70-191, it runs ubuntu just fine but i can't connect to any of the available wireless networks (free or locked ones) i searched for a driver (probably Intel 915GM) but nothin'. i also saw here in the forums that other users experience problems when trying to connect to a wifi network. Any kind of help or advice?
    Last edited by dinodxr; July 17th, 2013 at 10:33 PM.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,697
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Connect to Wireless Networks

    Hi dinodxr. Welcome to the forums

    Could you open a terminal run this commands and paste its results back?
    Code:
    sudo lshw -C network
    
    lspci -nnk | grep -iA2 net
    
    ifconfig
    
    route -n
    Regards.

  3. #3
    Join Date
    Jul 2013
    Beans
    16

    Re: Can't Connect to Wireless Networks

    dinodxr@dinodxr-M70:~$ sudo lshw -C network
    [sudo] password for dinodxr:
    PCI (sysfs)
    *-network:0
    description: Ethernet interface
    product: RTL-8139/8139C/8139C+
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 1
    bus info: pci@0000:06:01.0
    logical name: eth0
    version: 10
    serial: 00:0f:b0:de:11:96
    size: 100Mbit/s
    capacity: 100Mbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.0.5 latency=32 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
    resources: irq:21 ioport:5000(size=256) memory:bc006000-bc0060ff
    *-network:1 DISABLED
    description: Wireless interface
    product: PRO/Wireless 2200BG [Calexico2] Network Connection
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:06:02.0
    logical name: eth1
    version: 05
    serial: 00:16:6f:11:b5:8a
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) latency=32 link=no maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
    resources: irq:22 memory:bc007000-bc007fff

    dinodxr@dinodxr-M70:~$ lspci -nnk | grep -iA2 net
    06:01.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
    Subsystem: Toshiba America Info Systems Device [1179:ff00]
    Kernel driver in use: 8139too
    --
    06:02.0 Network controller [0280]: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection [8086:4220] (rev 05)
    Subsystem: Intel Corporation Device [8086:2741]
    Kernel driver in use: ipw2200



    dinodxr@dinodxr-M70:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0f:b0:de:11:96
    inet addr:192.168.0.5 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20f:b0ff:fede:1196/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:20239 errors:0 dropped:0 overruns:0 frame:0
    TX packets:15727 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:24948232 (24.9 MB) TX bytes:1950058 (1.9 MB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:425 errors:0 dropped:0 overruns:0 frame:0
    TX packets:425 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:40895 (40.8 KB) TX bytes:40895 (40.8 KB)


    dinodxr@dinodxr-M70:~$ route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
    192.168.0.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

  4. #4
    Join Date
    Jul 2013
    Beans
    16

    Re: Can't Connect to Wireless Networks

    i run the commands, as you said, but didn't had my wifi on. (also sorry for my bad english, italian here)

  5. #5
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,697
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Connect to Wireless Networks

    Thanks.

    Your wireless interface is disable.

    I have a Toshiba laptop and the button on the keyboard that turns on and off the wireless interface actually works. With that in mind, check if you can enable it from a hardware button, or a custom keyboard shortcut.

    Let us know how it goes.
    Regards.

  6. #6
    Join Date
    Jul 2013
    Beans
    16

    Re: Can't Connect to Wireless Networks

    ok, i found that switch. i got a red light and the network at the status bar shows me some wifi networks. but still can't get on anyone, even mine.

  7. #7
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,697
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Connect to Wireless Networks

    Glad you are making progress.

    Try unplugging your ethernet cable and try to connect your own network. What error do you get?

    Regards.

  8. #8
    Join Date
    Jul 2013
    Beans
    16

    Re: Can't Connect to Wireless Networks

    an error doesn't pop up, it just doesn't connect to any wifi network, even mine. it asks for my password i type and then nothing.

  9. #9
    Join Date
    Apr 2013
    Beans
    4

    Re: Can't Connect to Wireless Networks

    Hi dinodxr, Install ubuntu 12.04 again & driver install in your laptop.

    sudo apt-get update
    sudo apt-get install linux-backports-modules-wireless-lucid-generic
    sudo reboot
    create a the file /etc/modprobe.d/ath9k.conf and add the following line to it and reboot
    options ath9k nohwcrypt=1

  10. #10
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,493
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Can't Connect to Wireless Networks

    Quote Originally Posted by Jhon smith View Post
    Hi dinodxr, Install ubuntu 12.04 again & driver install in your laptop.

    sudo apt-get update
    sudo apt-get install linux-backports-modules-wireless-lucid-generic
    sudo reboot
    create a the file /etc/modprobe.d/ath9k.conf and add the following line to it and reboot
    options ath9k nohwcrypt=1
    This will not help, because of

    a) 12.04, the backports are for lucid (and they contain older drivers)

    b) he uses an Intel device, not Atheros

    Unfortunately, the ipw2200 device driver is not further developed. Please show the outputs of
    Code:
    lsmod
    rfkill list
    iwconfig
    dmesg | grep ipw
    cat /etc/udev/rules.d/70-persistent-net.rules

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •