Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Asus U38N

  1. #11
    Join Date
    Jul 2013
    Beans
    1

    Re: Asus U38N

    Hi,

    I had the same problems as described above for my brandnew U38N, and since last night it seems to work: At least 4 times reboot/shutdown+start did work nicely.

    So here is what I did:
    I had installed Ubuntu after getting to run the Live-64bit Ubuntu 13.04 iso-image from an USB stick.
    As described above, this needed several trials.

    I found out, that Lenovo IdeaPad S405 got the same APU and also the same problems:
    http://ubuntuforums.org/showthread.php?t=2147113
    So I used once more the USB stick to install Ubuntu 13.04 directly. This needed several trials until the screen worked,
    but finally, I was successful. I used the USB2Ethernet adapter to have wired internet connection.
    Sadly, it did not help, still the next reboot showed a black screen.
    However, after two more trials I was lucky and the screen worked and I could continue configuration.
    So I installed the AMD Catalyst graphic drivers as described here:
    http://askubuntu.com/questions/12429.../286775#286775
    This worked fine.

    Since it was late in the night, I tried 4 times a reboot or a shutdown+start and each time it worked fine.

    Remarks:
    1. I did not turn off secure boot, I did not need CSM. I was lucky that the screen worked two times, so I did not need an external monitor.
    2. So, probably it is all about successfully installing and running the AMD Catalyst graphic drivers.
    3. For anybody, who got already Ubuntu installed, but not yet with the AMD Catalyst graphic drivers, one might try out this:
    In the grub2 boot menu, type 'e' and add the boot option "nomodeset". In my case, I eneded up always that Ubuntu successfully booted, but
    without graphic, only text/command line.
    Then establish an wired internet connection and install the AMD drivers as described in the link above.
    I did not try out this procedure, but if it works, it might be the fastest way to make the graphic of an already installed Ubuntu working.

  2. #12
    Join Date
    Jul 2013
    Beans
    7

    Re: Asus U38N

    Quote Originally Posted by Nameless2 View Post
    Managed to boot straight into desktop 5 times now, either by reboot, hard boot or reboot from Windows 8. No issues yet and hope it stays this way. The thing I indeed forgot to mention are the UEFI settings. Like suggest by you and on several sites I browsed for this problem, one has to turn on CSM (set to Enabled). Then turn off Secure Boot Control. The tricky thing there for me was that it took like 3 times before it actually accepted those settings and inbetween I did set an administrator password for the UEFI. So even when you apply those settings, save and exit UEFI, reboot into it and check if your new settings actually are applied.
    It did not work with external screen in my case as it did for you.

    However, I have found the other way how to fix it on one of Linux Mint forums and that is exactly what I have done and it has been tested, and it works 100% for Xfce and others. I am using Xubuntu and it works beautifully on U38N.

    Before you do all this, again make sure CSM is enabled and Secure Boot is disabled!


    1. During boot hold down the left shift key to get the GRUB boot menu to show.
    2. Press the 'e' key to edit the boot parameters. Using the cursor keys of your keyboard scroll down to the line that starts with "linux" (red box in the screenshot) and go to the end of that line (red arrow in the screenshot).


    1. Add the boot parameters "nomodeset xforcevesa" (without the quotes, see red box in the screenshot). As you type, it will wrap to the next line on the screen and show a backslash character at the end of the previous line. That's fine. Press Ctrl+X or F10 to continue to boot.
    2. If you followed these steps, but you are still unable to boot successfully, please make a new topic for that and ask for help. (BEFORE GOING TO BULLET POINT 4, I (ERIKAS) HAVE DOWNLOADED AMD PROPRIETARY DRIVERS FROM THEIR SITE AND INSTALLED IT AFTER THE SUCCESSFUL SYSTEM REBOOT)
    3. After successfully booting:
      - for Linux Mint 13 and earlier, open the Additional Drivers program from the menu;
      - for Linux Mint 14 open the Software Sources program from the menu, then go to the Additional Drivers tab there.
      - for Linux Mint 15 open the Driver Manager program from the menu (see: http://www.linuxmint.com/rel_olivia_wha ... intdrivers).
      See what graphics card drivers are available for you (my graphics card doesn't need additional drivers, so I can't show any in the screenshot). If you are sure of the one you should install go ahead. But if you need further help with this, please make a new topic in the Graphics Cards & Monitors forum and include the output of the command "inxi -SGx" run from the terminal.

      Note that if you have a NVIDIA Optimus graphics card (Intel IGP + NVIDIA GPU), you need Bumblebee. That goes beyond the scope of this topic, but see here: https://wiki.ubuntu.com/Bumblebee. If you have a AMD Hybrid graphics card (Intel IGP + AMD GPU), I don't know the right steps except switch either the one or the other off (in the BIOS to "on-board IGP only" for Intel or "discrete mode" for AMD). For more help if you have multiple graphics cards, please make a new topic in the Graphics Cards & Monitors forum.


    I guess that is it for this case! Yay!

  3. #13
    Join Date
    Jul 2013
    Beans
    2

    Re: Asus U38N

    Had the exact same problem with Xubuntu on my U38N, and as Erikas mentioned, "nomodeset xforcevesa" solved the booting problem for me. Had to remove a couple of lines before that though. And as someone else said, run with CSM enabled and safe boot disabled.

    And after I installed the proprietary drivers for the graphics, the laptop now boots without a problem every time.

  4. #14
    Join Date
    Sep 2007
    Beans
    1

    Re: Asus U38N

    Also been having issues with this, and upon installing ubuntu originally "nomodeset" in grub worked fine until I could install Catalyst.

    Recently a kernel upgrade kicked out my graphics drivers and "nomodeset xforcevesa" didn't work. What I had to do was to start ubuntu in recovery mode, drop to root shell, issue the command "mount -o rw,remount /" to remount / as read/write, and then install catalyst from there. The next kernel upgrade went without a hitch though, so this issue may slowly begin to solve itself.

  5. #15
    Join Date
    Jul 2013
    Beans
    2

    Re: Asus U38N

    Anyone got the keyboard backlight to work?

  6. #16
    Join Date
    Sep 2013
    Beans
    2

    Re: Asus U38N

    Quote Originally Posted by sarkvik View Post
    Anyone got the keyboard backlight to work?
    Have you tried putting acpi_osi="" in the grub kernel command-line?

    This fixed all of the ACPI keys on my ASUS N550JV.

  7. #17
    Join Date
    Aug 2012
    Beans
    7

    Re: Asus U38N

    I'm guessing my most recent issue with this laptop was due to the upgrade from Windows 8 to 8.1. My guess is that it messed up some NTFS partitions or the boot partition that I had created as it kept running in an infinite loop of failing to load several partitions and folders. So my Ubuntu install got totally unbootable even through the recovery or older kernel options.

    Now I installed Ubuntu again by:
    - Downloading the Ubuntu 13.10 release image
    - Using UNetbootin to write the downloaded image onto a 2GB USB stick
    - Turn off the Asus U38N
    - Hook an ethernet cable up through the usb adapter and the USB3.0 port
    - Insert the 2GB stick in a USB2.0 on the right side of the laptop
    - Attach an external 1920x1080p screen through the HDMI port on the right side of the laptop
    - Attach power cord
    - Boot up the computer and immediately press F2 to enter UEFI/BIOS. In there set "Launch CSM" to "Enabled" and "Secure Boot State" to "Disabled". Under "Boot Option Priorities", make sure to select the USB stick as "Boot Option #1". Press F10 to save and reboot.
    - When booting from the USB stick, select "Try Ubuntu" and you should get output on at least the attached screen, possibly also on the screen of the laptop itself
    - Once inside the live environment, start up the installation program and select manual partitioning
    - Make sure that at least the following partitions are present, or created: Windows 8/8.1 partition, UEFI partition, swap partition for linux, a 250MB partition and a partition for Ubuntu.
    - Make sure to format the Ubuntu partition to ext4 format and the 250MB paritition to ext2 format. The mounting point for the ext4 partition should be "/" and for the ext2 partition "/boot". Before confirming all disk changes, select the ext2 partition as the location to install grub from the roll menu at the bottom.
    - Continue installation as you would normally do and reboot.
    - Grub should now give 4 options: Ubuntu, Ubuntu Advanced Options (recovery), Windows Boot Menu and System Settings (UEFI). Select Ubuntu.
    - Once loaded, search for the "Additional Drivers" tab in the "Software and Updates" menu and select the option "Using Video driver for the AMD graphics accelerators from fglrx (proprietary)"
    - Let the driver install, close the menu and shut down the laptop.
    - Unplug the HDMI cable and screen, boot the laptop and be greeted by full Ubuntu screen functionality!

    I must admit I do not get a ful 100% boot ratio, I am greeted with a black screen once in a while, but then it always already failed to show the Asus logo from the start already, or Grub. So I simply press the power button for 5 seconds to turn everything off, wait a bit and try again. Usually fixes it in one go.

    Edit:
    forgot to mention that for me, all the keyboard functions work out of the box with a fresh Ubuntu installation, non excluded. So if your keyboard doesn't light up properly (or light down), you most likely have bad hardware.
    Last edited by Nameless2; October 20th, 2013 at 12:49 AM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •