Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Replaced admin user, and now settings prompt for "root" password rather than user's

  1. #11
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    @Dave_L
    Yep, root is diabled

    @dannyboy79
    Code:
    cat /etc/group
    root:x:0:
    daemon:x:1:
    bin:x:2:
    sys:x:3:
    adm:x:4:philip
    tty:x:5:
    disk:x:6:
    lp:x:7:
    mail:x:8:
    news:x:9:
    uucp:x:10:
    man:x:12:
    proxy:x:13:
    kmem:x:15:
    dialout:x:20:
    fax:x:21:
    voice:x:22:
    cdrom:x:24:philip
    floppy:x:25:
    tape:x:26:
    sudo:x:27:
    audio:x:29:pulse
    dip:x:30:philip
    www-data:x:33:
    backup:x:34:
    operator:x:37:
    list:x:38:
    irc:x:39:
    src:x:40:
    gnats:x:41:
    shadow:x:42:
    utmp:x:43:
    video:x:44:
    sasl:x:45:
    plugdev:x:46:philip
    staff:x:50:
    games:x:60:
    users:x:100:
    nogroup:x:65534:
    libuuid:x:101:
    crontab:x:102:
    syslog:x:103:
    fuse:x:104:
    messagebus:x:105:
    bluetooth:x:106:
    scanner:x:107:
    colord:x:108:
    lpadmin:x:109:philip
    ssl-cert:x:110:
    lightdm:x:111:
    nopasswdlogin:x:112:
    netdev:x:113:
    whoopsie:x:114:
    mlocate:x:115:
    ssh:x:116:
    avahi-autoipd:x:117:
    avahi:x:118:
    pulse:x:119:
    pulse-access:x:120:
    utempter:x:121:
    rtkit:x:122:
    saned:x:123:
    phil:x:1000:philip
    sambashare:x:124:philip
    mysql:x:125:
    Thanks for the help guys, it's greatly appreciated!

  2. #12
    Join Date
    Sep 2010
    Beans
    898

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    Code:
    sudo:x:27:
    That's the only notable difference between your /etc/group file and mine.

    You have no users in your "sudo" group.

    Mine looks like:

    Code:
    sudo:x:27:USER
    where USER is my actual username.

  3. #13
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    That was it!

    I didn't see it until I posted the above: whilst
    Code:
    groups philip
    included sudo, for some reason /etc/group didn't reflect that. I've manually added myself to the sudo group in /etc/group and everythings working again

    Thanks again!
    Last edited by TuxImpersonator; July 17th, 2013 at 05:41 PM. Reason: typo

  4. #14
    Join Date
    Feb 2008
    Location
    in the Ether
    Beans
    31
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Replaced admin user, and now settings prompt for "root" password rather than user

    Thanks @Dave_L, looks like we posted at the exact same time (great minds think alike and all that )

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •