Results 1 to 6 of 6

Thread: debian 7 (wheezy) have no sound on asus laptop

  1. #1
    Join Date
    Oct 2011
    Beans
    5

    debian 7 (wheezy) have no sound on asus laptop

    debian 7 (wheezy) have no sound on asus laptop,help me please1、
    Code:
    wheezy@debian:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC660 Analog [ALC660 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC660 Digital [ALC660 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
      Subdevices: 1/1
      Subdevice #0: subdevice #02
    、then
    Code:
    sudo gedit /etc/modprobe.d/alsa-base.conf
    then add
    Code:
    options snd-hda-intel model=3stack-660 3
    、then
    Code:
    killall pulseaudio
    Code:
    wheezy@debian:~$ sudo alsa force-reload
    Unloading ALSA sound driver modules: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
    Loading ALSA sound driver modules: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer.
    4、
    Code:
    wheezy@debian:~$ pulseaudio -D
    E: [pulseaudio] main.c: 后台程序启动失败。
    5、
    Code:
    wheezy@debian:~$ sudo ls -la /dev/snd
    total 0
    drwxr-xr-x   3 root root      260  7月  9 20:53 .
    drwxr-xr-x  14 root root     3220  7月  9 22:16 ..
    drwxr-xr-x   2 root root       60  7月  9 20:53 by-path
    crw-rw---T+  1 root audio 116,  9  7月  9 20:53 controlC0
    crw-rw---T+  1 root audio 116,  8  7月  9 20:53 hwC0D0
    crw-rw---T+  1 root audio 116,  7  7月  9 20:53 hwC0D1
    crw-rw---T+  1 root audio 116,  6  7月  9 22:26 pcmC0D0c
    crw-rw---T+  1 root audio 116,  5  7月  9 22:26 pcmC0D0p
    crw-rw---T+  1 root audio 116,  4  7月  9 22:26 pcmC0D1p
    crw-rw---T+  1 root audio 116,  3  7月  9 20:53 pcmC0D6c
    crw-rw---T+  1 root audio 116,  2  7月  9 20:53 pcmC0D6p
    crw-rw---T+  1 root audio 116,  1  7月  9 22:27 seq
    crw-rw---T+  1 root audio 116, 33  7月  9 20:53 timer
    6、
    Code:
    wheezy@debian:~$ groups
    wheezy cdrom floppy audio dip video plugdev scanner bluetooth netdev
    7、
    Code:
    wheezy@debian:~$ alsamixerall right
    8、
    Code:
    root@debian:~# alsactl init
    Found hardware: "HDA-Intel" "Realtek ALC660" "HDA:10ec0861,10431105,00100340 HDA:10573055,104310c6,00100700" "0x1043" "0x1263"
    Hardware is initialized using a generic method
    debian 7 (wheezy) have no sound on asus laptop,have reset a lot of times ,please help ,thanks a lot!
    Last edited by CharlesA; July 10th, 2013 at 04:24 AM. Reason: fixed OP. Thanks pqwoerituytrueiwoq!

  2. #2
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: debian 7 (wheezy) have no sound on asus laptop

    you might see if you can edit this question to make it easier to read.

  3. #3
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,386
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: debian 7 (wheezy) have no sound on asus laptop

    I fixed up the 1st post
    Quote Originally Posted by meego View Post
    debian 7 (wheezy) have no sound on asus laptop,help me please1、
    Code:
    wheezy@debian:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC660 Analog [ALC660 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC660 Digital [ALC660 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
      Subdevices: 1/1
      Subdevice #0: subdevice #02
    、then
    Code:
    sudo gedit /etc/modprobe.d/alsa-base.conf
    then add
    Code:
    options snd-hda-intel model=3stack-660 3
    、then
    Code:
    killall pulseaudio
    Code:
    wheezy@debian:~$ sudo alsa force-reload
    Unloading ALSA sound driver modules: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
    Loading ALSA sound driver modules: snd-hda-codec-si3054 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer.
    4、
    Code:
    wheezy@debian:~$ pulseaudio -D
    E: [pulseaudio] main.c: 后台程序启动失败。
    5、
    Code:
    wheezy@debian:~$ sudo ls -la /dev/snd
    total 0
    drwxr-xr-x   3 root root      260  7月  9 20:53 .
    drwxr-xr-x  14 root root     3220  7月  9 22:16 ..
    drwxr-xr-x   2 root root       60  7月  9 20:53 by-path
    crw-rw---T+  1 root audio 116,  9  7月  9 20:53 controlC0
    crw-rw---T+  1 root audio 116,  8  7月  9 20:53 hwC0D0
    crw-rw---T+  1 root audio 116,  7  7月  9 20:53 hwC0D1
    crw-rw---T+  1 root audio 116,  6  7月  9 22:26 pcmC0D0c
    crw-rw---T+  1 root audio 116,  5  7月  9 22:26 pcmC0D0p
    crw-rw---T+  1 root audio 116,  4  7月  9 22:26 pcmC0D1p
    crw-rw---T+  1 root audio 116,  3  7月  9 20:53 pcmC0D6c
    crw-rw---T+  1 root audio 116,  2  7月  9 20:53 pcmC0D6p
    crw-rw---T+  1 root audio 116,  1  7月  9 22:27 seq
    crw-rw---T+  1 root audio 116, 33  7月  9 20:53 timer
    6、
    Code:
    wheezy@debian:~$ groups
    wheezy cdrom floppy audio dip video plugdev scanner bluetooth netdev
    7、
    Code:
    wheezy@debian:~$ alsamixerall right
    8、
    Code:
    root@debian:~# alsactl init
    Found hardware: "HDA-Intel" "Realtek ALC660" "HDA:10ec0861,10431105,00100340 HDA:10573055,104310c6,00100700" "0x1043" "0x1263"
    Hardware is initialized using a generic method
    debian 7 (wheezy) have no sound on asus laptop,have reset a lot of times ,please help ,thanks a lot!
    on 4 it would say "Daemon startup failed." if the OP was using the English version
    and on 5 7月 would be July
    Last edited by pqwoerituytrueiwoq; July 10th, 2013 at 04:13 AM. Reason: missed a spot
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  4. #4
    Join Date
    Oct 2011
    Beans
    5

    Re: debian 7 (wheezy) have no sound on asus laptop

    1、options snd-hda-intel model=3stack-660 after the last word ,not have 32、I use the command wheezy@debian:~$ alsamixerall,it pop up the Adjustment button all right

  5. #5
    Join Date
    Oct 2011
    Beans
    5

    Re: debian 7 (wheezy) have no sound on asus laptop

    debian 7 (wheezy) have no sound on asus laptop,I have tried a lot of ways ,but it doesn't work,please help me.

  6. #6
    Join Date
    Nov 2013
    Beans
    3

    Re: debian 7 (wheezy) have no sound on asus laptop

    I had a similar problem after installing Wheezy. Perhaps my solution may come in handy to others.

    debian@wheezy:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: MID [HDA Intel MID], device 8: HDMI 2 [HDMI 2]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    I previously had a graphics problem (on the first Wheezy release) and someone suggested that I should try a more updated kernel by installing a backport. This not only solved my graphics problem with my Haswell chipset, but the latest backport 3.10 fixed my sound issues as well.

    First, you need to add the backport repository to your sources.list and reload your repository
    echo "deb http://ftp.us.debian.org/debian/ wheezy-backports main" >> /etc/apt/sources.list && apt-get update
    You then need to search for the available backports. You can see the list by typing

    apt-get search linux-
    Since I have an AMD64, I opted for the 3.10-0.bpo.3-amd64 releases. You need both the image file and the associated headers, enter.

    aptitude -t wheezy-backports install linux-image-3.10-0.bpo.3-amd64
    for the image file, and
    aptitude -t wheezy-backports install linux-headers-3.10-0.bpo.3-amd64
    for the headers. Grub will automatically update. When you restart, you can pick the latest kernel. For some reason, alsamixer defaulted to my hdmi, so I had to make a change to the config. I created the config file

    ~/.asoundrc

    with the following entry

    pcm.!default {
    type hw
    card 1
    }

    ctl.!default {
    type hw
    card 1
    }
    When I restarted, running alsamixer showed the desired controls I wanted. Hope this helps.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •