So you're using a TNT2 (nvidia nv05) and the open-source nouveau driver. I didn't see any matching bugs: https://bugs.freedesktop.org/buglist...u&product=xorg

I would try to turn off cursor acceleration. Make an /etc/X11/xorg.conf with the following contents:
Code:
Section "Device"
        Identifier "Configured Video Device"
        Option "HWCursor" "false"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
EndSection
#trailing line
Log out after you make it to restart X.