Results 1 to 10 of 16

Thread: Radeon HD 3870 driver installation issue on “Ubuntu 12.04 precise”

Threaded View

  1. #1
    Join Date
    Mar 2008
    Beans
    52

    Exclamation Radeon HD 3870 driver installation issue on “Ubuntu 12.04 precise”

    Radeon HD 3870 driver installation issue on "Ubuntu 12.04 precise":
    [EDIT](TLDR)
    Hey everyone, I got my problem fixed by using the latest answer given to me here:

    http://askubuntu.com/questions/31649...-12-04-precise

    used the makson96/fglrx repository method and it worked like a charm!

    The given Instructions I used can be found in here:
    https://launchpad.net/~makson96/+archive/fglrx
    for prettier formatting look'em up at the bottom of the page of the first link! ^_^
    yay!
    [/EDIT]

    I know that this is my actual driver because:

    > ~$ lspci | grep -i amd
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV670 [Radeon HD 3870]
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]


    Steps I've taken:

    1. Gone here:
    http://support.amd.com/us/gpudownloa...eon_linux.aspx

    2. Installed "AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver"

    3. Restarted

    4. Launched "amdcccle" and got the following error message:

    "Initialization error"

    There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.
    No AMD graphics driver is installed, or the AMD driver is not functioning properly.
    Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig.
    -5. Got my hands on something called: "ubuntu-amd-catalyst-install", installed and and launched it and it showed me the following error message:

    "The Fan Club - Ubuntu AMD Catalyst™ Install"
    Detected graphics controller:

    Hynix Semiconductor (Hyundai Electronics) Radeon HD 3870

    Ubuntu 12.04
    Linux Kernel: 3.5
    X-Server version:


    Your system is not supported by this driver


    Your system is not supported by this driver <--- ????




    I installed synaptic and then installed the fglrx driver from there, didn't make "amdcccle" start working either.

    I've also ran "aticonfig --initial" and it didn't change anything.


    At the moment I am not pleased because my maximum (and only) resolution is 1024x768 and I wish to change that.


    I definitely remembering installing Ubuntu couple of years ago with the same hardware never got this kind of error message.

    Have the ubuntu development team done something wrong over the years to ubuntu
    that degraded it's ability to support my (unchanged) hardware?

    I've looked up the suggested searches and non of them seem to help me, I put my trust in your hands, I hope that you can help me figure out why ubuntu has stopped supporting my used-to-be-completely-supported graphic card.




    Thanks ahead for any positive helpers.


    I was told to remove everything I've done (which I have by now) and to go here and use this guide:
    https://help.ubuntu.com/community/BinaryDriverHowto/ATI

    I did, then in step 2.1.8 I got this output after sending the command "fglrxinfo":

    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 153 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 12
    Current serial number in output stream: 12
    when it is written in the guide that I should get something like:

    display: :0 screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6300M Series
    OpenGL version string: 4.2.11733 Compatibility Profile Context
    Please ubuntu experts I need your help, why is this happening? what do I do?


    I also tried posting this help request in other domains but they are too slow, so I thought of trying out my luck in here as well.
    Last edited by QIII; July 8th, 2013 at 07:36 PM. Reason: Unnecessary and overly large image removed.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •