Hi All,

The hard drive on my laptop died and had it replaced. I have done a clean install and I am attempting to restore from an external hard drive i backed up onto.
I have tried copying the files locally, clearning the .cache directory for duplicity and ive tried different restore dates. I have also uninstalled and reinstalled duplicity and dejadupe and have tried to restore from the command line. Anyone got any ideas on what is wrong?

Traceback (most recent call last):
File "/usr/bin/duplicity", line 1411, in <module>
File "/usr/bin/duplicity", line 1404, in with_tempdir
File "/usr/bin/duplicity", line 1338, in main
File "/usr/bin/duplicity", line 632, in restore
File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 526, in Write_ROPaths
for ropath in rop_iter:
File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 499, in integrate_patch_iters
final_ropath = patch_seq2ropath( normalize_ps( patch_seq ) )
File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 463, in patch_seq2ropath
assert first.difftype != "diff", patch_seq
AssertionError: [(('home', 'nathaniel', '.gnupg', 'random_seed') reg), (('home', 'nathaniel', '.gnupg', 'random_seed') reg), (('home', 'nathaniel', '.gnupg', 'random_seed') reg), (('home', 'nathaniel', '.gnupg', 'random_seed') reg), (('home', 'nathaniel', '.gnupg', 'random_seed') reg)]