Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Not Waking Up From Suspend (Ubuntu 12.04)

  1. #1
    Join Date
    Oct 2013
    Beans
    10

    Not Waking Up From Suspend (Ubuntu 12.04)

    I have read up on other threads, but this doesn't seem to be quite what other people have had. This computer isn't a laptop, which may make a difference?

    Here's the problem: If I click suspend, it turns the screen off (as it should), but none of the keys or mouse will wake it back up. A few seconds on the power button is also useless. When I press any button on the monitor, it says that it is in sleep mode, and to wake it press any key or move mouse, before returning to off. It isn't just a black screen, which has me stumped.

    Any ideas?

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Hello and welcome to the forums.

    To show which devices are configured for wakeup, type the following command in a terminal window and post back the results:
    Code:
    cat /proc/acpi/wakeup
    To help identify the devices, the two following commands will help:
    Code:
    lspci
    ...and:
    Code:
    lspci -t
    If the keyboard/mouse channels are available, you can enable them to wake up the system by running a command like:
    Code:
    echo <DEVICE> | sudo tee /proc/acpi/wakeup
    ...where <DEVICE> is the device name you wish to enable.

    Post back the results of those commands and lets see what you have.

  3. #3
    Join Date
    Oct 2013
    Beans
    10

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Here are the results:


    Code:
    cat /proc/acpi/wakeup
    Device    S-state      Status   Sysfs node
    PCI0      S5    *disabled  no-bus:pci0000:00
    HUB0      S5    *disabled  pci:0000:00:1e.0
    UAR1      S5    *disabled  pnp:00:07
    USB0      S1    *enabled   pci:0000:00:1d.0
    USB1      S1    *enabled   pci:0000:00:1d.1
    USB2      S1    *enabled   pci:0000:00:1d.2
    USB3      S1    *enabled   pci:0000:00:1d.3
    USBE      S1    *enabled   pci:0000:00:1d.7
    MODM      S5    *disabled

    And:


    Code:
    lspci -t
    -[0000:00]-+-00.0
               +-01.0-[01]--+-00.0
               |            \-00.1
               +-06.0
               +-1d.0
               +-1d.1
               +-1d.2
               +-1d.3
               +-1d.7
               +-1e.0-[02]--+-01.0
               |            +-02.0
               |            \-07.0
               +-1f.0
               +-1f.2
               +-1f.3
               \-1f.5
    Followed by:

    Code:
    lspci
    00:00.0 Host bridge: Intel Corporation82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    00:01.0 PCI bridge: Intel Corporation82865G/PE/P AGP Bridge (rev 02)
    00:06.0 System peripheral: IntelCorporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
    00:1d.0 USB controller: IntelCorporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB controller: IntelCorporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB controller: IntelCorporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB controller: IntelCorporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB controller: IntelCorporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation82801 PCI Bridge (rev c2)
    00:1f.0 ISA bridge: Intel Corporation82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
    00:1f.2 IDE interface: IntelCorporation 82801EB (ICH5) SATA Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
    00:1f.5 Multimedia audio controller:Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev02)
    01:00.0 VGA compatible controller:Advanced Micro Devices, Inc. [AMD/ATI] R300 [Radeon 9700/9700 PRO]
    01:00.1 Display controller: AdvancedMicro Devices, Inc. [AMD/ATI] R300 [Radeon 9700 PRO] (Secondary)
    02:01.0 FireWire (IEEE 1394): TexasInstruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
    02:02.0 Ethernet controller: 3ComCorporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
    02:07.0 Ethernet controller: QualcommAtheros AR5212/AR5213 Wireless Network Adapter (rev 01)

    The last one doesn't seem to work...


    bash: syntax error near unexpectedtoken `|'

    NOT using USB for keyboard or mouse, if that matters.
    Last edited by Toz; October 23rd, 2013 at 01:06 AM. Reason: added code blocks

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Can you go into the system bios and look for an option something like "acpi" or "sleep modes". Look for something that talks about S-modes (S1, S2, S3, S4, S5). If you find it, what is it currently set at and what options are available? Let me know if there is an online manual available for your motherboard/bios.

    And also, can you run the following command and post back the link that is generated:
    Code:
    pastebinit /var/log/dmesg
    If it complains that pastebinit isn't installed, you can install it via:
    Code:
    sudo apt-get install pastebinit

  5. #5
    Join Date
    Oct 2013
    Beans
    10

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    There is (in ACPI) PowerOn Suspend (S1) and Suspend to RAM (S3). Default is set to PowerOn Suspend.

    Here is the link: http://paste.ubuntu.com/6286722/

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Quote Originally Posted by RCAProduction View Post
    There is (in ACPI) PowerOn Suspend (S1) and Suspend to RAM (S3). Default is set to PowerOn Suspend.
    Can you try changing it to S3 (Suspend to Ram). See if that makes a difference. Also, post back again, after making the change:
    Code:
    cat /proc/acpi/wakeup
    ...and
    Code:
    pastebinit /var/log/dmesg
    ...and try another suspend and see if it wakes up properly.

  7. #7
    Join Date
    Oct 2013
    Beans
    10

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    EDIT: I tested again, and before the screen turned off I was able to enter my passcode and start the computer. It started fine... Curious.

    No difference. It suspends and shuts off power, but when turned back on hits the same "use keyboard to wake up" roadblock.

    cat /proc/acpi/wakeup
    Device S-state Status Sysfs node
    PCI0 S5 *disabled no-busci0000:00
    HUB0 S5 *disabled pci:0000:00:1e.0
    UAR1 S5 *disabled pnp:00:07
    USB0 S3 *enabled pci:0000:00:1d.0
    USB1 S3 *enabled pci:0000:00:1d.1
    USB2 S3 *enabled pci:0000:00:1d.2
    USB3 S3 *enabled pci:0000:00:1d.3
    USBE S3 *enabled pci:0000:00:1d.7
    MODM S5 *disabled

    And http://paste.ubuntu.com/6292027/
    Last edited by RCAProduction; October 24th, 2013 at 12:40 AM.

  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Can you try the following:
    Code:
    echo "UAR1" | sudo tee /proc/acpi/wakeup
    ...this should set UAR1 as enabled in /proc/acpi/wakeup. Then try to suspend and resume with the keyboard, mouse or power button.

    If it still doesn't work, try enabling all of the disabled ones:
    Code:
    echo "PCI0" | sudo tee /proc/acpi/wakeup
    echo "HUB0" | sudo tee /proc/acpi/wakeup
    echo "UAR1" | sudo tee /proc/acpi/wakeup
    echo "MODM" | sudo tee /proc/acpi/wakeup
    ...and try a suspend/resume. Lets see what happens.

  9. #9
    Join Date
    Oct 2013
    Beans
    10

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    None of that worked... I think there may be a different problem. Lately, the computer has gone to sleep (not to RAM... It's like it overloads and locks up) when it has to either do something graphically intensive, or if it requires a connection to the internet and has to be communicating more than normal. (e.g. games, videos, CDs, etc.) Most recently it shuts down for almost no reason at all. I feel that when it wakes from suspend it locks up, explaining why I can't do anything. Earlier this week I had remove my fourth memory card and clean it because it wasn't letting me start up. I thought it might be the graphics card, but I installed the proper software for it so that is doubtful. I need to stop these random lock-ups before I can truly tell if suspend is fixed. What should I do?

  10. #10
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not Waking Up From Suspend (Ubuntu 12.04)

    Faulty memory? Have you tried running a memory test?

    Can I also see your pm-suspend log file:
    Code:
    pastebinit /var/log/pm-suspend.log
    ...and post back the link that is generated.

    If pastebinit isn't installed, you can install it via:
    Code:
    sudo apt-get install pastebinit

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •