Page 1 of 6 123 ... LastLast
Results 1 to 10 of 51

Thread: WiFi often disconnects

  1. #1
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    WiFi often disconnects

    Hello,
    I use Ubuntu 13.04 Raring Ringtail on my Acer TravelMate 5730. Since I left hometown and moved I use a wifi hotspot with my uncle and I found out that I have strange problems. Wifi suddenly disconnects for no reasons and SSID disappears from Network Manager's list. Sometimes disabling wifi from NM and re-enabling it would solve the problem, sometimes it would not. I have the same problem with my Nexus 4 with Android 4.2.2 Jelly Bean but NOT with my old LG Optimus One with unofficial CyanogenMod 9 (Android 4.0.x ICS). With the latter, it happens that connection doesn't work (at the same time, on my laptop, wifi has totally disconnected) but wifi is still connected so I can go to router's page and reset it. I tried almost everything: changing kernel (3.8, 3.9 and 3.10), changing security (WEP and WPA), disabling wifi 'n', changing wifi channel, reducing beaconing interval and disabling firewall in the router. Nothing worked. It's getting very frustrating and don't know what to do. Do you people have idea of what's happening? Here's my dmesg, by the way:

    Code:
    [   11.449638] input: Acer BMA150 accelerometer as /devices/virtual/input/input5
    [   11.683920] input: PS/2 Mouse as /devices/platform/i8042/serio2/input/input6
    [   11.706696] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio2/input/input7
    [   12.000225] Console: switching to colour frame buffer device 160x50
    [   12.003365] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
    [   12.003367] i915 0000:00:02.0: registered panic notifier
    [   12.099589] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   12.104700] microcode: CPU1 sig=0x6fd, pf=0x80, revision=0xa1
    [   12.109532] cfg80211: World regulatory domain updated:
    [   12.109538] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [   12.109541] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [   12.109543] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [   12.109546] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [   12.109548] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [   12.109551] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [   12.118194] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [   12.125055] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [   12.142774] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff:
    [   12.142785]  excluding 0xc0000-0xd3fff 0xe4000-0xfffff
    [   12.142816] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff:
    [   12.142827]  excluding 0xa0000000-0xa0ffffff
    [   12.142849] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff:
    [   12.142860]  excluding 0x60000000-0x60ffffff
    [   12.176444] acpi device:03: registered as cooling_device2
    [   12.176543] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
    [   12.176610] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input8
    [   12.180160] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
    [   12.183564] snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
    [   12.183875] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
    [   12.220340] autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [   12.220346]    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [   12.220348]    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
    [   12.220350]    mono: mono_out=0x0
    [   12.220351]    inputs:
    [   12.220354]      Mic=0x18
    [   12.220356]      Internal Mic=0x12
    [   12.220358]      Line=0x1a
    [   12.220360] realtek: No valid SSID, checking pincfg 0x4016852d for NID 0x1d
    [   12.220362] realtek: Enabling init ASM_ID=0x852d CODEC_ID=10ec0268
    [   12.272654] autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
    [   12.272660]    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [   12.272662]    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [   12.272664]    mono: mono_out=0x0
    [   12.272666]    inputs:
    [   12.294269] input: HDA Intel HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
    [   12.294536] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
    [   12.294873] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
    [   12.295097] input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
    [   12.311147] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [   12.314332] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [   12.391841] init: Failed to spawn atd main process: unable to execute: No such file or directory
    [   12.432650] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   12.662566] zram: module is from the staging directory, the quality is unknown, you have been warned.
    [   12.681026] zram: Created 2 device(s) ...
    [   12.700044] usb 8-2: new full-speed USB device number 2 using uhci_hcd
    [   12.744946] Adding 752520k swap on /dev/zram0.  Priority:5 extents:1 across:752520k SSFS
    [   12.771585] Adding 752520k swap on /dev/zram1.  Priority:5 extents:1 across:752520k SSFS
    [   12.872068] usb 8-2: New USB device found, idVendor=0a5c, idProduct=2101
    [   12.872075] usb 8-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [   12.872078] usb 8-2: Product: Acer Module
    [   12.872081] usb 8-2: Manufacturer: Broadcom Corp
    [   12.926499] usbcore: registered new interface driver btusb
    [   18.810108] wlan0: authenticate with 38:22:9d:03:a7:d2
    [   18.811746] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [   18.819125] wlan0: authenticated
    [   18.819287] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [   18.820076] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [   18.841530] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [   18.844400] wlan0: associated
    [   18.844435] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   54.148194] init: plymouth-stop pre-start process (2429) terminated with status 1
    [   89.924139] usb 8-2: USB disconnect, device number 2
    [  909.820362] cfg80211: Calling CRDA to update world regulatory domain
    [  909.835534] cfg80211: World regulatory domain updated:
    [  909.835546] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [  909.835554] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  909.835560] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  909.835566] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  909.835573] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  909.835579] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  921.177717] wlan0: authenticate with 38:22:9d:03:a7:d2
    [  921.179416] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [  921.181785] wlan0: authenticated
    [  921.182106] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [  921.184153] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [  921.215210] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [  921.217492] wlan0: associated
    [  921.217561] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [  924.192364] cfg80211: Calling CRDA to update world regulatory domain
    [  924.201939] cfg80211: World regulatory domain updated:
    [  924.201944] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [  924.201947] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  924.201950] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  924.201953] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  924.201955] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  924.201958] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  927.357509] wlan0: authenticate with 38:22:9d:03:a7:d2
    [  927.359459] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [  927.361872] wlan0: authenticated
    [  927.362257] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [  927.364084] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [  927.395258] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [  927.397765] wlan0: associated
    [ 1365.400427] cfg80211: Calling CRDA to update world regulatory domain
    [ 1365.412885] cfg80211: World regulatory domain updated:
    [ 1365.412891] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 1365.412894] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1365.412897] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1365.412899] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1365.412902] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1365.412904] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1387.613748] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 1387.615578] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 1387.617966] wlan0: authenticated
    [ 1387.618848] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 1387.620947] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 1387.652039] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 1387.654680] wlan0: associated
    [ 1706.528833] tg3 0000:02:00.0: System wakeup enabled by ACPI
    [ 1706.750737] wlan0: deauthenticating from 38:22:9d:03:a7:d2 by local choice (reason=3)
    [ 1706.758088] cfg80211: Calling CRDA to update world regulatory domain
    [ 1706.763931] cfg80211: World regulatory domain updated:
    [ 1706.763938] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 1706.763941] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1706.763944] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1706.763946] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1706.763949] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1706.763951] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1706.743715] PM: Syncing filesystems ... done.
    [ 1706.810694] Freezing user space processes ... (elapsed 0.10 seconds) done.
    [ 1706.920273] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
    [ 1706.936283] Suspending console(s) (use no_console_suspend to debug)
    [ 1706.936821] sd 0:0:0:0: [sda] Synchronizing SCSI cache
    [ 1706.938096] sd 0:0:0:0: [sda] Stopping disk
    [ 1707.488130] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D3hot
    [ 1707.488182] PM: suspend of devices complete after 551.492 msecs
    [ 1707.488472] PM: late suspend of devices complete after 0.287 msecs
    [ 1707.504358] ehci-pci 0000:00:1d.7: System wakeup enabled by ACPI
    [ 1707.520065] uhci_hcd 0000:00:1d.2: System wakeup enabled by ACPI
    [ 1707.520107] uhci_hcd 0000:00:1d.1: System wakeup enabled by ACPI
    [ 1707.520148] uhci_hcd 0000:00:1d.0: System wakeup enabled by ACPI
    [ 1707.520279] ehci-pci 0000:00:1a.7: System wakeup enabled by ACPI
    [ 1707.536060] uhci_hcd 0000:00:1a.2: System wakeup enabled by ACPI
    [ 1707.536101] uhci_hcd 0000:00:1a.1: System wakeup enabled by ACPI
    [ 1707.536143] uhci_hcd 0000:00:1a.0: System wakeup enabled by ACPI
    [ 1707.536195] PM: noirq suspend of devices complete after 47.720 msecs
    [ 1707.536425] ACPI: Preparing to enter system sleep state S3
    [ 1707.563891] PM: Saving platform NVS memory
    [ 1707.564253] Disabling non-boot CPUs ...
    [ 1707.668036] smpboot: CPU 1 is now offline
    [ 1707.668409] ACPI: Low-level resume complete
    [ 1707.668409] PM: Restoring platform NVS memory
    [ 1707.668409] Enabling non-boot CPUs ...
    [ 1707.668409] smpboot: Booting Node 0 Processor 1 APIC 0x1
    [ 1707.680100] CPU1 is up
    [ 1707.682600] ACPI: Waking up from system sleep state S3
    [ 1707.780215] uhci_hcd 0000:00:1a.0: System wakeup disabled by ACPI
    [ 1707.780286] uhci_hcd 0000:00:1a.1: System wakeup disabled by ACPI
    [ 1707.780360] uhci_hcd 0000:00:1a.2: System wakeup disabled by ACPI
    [ 1707.796084] ehci-pci 0000:00:1a.7: System wakeup disabled by ACPI
    [ 1707.796620] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D0
    [ 1707.812504] uhci_hcd 0000:00:1d.0: System wakeup disabled by ACPI
    [ 1707.812576] uhci_hcd 0000:00:1d.1: System wakeup disabled by ACPI
    [ 1707.812645] uhci_hcd 0000:00:1d.2: System wakeup disabled by ACPI
    [ 1707.828078] ehci-pci 0000:00:1d.7: System wakeup disabled by ACPI
    [ 1707.876242] yenta_cardbus 0000:0d:06.0: O2: enabling read prefetch/write burst. If you experience problems or performance issues, use the yenta_socket parameter 'o2_speedup=off'
    [ 1707.892853] PM: noirq resume of devices complete after 127.224 msecs
    [ 1707.893179] PM: early resume of devices complete after 0.282 msecs
    [ 1707.893227] i915 0000:00:02.0: setting latency timer to 64
    [ 1707.893678] uhci_hcd 0000:00:1a.0: setting latency timer to 64
    [ 1707.893710] usb usb3: root hub lost power or was reset
    [ 1707.893856] uhci_hcd 0000:00:1a.1: setting latency timer to 64
    [ 1707.893884] usb usb4: root hub lost power or was reset
    [ 1707.894085] uhci_hcd 0000:00:1a.2: setting latency timer to 64
    [ 1707.894113] usb usb5: root hub lost power or was reset
    [ 1707.894258] ehci-pci 0000:00:1a.7: setting latency timer to 64
    [ 1707.894522] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
    [ 1707.894751] uhci_hcd 0000:00:1d.0: setting latency timer to 64
    [ 1707.894780] usb usb6: root hub lost power or was reset
    [ 1707.894922] uhci_hcd 0000:00:1d.1: setting latency timer to 64
    [ 1707.894950] usb usb7: root hub lost power or was reset
    [ 1707.895091] uhci_hcd 0000:00:1d.2: setting latency timer to 64
    [ 1707.895120] usb usb8: root hub lost power or was reset
    [ 1707.895262] ehci-pci 0000:00:1d.7: setting latency timer to 64
    [ 1707.895293] pci 0000:00:1e.0: setting latency timer to 64
    [ 1707.895313] ahci 0000:00:1f.2: setting latency timer to 64
    [ 1707.895359] tg3 0000:02:00.0: System wakeup disabled by ACPI
    [ 1707.895408] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
    [ 1708.216179] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    [ 1708.224186] ata5: SATA link down (SStatus 0 SControl 300)
    [ 1708.228192] usb 3-1: reset full-speed USB device number 2 using uhci_hcd
    [ 1708.232074] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [ 1708.240191] ata6: SATA link down (SStatus 0 SControl 300)
    [ 1708.286676] ata1.00: configured for UDMA/133
    [ 1708.299111] ata2.00: configured for UDMA/133
    [ 1708.300124] sd 0:0:0:0: [sda] Starting disk
    [ 1708.476093] usb 1-3: reset high-speed USB device number 3 using ehci-pci
    [ 1709.150457] PM: resume of devices complete after 1257.268 msecs
    [ 1709.336191] Restarting tasks ... done.
    [ 1709.367032] video LNXVIDEO:00: Restoring backlight state
    [ 1710.096879] tg3 0000:02:00.0: irq 47 for MSI/MSI-X
    [ 1710.880386] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 1710.884913] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [ 1710.887928] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [ 1710.972052] [drm] HPD interrupt storm detected on connector DP-2: switching from hotplug detection to polling
    [ 1711.016702] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1717.393522] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 1717.395452] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 1717.402855] wlan0: authenticated
    [ 1717.403206] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 1717.404778] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 1717.426319] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=2)
    [ 1717.429799] wlan0: associated
    [ 1717.429873] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 2599.784789] tg3 0000:02:00.0: System wakeup enabled by ACPI
    [ 2599.970594] PM: Syncing filesystems ... done.
    [ 2600.003652] Freezing user space processes ... (elapsed 0.01 seconds) done.
    [ 2600.020263] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
    [ 2600.036277] Suspending console(s) (use no_console_suspend to debug)
    [ 2600.036743] wlan0: deauthenticating from 38:22:9d:03:a7:d2 by local choice (reason=3)
    [ 2600.046507] cfg80211: Calling CRDA to update world regulatory domain
    [ 2600.081326] sd 0:0:0:0: [sda] Synchronizing SCSI cache
    [ 2600.082381] sd 0:0:0:0: [sda] Stopping disk
    [ 2600.632125] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D3hot
    [ 2600.632178] PM: suspend of devices complete after 595.499 msecs
    [ 2600.632476] PM: late suspend of devices complete after 0.294 msecs
    [ 2600.648358] ehci-pci 0000:00:1d.7: System wakeup enabled by ACPI
    [ 2600.664066] uhci_hcd 0000:00:1d.2: System wakeup enabled by ACPI
    [ 2600.664109] uhci_hcd 0000:00:1d.1: System wakeup enabled by ACPI
    [ 2600.664150] uhci_hcd 0000:00:1d.0: System wakeup enabled by ACPI
    [ 2600.664281] ehci-pci 0000:00:1a.7: System wakeup enabled by ACPI
    [ 2600.680061] uhci_hcd 0000:00:1a.2: System wakeup enabled by ACPI
    [ 2600.680102] uhci_hcd 0000:00:1a.1: System wakeup enabled by ACPI
    [ 2600.680143] uhci_hcd 0000:00:1a.0: System wakeup enabled by ACPI
    [ 2600.680196] PM: noirq suspend of devices complete after 47.717 msecs
    [ 2600.680424] ACPI: Preparing to enter system sleep state S3
    [ 2600.704451] PM: Saving platform NVS memory
    [ 2600.704805] Disabling non-boot CPUs ...
    [ 2600.808021] smpboot: CPU 1 is now offline
    [ 2600.808344] ACPI: Low-level resume complete
    [ 2600.808344] PM: Restoring platform NVS memory
    [ 2600.808344] Enabling non-boot CPUs ...
    [ 2600.808344] smpboot: Booting Node 0 Processor 1 APIC 0x1
    [ 2600.820163] CPU1 is up
    [ 2600.824253] ACPI: Waking up from system sleep state S3
    [ 2600.928209] uhci_hcd 0000:00:1a.0: System wakeup disabled by ACPI
    [ 2600.928280] uhci_hcd 0000:00:1a.1: System wakeup disabled by ACPI
    [ 2600.928354] uhci_hcd 0000:00:1a.2: System wakeup disabled by ACPI
    [ 2600.944082] ehci-pci 0000:00:1a.7: System wakeup disabled by ACPI
    [ 2600.944621] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D0
    [ 2600.960431] uhci_hcd 0000:00:1d.0: System wakeup disabled by ACPI
    [ 2600.960500] uhci_hcd 0000:00:1d.1: System wakeup disabled by ACPI
    [ 2600.960568] uhci_hcd 0000:00:1d.2: System wakeup disabled by ACPI
    [ 2600.976081] ehci-pci 0000:00:1d.7: System wakeup disabled by ACPI
    [ 2601.024238] yenta_cardbus 0000:0d:06.0: O2: enabling read prefetch/write burst. If you experience problems or performance issues, use the yenta_socket parameter 'o2_speedup=off'
    [ 2601.040847] PM: noirq resume of devices complete after 125.666 msecs
    [ 2601.041168] PM: early resume of devices complete after 0.277 msecs
    [ 2601.041220] i915 0000:00:02.0: setting latency timer to 64
    [ 2601.041599] uhci_hcd 0000:00:1a.0: setting latency timer to 64
    [ 2601.041630] usb usb3: root hub lost power or was reset
    [ 2601.041775] uhci_hcd 0000:00:1a.1: setting latency timer to 64
    [ 2601.041804] usb usb4: root hub lost power or was reset
    [ 2601.041945] uhci_hcd 0000:00:1a.2: setting latency timer to 64
    [ 2601.041974] usb usb5: root hub lost power or was reset
    [ 2601.042117] ehci-pci 0000:00:1a.7: setting latency timer to 64
    [ 2601.042312] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
    [ 2601.042571] uhci_hcd 0000:00:1d.0: setting latency timer to 64
    [ 2601.042611] usb usb6: root hub lost power or was reset
    [ 2601.042757] uhci_hcd 0000:00:1d.1: setting latency timer to 64
    [ 2601.042785] usb usb7: root hub lost power or was reset
    [ 2601.042926] uhci_hcd 0000:00:1d.2: setting latency timer to 64
    [ 2601.042955] usb usb8: root hub lost power or was reset
    [ 2601.043100] ehci-pci 0000:00:1d.7: setting latency timer to 64
    [ 2601.043130] pci 0000:00:1e.0: setting latency timer to 64
    [ 2601.043151] ahci 0000:00:1f.2: setting latency timer to 64
    [ 2601.043196] tg3 0000:02:00.0: System wakeup disabled by ACPI
    [ 2601.166515] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
    [ 2601.364167] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    [ 2601.368163] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [ 2601.372176] ata5: SATA link down (SStatus 0 SControl 300)
    [ 2601.384184] ata6: SATA link down (SStatus 0 SControl 300)
    [ 2601.388182] usb 1-3: reset high-speed USB device number 3 using ehci-pci
    [ 2601.423024] ata1.00: configured for UDMA/133
    [ 2601.440006] ata2.00: configured for UDMA/133
    [ 2601.440165] sd 0:0:0:0: [sda] Starting disk
    [ 2601.640194] usb 3-1: reset full-speed USB device number 2 using uhci_hcd
    [ 2601.901404] ACPI Error: [CB04] Namespace lookup failure, AE_ALREADY_EXISTS (20130328/dsfield-211)
    [ 2601.901416] ACPI Error: Method parse/execution failed [\_SB_.AMW0.WMCA] (Node ffff8800b6a37960), AE_ALREADY_EXISTS (20130328/psparse-537)
    [ 2601.901428] ACPI: Marking method WMCA as Serialized because of AE_ALREADY_EXISTS error
    [ 2601.974705] PM: resume of devices complete after 933.527 msecs
    [ 2601.978989] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [ 2601.987000] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [ 2601.975690] Restarting tasks ... done.
    [ 2602.020301] video LNXVIDEO:00: Restoring backlight state
    [ 2602.055568] cfg80211: World regulatory domain updated:
    [ 2602.055579] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 2602.055584] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2602.055589] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2602.055594] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2602.055598] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2602.055603] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2602.119178] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2603.261029] tg3 0000:02:00.0: irq 47 for MSI/MSI-X
    [ 2604.031899] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 2604.033170] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [ 2604.036214] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [ 2604.156486] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2610.537669] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 2610.539337] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 2610.546728] wlan0: authenticated
    [ 2610.547100] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 2610.548135] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 2610.569678] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=2)
    [ 2610.572771] wlan0: associated
    [ 2610.572855] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 2874.228665] cfg80211: Calling CRDA to update world regulatory domain
    [ 2874.242406] cfg80211: World regulatory domain updated:
    [ 2874.242417] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 2874.242425] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2874.242432] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2874.242438] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2874.242444] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2874.242450] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2922.349184] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 2922.350370] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 2922.357755] wlan0: authenticated
    [ 2922.357967] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 2922.360204] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 2922.381760] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 2922.383628] wlan0: associated
    [ 2922.383675] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 3919.876334] cfg80211: Calling CRDA to update world regulatory domain
    [ 3919.890771] cfg80211: World regulatory domain updated:
    [ 3919.890786] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 3919.890793] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3919.890801] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 3919.890807] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 3919.890813] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3919.890819] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3931.258137] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 3931.259578] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 3931.364059] wlan0: send auth to 38:22:9d:03:a7:d2 (try 2/3)
    [ 3931.366374] wlan0: authenticated
    [ 3931.366612] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 3931.368070] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 3931.399085] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 3931.401124] wlan0: associated
    [ 3931.401158] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 6115.221284] cfg80211: Calling CRDA to update world regulatory domain
    [ 6115.234082] cfg80211: World regulatory domain updated:
    [ 6115.234087] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 6115.234089] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6115.234092] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 6115.234094] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 6115.234096] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6115.234099] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6126.586105] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 6126.587691] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 6126.590124] wlan0: authenticated
    [ 6126.590602] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 6126.592566] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 6126.623700] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 6126.626016] wlan0: associated
    [ 6133.196395] cfg80211: Calling CRDA to update world regulatory domain
    [ 6133.206728] cfg80211: World regulatory domain updated:
    [ 6133.206749] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 6133.206752] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6133.206755] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 6133.206757] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 6133.206760] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6133.206762] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 6136.372481] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 6136.374040] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 6136.396166] wlan0: send auth to 38:22:9d:03:a7:d2 (try 2/3)
    [ 6136.417797] wlan0: send auth to 38:22:9d:03:a7:d2 (try 3/3)
    [ 6136.437974] wlan0: authentication with 38:22:9d:03:a7:d2 timed out
    [ 6152.104905] show_signal_msg: 51 callbacks suppressed
    [ 6152.104911] plugin-containe[4977]: segfault at 0 ip 00007f0d29bd3d72 sp 00007fffe83a9720 error 4 in plugin-container[7f0d29bc9000+10000]
    [ 6156.009601] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 6156.010834] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 6156.013146] wlan0: authenticated
    [ 6156.013354] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 6156.013359] wlan0: waiting for beacon from 38:22:9d:03:a7:d2
    [ 6156.020036] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 6156.051092] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 6156.052938] wlan0: associated
    [ 9816.900205] cfg80211: Calling CRDA to update world regulatory domain
    [ 9816.907535] cfg80211: World regulatory domain updated:
    [ 9816.907539] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 9816.907542] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 9816.907545] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 9816.907547] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 9816.907549] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 9816.907551] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 9852.800830] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
    [ 9854.815147] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
    [ 9854.816523] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    [ 9854.819562] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
    [ 9854.942367] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 9861.373331] wlan0: authenticate with 38:22:9d:03:a7:d2
    [ 9861.375442] wlan0: send auth to 38:22:9d:03:a7:d2 (try 1/3)
    [ 9861.383021] wlan0: authenticated
    [ 9861.383451] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 9861.384140] wlan0: associate with 38:22:9d:03:a7:d2 (try 1/3)
    [ 9861.405677] wlan0: RX AssocResp from 38:22:9d:03:a7:d2 (capab=0x431 status=0 aid=1)
    [ 9861.409165] wlan0: associated
    [ 9861.409256] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    I think you can find more recent events in the last lines of course.

  2. #2
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: WiFi often disconnects

    Anyone with an idea in mind?

  3. #3
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,640
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WiFi often disconnects

    Hi, copy and paste this command in the terminal (ctrl+alt+t) please:
    Code:
     wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script
    It will download a script and create a file named wireless-info.tar.gz in your home folder with wireless information so we can see the condition of your wireless at this time and the Mac address, WPA key and WEP key are removed for your security, then reply back, click on the paper clip and attach the wireless-info.tar.gz file as a zip file.

    If you do not have ethernet either then follow the directions at this link for running the script without internet.
    http://ubuntuforums.org/showpost.php?p=12350385
    Thanks

  4. #4
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    Post Re: WiFi often disconnects

    I've attached the gzip file to this message.
    Attached Files Attached Files

  5. #5
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,640
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WiFi often disconnects

    Hi, please do:
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    Then add this one line to the bottom of the file:
    Code:
    options iwlwifi 11n_disable=1 swcrypto=1 bt_coex_active=N
    Also it would be best to set your encryption in your router to just wpa2 if you have that option wep does not work well with linux.
    Then reboot
    Thanks

  6. #6
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: WiFi often disconnects

    I tried WEP only once, but I always use WPA. Is it OK? Actually I don't know why I see "WEP" in dmesg.

  7. #7
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: WiFi often disconnects

    I added that line in iwlwifi.conf, but wifi just disconnected again
    Seems that this time disabling wifi with network manager and enabling it again won't work. Doesn't even connect on my Nexus 4.

    Code:
    [ 2933.298446] wlan0: direct probe to 38:22:9d:03:a7:d2 (try 1/3)
    [ 2933.500070] wlan0: direct probe to 38:22:9d:03:a7:d2 (try 2/3)
    [ 2933.704088] wlan0: direct probe to 38:22:9d:03:a7:d2 (try 3/3)
    [ 2933.908085] wlan0: authentication with 38:22:9d:03:a7:d2 timed out
    Anyway, it's totally random: sometimes it just connects again, sometimes not (just like now, for example).
    Last edited by Shishimaru; July 6th, 2013 at 08:27 PM.

  8. #8
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,640
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WiFi often disconnects

    Please post the contents of:
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    and set your wireless settings in network manger to match the screenshots.
    The dmesg about the wep is strange and it looks like you have a bug in the kernel but I am not sure that is your issue.
    Thanks
    Attached Images Attached Images

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,925
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: WiFi often disconnects

    iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    Just peeking over your shoulders. This means that HT and VHT, or high throughput and very high throughput; also known as N speeds, are disabled because the router is set to either WEP or TKIP. You have already said you are using WPA, so the router must be set to WPA-TKIP. The encryption algorithm AES is more secure so I suggest you reset the router to WPA2-AES. http://www.dd-wrt.com/phpBB2/files/wpa2aes_174.jpg

    I am not sure that will help you connect any better, but it will eliminate a troubling message and one possibility.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Nov 2009
    Location
    Caserta, Italy
    Beans
    51
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: WiFi often disconnects

    @Wild Man: my NM settings are already like that (just using OpenDNS and not Google's).
    This is the file content:
    Code:
    ~$ cat /etc/modprobe.d/iwlwifi.conf
    # /etc/modprobe.d/iwlwifi.conf
    # iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
    # microcode file installed on the system.  When removing iwlwifi, first
    # remove the iwl?vm module and then iwlwifi.
    remove iwlwifi \
    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
    && /sbin/modprobe -r mac80211
    options iwlwifi 11n_disable=1 swcrypto=1 bt_coex_active=N
    @chili555: OK, I'm going to try AES algorithm and I'll let you know if it'll make a difference or not.

    Thanks to both: some little help definitely helps me feeling less abandoned about this issue. Anyway, do you people think that advanced settings like DTIM or beaconing interval have something to do?

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •