Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 43

Thread: New xorg-server 1.14.1 has arrived

  1. #31
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: New xorg-server 1.14.1 has arrived

    Quote Originally Posted by VinDSL View Post
    I dunno... Maybe I just got lucky.
    I couldn't get anywhere with 1.14.1 on this legacy machine, soooo...
    I installed (edgers) xserver-xephyr 1.14.2 & xserver-common 1.14.2, and waited patiently for xserver-xorg-core 1.14.2 to be fully cooked (it was being held back, after the partial upgrade).
    Yesterday, one or more of the dependencies that xserver-xorg-core 1.14.2 was waiting for was fulfilled.
    Of note...
    Code:
    Commit Log for Mon Jul  8 12:46:19 2013
    Removed the following packages:
    xserver-xorg-input-mouse
    xserver-xorg-video-vesa
    I *thought* this was rather odd.
    Just saying...
    Did You try to re-install these two packages?

  2. #32
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,802
    Distro
    Ubuntu Development Release

    Re: New xorg-server 1.14.1 has arrived

    Quote Originally Posted by zika View Post
    Did You try to re-install these two packages?
    No. Everything seems to be running fine without them...

    Code:
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-input-mouse
    xserver-xorg-input-mouse:
      Installed: (none)
      Candidate: 1:1.7.2-3build1
      Version table:
         1:1.7.2-3build1 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-video-vesa
    xserver-xorg-video-vesa:
      Installed: (none)
      Candidate: 1:2.3.2-0ubuntu3
      Version table:
         1:2.3.2-0ubuntu3 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
    vindsl@Zuul:~$
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  3. #33
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: New xorg-server 1.14.1 has arrived

    Quote Originally Posted by VinDSL View Post
    No. Everything seems to be running fine without them...
    My mistake, I thought You need them...

  4. #34
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,802
    Distro
    Ubuntu Development Release

    Re: New xorg-server 1.14.1 has arrived

    Quote Originally Posted by zika View Post
    My mistake, I thought You need them...
    I thought so, too.

    Weird, eh?

    Here's something even weirder...

    I've always had a problem with my mouse pointer jumping around the screen, for no apparent reason. For instance, I'll just be sitting here, reading a page, and the pointer will jump to the bottom, or top-left corner of the screen... whenever, wherever. It's like some poltergeist moves it on me.

    It doesn't *seem* to be doing that now.

    I'll keep an eye on it, and see if it's my imagination, or it's been fixed.
    Last edited by VinDSL; July 9th, 2013 at 06:20 PM. Reason: Addendum
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  5. #35
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,802
    Distro
    Ubuntu Development Release

    Re: New xorg-server 1.14.1 has arrived

    Hrm...

    I was just checking the description of x11-xserver-utils, and it says:

    An X client is a program that interfaces with an X server (almost always via
    the X libraries), and thus with some input and output hardware like a
    graphics card, monitor, keyboard, and pointing device (such as a mouse).
    Perhaps, I've been inadvertently running two (or more) mouse drivers, all these years.

    BTW, here's the extent of my xserver stable...




    Working a treat, on this old dog...
    Last edited by VinDSL; July 9th, 2013 at 06:45 PM. Reason: Addendum
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  6. #36
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: New xorg-server 1.14.1 has arrived

    Quote Originally Posted by VinDSL View Post
    Hrm...

    I was just checking the description of x11-xserver-utils, and it says:

    An X client is a program that interfaces with an X server (almost always via
    the X libraries), and thus with some input and output hardware like a
    graphics card, monitor, keyboard, and pointing device (such as a mouse).

    Perhaps, I've been inadvertently running two (or more) mouse drivers, all these years.
    ...
    Working a treat, on this old dog...
    Xserver-utils interfaces with some hardware...
    It does not mean it includes drivers.

    However, xserver-xorg-input-mouse is generally not needed at all.
    That is because the newer pointing device driver system, xserver-xorg-input-evdev, takes care of it.
    So if you have both -mouse and -evdev packages installed, your setup will use -evdev, not -mouse package.

  7. #37
    Join Date
    Sep 2008
    Beans
    796

    Re: New xorg-server 1.14.1 has arrived

    With proposed updates and xorg-edgers enabled there wasn't much sign that I would be able to upgrade to X Server 1.14.2 any time soon without removing anything.

    Note to self of packages removed/upgraded:

    Code:
    paul@lubuntu-64:~$ sudo aptitude full-upgrade
    The following packages will be upgraded: 
      libxfixes3 libxi6 xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-wacom xserver-xorg-video-ati xserver-xorg-video-intel xserver-xorg-video-mga 
      xserver-xorg-video-modesetting xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-tdfx 
      xserver-xorg-video-vmware 
    15 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3,317 kB of archives. After unpacking 1,024 B will be used.
    The following packages have unmet dependencies:
     xserver-xorg-video-siliconmotion : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-sisusb : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-savage : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-neomagic : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-input-synaptics : Depends: xorg-input-abi-18 which is a virtual package.
     xserver-xorg-input-mouse : Depends: xorg-input-abi-18 which is a virtual package.
     xserver-xorg-video-vesa : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-cirrus : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-mach64 : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-fbdev : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-trident : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-input-vmmouse : Depends: xorg-input-abi-18 which is a virtual package.
     xserver-xorg-video-sis : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-s3 : Depends: xorg-video-abi-13 which is a virtual package.
     xserver-xorg-video-r128 : Depends: xorg-video-abi-13 which is a virtual package.
    The following actions will resolve these dependencies:
    
          Remove the following packages:    
    1)      xserver-xorg-input-all          
    2)      xserver-xorg-input-mouse        
    3)      xserver-xorg-input-synaptics    
    4)      xserver-xorg-input-vmmouse      
    5)      xserver-xorg-video-all          
    6)      xserver-xorg-video-ati          
    7)      xserver-xorg-video-cirrus       
    8)      xserver-xorg-video-fbdev        
    9)      xserver-xorg-video-mach64       
    10)     xserver-xorg-video-neomagic     
    11)     xserver-xorg-video-r128         
    12)     xserver-xorg-video-s3           
    13)     xserver-xorg-video-savage       
    14)     xserver-xorg-video-siliconmotion
    15)     xserver-xorg-video-sis          
    16)     xserver-xorg-video-sisusb       
    17)     xserver-xorg-video-trident      
    18)     xserver-xorg-video-vesa         
    
    
    
    Accept this solution? [Y/n/q/?] q
    Abandoning all efforts to resolve these dependencies.
    Abort.
    paul@lubuntu-64:~$
    The only ones I cared about keeping were xserver-xorg-video-fbdev and xserver-xorg-video-vesa, but in theory I should be able to add them again at some point.

    All still seems to be working ok.

  8. #38
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,802
    Distro
    Ubuntu Development Release

    Re: New xorg-server 1.14.1 has arrived

    I'm running 1.14.2...

    Code:
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-core
    xserver-xorg-core:
      Installed: 2:1.14.2+git20130717+server-1.14-branch.54b125d1-0ubuntu0ricotz
      Candidate: 2:1.14.2+git20130717+server-1.14-branch.54b125d1-0ubuntu0ricotz
      Version table:
     *** 2:1.14.2+git20130717+server-1.14-branch.54b125d1-0ubuntu0ricotz 0
            500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ saucy/main i386 Packages
            100 /var/lib/dpkg/status
         2:1.14.2-0ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-video-fbdev
    xserver-xorg-video-fbdev:
      Installed: 1:0.4.3-0ubuntu3
      Candidate: 1:0.4.3-0ubuntu3
      Version table:
     *** 1:0.4.3-0ubuntu3 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
            100 /var/lib/dpkg/status
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-video-vesa
    xserver-xorg-video-vesa:
      Installed: 1:2.3.2-0ubuntu3
      Candidate: 1:2.3.2-0ubuntu3
      Version table:
     *** 1:2.3.2-0ubuntu3 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
            100 /var/lib/dpkg/status
    vindsl@Zuul:~$ apt-cache policy xserver-xorg-video-nouveau
    xserver-xorg-video-nouveau:
      Installed: 1:1.0.8+git20130710.8c1c5d4f-0ubuntu0sarvatt
      Candidate: 1:1.0.8+git20130710.8c1c5d4f-0ubuntu0sarvatt
      Version table:
     *** 1:1.0.8+git20130710.8c1c5d4f-0ubuntu0sarvatt 0
            500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ saucy/main i386 Packages
            100 /var/lib/dpkg/status
         1:1.0.8-0ubuntu1.1 0
            500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
    vindsl@Zuul:~$
    Yes, it removed the stuff you listed (above), but I simply reinstalled what I wanted.

    Seems to work fine with 1.14.2
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  9. #39
    Join Date
    Sep 2008
    Beans
    796

    Re: New xorg-server 1.14.1 has arrived

    Hi Vin,

    Yep, seems to be ok here too.

    I owe you another post about the 3.11-rc1 kernel and the legacy nvidia drivers! I'll do that quickly now.

    Cheers,

    Paul

  10. #40
    Join Date
    May 2010
    Beans
    142

    Re: New xorg-server 1.14.1 has arrived

    Yesterdays updates killed X hard for me, and various kernels worked so-so but eventually I got everything back up using yesterdays daily 3.11-kernel. Gnome-shell is smooth etc but I have the segfaulting Gimp issue...

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •