Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Xruns

  1. #1
    Join Date
    Jul 2013
    Beans
    5

    Xruns

    Hello everybody! I'm an Ubuntu newbie.

    I shifted from Windows to Ubuntu 12.04 (64 bit) six months ago. Now I've just upgraded my system to Ubuntu Studio following the Selective Upgrade guide (https://help.ubuntu.com/community/Ub...ective_Upgrade).

    Everything went well until I tried to install the Real Time Kernel as instructed in the previously mentioned guide. I got an issue when executing the command:

    sudo apt-get install linux-rt linux-headers-rt

    I got the following message:

    Code:
    sudo apt-get install linux-rt linux-headers-rt
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package linux-rt
    E: Unable to locate package linux-headers-rt
    I decided to give a try to my new system anyway. I connected my Alesis io2 interface, launched Jack and Ardour, and tried to record some stuff. I got horrible cracks while recording a new track and when playing it back. I tried to change various parameters in Jack (frames/period, sample rate, periods/buffer etc.) without any results.

    Do you think the cracks depends on the lack of a real time kernel? Are those cracks caused by xruns? How can I install a real time kernel?

    Thank you very much for your patience and kind support.
    Last edited by Almuzura; July 4th, 2013 at 11:15 AM.

  2. #2
    Join Date
    Jun 2008
    Beans
    1,139
    Distro
    Ubuntu Studio

    Re: Xruns

    There is no RT kernel in 12.04. Use lowlatency instead.
    Something like
    Code:
    sudo apt-get install linux-lowlatency
    etc.

    Hard to say. Check your CPU speed is on performance.

  3. #3
    Join Date
    Apr 2007
    Location
    Netherlands
    Beans
    218
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Xruns

    ubuntu(studio) 12.04 doesn't have any linux-rt
    I advise you to give the packages from kx-studio a try (http://kxstudio.sourceforge.net/), I've got very good results with it.
    Read on how to upgrading here http://kxstudio.sourceforge.net/Docu...Ubuntu:Upgrade
    I didn't install the full desktop package , just the low-latency kernel and the apps I needed
    Last edited by luctor; July 4th, 2013 at 01:27 PM. Reason: forgot 12.04

  4. #4
    Join Date
    Jul 2013
    Beans
    5

    Re: Xruns

    Thank you, Jejeman!
    It worked. Now I can set latency as low as 10 ms without getting cracks.

    Thank you, Luctor, too.
    I will browse that page on KXStudio anyway; I might find something helpful!

    Bye!
    Last edited by Almuzura; July 5th, 2013 at 04:14 PM.

  5. #5
    Join Date
    Jul 2013
    Beans
    5

    Re: Xruns

    Hello everybody,

    the problem with xruns appeared again.

    Maybe it's due to the fact that I have reached a certain number of tracks and the system resources are insufficient?

  6. #6
    Join Date
    Jan 2012
    Beans
    56

    Re: Xruns

    Just raise your latency if it's getting too much for the system.Unless you're doing midi recording or you are monitoring your instrument through the system rather that an amp or something then you're better off with a higher latency to give the system more time to process the audio data.

  7. #7
    Join Date
    Jul 2013
    Beans
    5

    Re: Xruns

    Thank you, CraigPid.
    That's what I actually did. The point is that I have to raise the latency up to 40ms or more to avoid or at least lessen the chances to get xruns. But 40ms it's not tolerable. In the end I had to temporarily move the tracks that I had recorded, which is also a non ideal situation. Do you think that the audio interface is also responsible for latency issues or it all depends on the computer? I'm using an Alesis io2. Maybe I just need to upgrade my system.

  8. #8
    Join Date
    Jan 2012
    Beans
    56

    Re: Xruns

    40 ms would really suck. I'm not familiar with that audio interface but a lot of factors in the system can contribute to latency. That said ... if the system is set up properly there shouldn't really be a problem even on an older system. Do you have other programs or services running that are using cpu cycles? You said you upgraded from 12.04 to Ubuntu Studio. Did you try doing a clean install of Ubuntu Studio and disable the startup services that you don't need. If you have compositing disabled that makes a big difference.

  9. #9
    Join Date
    May 2013
    Location
    Hamunaptra
    Beans
    624
    Distro
    Ubuntu Studio

    Re: Xruns

    CraigPid, Thanks for the suggestion of 'disabling compositing' ... helped me a little...
    bhatta

    May the Source be with you !
    Ash nazg durbatulûk, ash nazg gimbatul, ash nazg thrakatulûk, agh
    'Buntu-ishi krimpatul !

  10. #10
    Join Date
    Jul 2013
    Beans
    5

    Re: Xruns

    No, I don't have any other program running apart from Ardour. How can I disable compositing? I wanna try this. If it doesn't work, I'll try a clean install of Ubuntu Studio. Thank you anyway for your priceless suggestions!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •