Page 2 of 13 FirstFirst 123412 ... LastLast
Results 11 to 20 of 124

Thread: wireless keeps asking for password, ubuntu 12.04

  1. #11
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,709
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Hi, please show the output of:
    Code:
    lspci -nnk | grep -iA2 net
    Thanks

  2. #12
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by Wild Man View Post
    Hi, please show the output of:
    Code:
    lspci -nnk | grep -iA2 net
    Thanks
    Code:
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 07)	Subsystem: Hewlett-Packard Company Device [103c:1858]
    	Kernel driver in use: r8169
    --
    02:00.0 Network controller [0280]: Ralink corp. Device [1814:3290]
    	Subsystem: Hewlett-Packard Company Device [103c:18ec]
    	Kernel driver in use: rt2860
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  3. #13
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,709
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    It says that rt2860 is the driver being used but it does not look right to me, if that is the driver like it says you should be able to do this:
    Code:
    gksudo gedit /etc/pm/config.d/unload_modules
    then add this line:
    Code:
    SUSPEND_MODULES="$SUSPEND_MODULES rt2860
    save then close gedit and reboot.
    Thanks

  4. #14
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by Wild Man View Post
    It says that rt2860 is the driver being used but it does not look right to me, if that is the driver like it says you should be able to do this:
    Code:
    gksudo gedit /etc/pm/config.d/unload_modules
    then add this line:
    Code:
    SUSPEND_MODULES="$SUSPEND_MODULES rt2860
    save then close gedit and reboot.
    Thanks
    I'm trying it now.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  5. #15
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    It didnt fix it.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  6. #16
    Join Date
    Apr 2012
    Beans
    5,341

    Re: wireless keeps asking for password, ubuntu 12.04

    Do you have autologin enabled? is the 'Available to all users' box checked as well as the 'Connect automatically' one?

  7. #17
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by steeldriver View Post
    Do you have autologin enabled? is the 'Available to all users' box checked as well as the 'Connect automatically' one?
    No, yes, and yes.

    Edit: Now it has auto login.
    Last edited by pretty_whistle; July 5th, 2013 at 02:37 AM.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  8. #18
    Join Date
    Apr 2012
    Beans
    5,341

    Re: wireless keeps asking for password, ubuntu 12.04

    OK... there goes that theory (I was thinking it might be keyring related rather than wifi related per se)

  9. #19
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,713
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by Wild Man View Post
    It says that rt2860 is the driver being used but it does not look right to me....
    Wild Man, it is rt3290sta we compiled here : http://ubuntuforums.org/showthread.p...1#post12716581
    Weird ways of Ralink..

    @ pretty_whistle,
    Accordingly, try "rt3290sta" instead of rt2860 in Wild Man's solution. It is supposed to unload the module when going to sleep, then load it again when resuming. Not the same thing that I was thinking (delaying the connection), but often helps.

    You also said "reboot". Does it do this after a reboot as well? Or just after a sleep --> resume cycle?
    And.. do you need to click on the password box only once? Like everything is working absolutely perfect, just can't do it automatically?

    Answer to these two question can significantly change our approach, if the above suggestion fails to do the trick.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  10. #20
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    956
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by varunendra View Post
    Wild Man, it is rt3290sta we compiled here : http://ubuntuforums.org/showthread.p...1#post12716581
    Weird ways of Ralink..

    @ pretty_whistle,
    Accordingly, try "rt3290sta" instead of rt2860 in Wild Man's solution. It is supposed to unload the module when going to sleep, then load it again when resuming. Not the same thing that I was thinking (delaying the connection), but often helps.

    You also said "reboot". Does it do this after a reboot as well? Or just after a sleep --> resume cycle?
    And.. do you need to click on the password box only once? Like everything is working absolutely perfect, just can't do it automatically?

    Answer to these two question can significantly change our approach, if the above suggestion fails to do the trick.
    I tried Wild Man's solution with rt3290sta but it didnt resolve it. However I did get an error window (see below) and I couldnt suspend anymore so I had to undo it.


    As to your question, yes it does it after a reboot too. And do I need to click on it just once? Yes. It just doesn't do it automatically which is what I want it to do.
    Last edited by pretty_whistle; July 5th, 2013 at 04:34 PM.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


Page 2 of 13 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •