Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 124

Thread: wireless keeps asking for password, ubuntu 12.04

  1. #1
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    971
    Distro
    Ubuntu 14.04 Trusty Tahr

    Question wireless keeps asking for password, ubuntu 12.04

    This is on Ubuntu 12.04.

    After a reboot and coming back from 'suspend' my wireless connection tries to reconnect but keeps asking for the password. Its already filled in for me in the little window so I have to hit the 'connect' button.

    How do I correct this and connect automatically?
    Last edited by pretty_whistle; July 11th, 2013 at 12:29 AM.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,897
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Please follow the "Wireless Script" link in my signature, download the script as per Method #2 there and keep the script ready. Run the script when it fails to connect after resuming from suspend, and post back the report it generates.

    And what do you mean by "after reboot"? Does it work well in any case at all? Is it the same rt3290sta driver that we compiled a few hours ago in a different thread?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #3
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,897
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Just got a message from my respectable friend Hadaka, and re-read your post -
    Quote Originally Posted by pretty_whistle View Post
    Its already filled in for me in the little window so I have to hit the 'connect' button.

    How do I correct this and connect automatically?
    I think I totally misunderstood your post earlier (if not this time). Do you mean you are able to connect just fine only need to "click" the button manually? If so, there is no need to go through the script or any other hassles. Just edit your connection to make it connect automatically -

    Open Network Manager > Edit Connection > Wireless tab > double-click your connection to edit it > make sure "Connect Automatically" box has a Tick-mark in it > Save and close > Done !

    Thanks again to Hadaka for waking me up
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  4. #4
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    971
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by varunendra View Post
    Just got a message from my respectable friend Hadaka, and re-read your post -


    I think I totally misunderstood your post earlier (if not this time). Do you mean you are able to connect just fine only need to "click" the button manually? If so, there is no need to go through the script or any other hassles. Just edit your connection to make it connect automatically -

    Open Network Manager > Edit Connection > Wireless tab > double-click your connection to edit it > make sure "Connect Automatically" box has a Tick-mark in it > Save and close > Done !

    Thanks again to Hadaka for waking me up
    That's correct. I just need to click the button manually.

    And the 'connect automatically' box has a tick-mark in it but it's acting like it doesn't.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,897
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by pretty_whistle View Post
    That's correct. I just need to click the button manually.

    And the 'connect automatically' box has a tick-mark in it but it's acting like it doesn't.
    Hmm.. maybe then it is an issue of driver not getting ready in time. But just as a sanity check, have you saved the correct password and security type in Network Manager itself ?

    If yes, please post the output of -
    Code:
    sudo cat /etc/NetworkManager/system-connections/<your connection name>
    CAUTION !! The above output will also contain your saved password. Remove or obscure it before posting the output here !
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #6
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    971
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by varunendra View Post
    Hmm.. maybe then it is an issue of driver not getting ready in time. But just as a sanity check, have you saved the correct password and security type in Network Manager itself ?

    If yes, please post the output of -
    Code:
    sudo cat /etc/NetworkManager/system-connections/<your connection name>
    CAUTION !! The above output will also contain your saved password. Remove or obscure it before posting the output here !
    I saved the right info alright, I even re-entered it to be sure.

    Here's the output:

    Code:
    [connection]id=H5c8a4fWr
    uuid=ea16b0ca-9464-410b-abc5-d5c79fabd74e
    type=802-11-wireless
    timestamp=1372955628
    
    
    [802-11-wireless]
    ssid=*********
    mode=infrastructure
    security=802-11-wireless-security
    
    
    [802-11-wireless-security]
    key-mgmt=wpa-psk
    psk=**********
    
    
    [ipv4]
    method=auto
    
    
    [ipv6]
    method=auto
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,897
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless keeps asking for password, ubuntu 12.04

    Everything seems as it should be in the settings. Maybe we just need to delay the initiation of connection somehow. Unfortunately I don't yet know how to do it. I'll need to do some searching-reading on it. I suggest you do the same (how to delay wireless connection after resuming/rebooting).

    Please remind me if I forget about this and no one else comes up with a suggestion either.
    (I pick up threads by noticing new posts)
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #8
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    971
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    Quote Originally Posted by varunendra View Post
    Everything seems as it should be in the settings. Maybe we just need to delay the initiation of connection somehow. Unfortunately I don't yet know how to do it. I'll need to do some searching-reading on it. I suggest you do the same (how to delay wireless connection after resuming/rebooting).

    Please remind me if I forget about this and no one else comes up with a suggestion either.
    (I pick up threads by noticing new posts)
    Thanks for trying.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  9. #9
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: wireless keeps asking for password, ubuntu 12.04

    Hi, give this a try..
    click your launcher...System Settings..Network..Wireless..(highlight YOUR ssid) then click..Forget Network
    boot
    when the system comes back up and says.."Network Connections Are Available" then click YOUR ssid
    Enter your "password-key" connect.
    then..click the wireless icon...next to the envelope..Edit Connections..Wireless..Your ssid..Edit
    Click Connect Automatically.then configure exactly like the attached screen shots..
    Screenshot from 2013-07-04 19:21:48.jpgScreenshot from 2013-07-04 19:20:59.jpgScreenshot from 2013-07-04 19:22:24.jpgScreenshot from 2013-07-04 19:22:44.jpg
    configure your security per your settings..
    save settings...boot
    Last edited by Hadaka; July 5th, 2013 at 12:32 AM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  10. #10
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    971
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless keeps asking for password, ubuntu 12.04

    It's still doing it
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


Page 1 of 13 12311 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •