Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Many errors while installing gcc 3.4.6

  1. #11
    Join Date
    Jun 2007
    Beans
    13,028

    Re: Many errors while installing gcc 3.4.6

    Not sure what your issue is but -
    seems you're running a virtual 11.10 with no 11.10 repo support.
    (11.10 is EOL, you need to switch your sources to the 'old-release' repo

    The way it's showing the attempted install is a bit odd "Unpacking cpp-3.4:i386 " , ect. , don't usually see that though i've not used 11.10 for some time

    cpp is failing on libc6, seems odd there, & there are more fails other than libstdc++6, - libgcc1, maybe others

    So the main question is, Do you have the old-release repos enabled for oneiric?

    The earliest I have is 12.04 32 bit - as you can see no issue with the 3.4 gcc packages (
    doug@doug-XPS-M1330:/media/0a803857-8b6f-4332-82b4-85ebf8283805/home/doug/Desktop/gcc-3.4-32bit$ sudo dpkg -i *.deb
    [sudo] password for doug:
    Selecting previously unselected package cpp-3.4.
    (Reading database ... 291996 files and directories currently installed.)
    Unpacking cpp-3.4 (from cpp-3.4_3.4.6-6ubuntu5_i386.deb) ...
    Selecting previously unselected package g++-3.4.
    Unpacking g++-3.4 (from g++-3.4_3.4.6-6ubuntu5_i386.deb) ...
    Selecting previously unselected package gcc-3.4.
    Unpacking gcc-3.4 (from gcc-3.4_3.4.6-6ubuntu5_i386.deb) ...
    Selecting previously unselected package gcc-3.4-base.
    Unpacking gcc-3.4-base (from gcc-3.4-base_3.4.6-6ubuntu5_i386.deb) ...
    Selecting previously unselected package libstdc++6-dev.
    Unpacking libstdc++6-dev (from libstdc++6-dev_3.4.6-6ubuntu5_i386.deb) ...
    Setting up gcc-3.4-base (3.4.6-6ubuntu5) ...
    Setting up cpp-3.4 (3.4.6-6ubuntu5) ...
    Processing triggers for man-db ...
    Setting up gcc-3.4 (3.4.6-6ubuntu5) ...
    Setting up g++-3.4 (3.4.6-6ubuntu5) ...
    Setting up libstdc++6-dev (3.4.6-6ubuntu5) ...
    doug@doug-XPS-M1330:/media/0a803857-8b6f-4332-82b4-85ebf8283805/home/doug/Desktop/gcc-3.4-32bit$

  2. #12
    Join Date
    Dec 2009
    Location
    Chennai
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Many errors while installing gcc 3.4.6

    You can just try the following.

    $ sudo apt-cache search gcc

    In the output list, if you find gcc-3.4.6 then you can straight away install using
    $ sudo apt-get install gcc-3.4.6

    I think that your trying to install multiple versions of gcc. You need to set different prefix while installing a new version.
    http://gcc.gnu.org/faq.html#multiple

  3. #13
    Join Date
    Jul 2013
    Beans
    8

    Re: Many errors while installing gcc 3.4.6

    Quote Originally Posted by mc4man View Post
    Not sure what your issue is but -
    seems you're running a virtual 11.10 with no 11.10 repo support.
    (11.10 is EOL, you need to switch your sources to the 'old-release' repo

    The way it's showing the attempted install is a bit odd "Unpacking cpp-3.4:i386 " , ect. , don't usually see that though i've not used 11.10 for some time

    cpp is failing on libc6, seems odd there, & there are more fails other than libstdc++6, - libgcc1, maybe others

    So the main question is, Do you have the old-release repos enabled for oneiric?

    The earliest I have is 12.04 32 bit - as you can see no issue with the 3.4 gcc packages (
    http://old-releases.ubuntu.com/ubuntu/dists/hardy/

    I should add this to the sources.list, right?

  4. #14
    Join Date
    Apr 2012
    Beans
    5,362

    Re: Many errors while installing gcc 3.4.6

    Quote Originally Posted by Eredanne View Post
    Yep, I have to compile this code and no other version can compile it without errors...

    I only need it to compile this code. My hosting service doesn't support any other ubuntu versions but, it supports some other ones. Should I go for it?
    What exactly is "this code" and what kind of errors? Have you considered putting your effort into fixing the code so that it builds in your current environment - you may find it's a lot easier than getting a working gcc-3.4.6 based toolchain installed

    Just a thought

  5. #15
    Join Date
    Jul 2013
    Beans
    8

    Re: Many errors while installing gcc 3.4.6

    Quote Originally Posted by steeldriver View Post
    What exactly is "this code" and what kind of errors? Have you considered putting your effort into fixing the code so that it builds in your current environment - you may find it's a lot easier than getting a working gcc-3.4.6 based toolchain installed

    Just a thought
    It's a Anatolia MUD codebase. I tried many versions of GCC in the past and gcc-3.4.6 is the most stable for this one every other one doesn't compile at all or give errors. It would take me days to fix it I assume.

  6. #16
    Join Date
    Jun 2007
    Beans
    13,028

    Re: Many errors while installing gcc 3.4.6

    Quote Originally Posted by Eredanne View Post
    http://old-releases.ubuntu.com/ubuntu/dists/hardy/

    I should add this to the sources.list, right?
    No, you need to add the repo for the EOL release you are using which is 11.10, oneiric.
    The only packages you need or want from hardy you already have (the 5 prev. mentioned

    How you properly add it i've never had reason to know, ask

  7. #17
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,244
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Many errors while installing gcc 3.4.6

    Quote Originally Posted by mc4man View Post
    No, you need to add the repo for the EOL release you are using which is 11.10, oneiric.
    The only packages you need or want from hardy you already have (the 5 prev. mentioned

    How you properly add it i've never had reason to know, ask
    This works, somewhat
    Code:
    sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
    Make sure that each line says old-release, and not us.old-release, or gb.old-release, or whatever the mirror is.
    Then run apt-get update and inevitably comment out the lines which come up with errors.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  8. #18
    Join Date
    Jun 2007
    Beans
    13,028

    Re: Many errors while installing gcc 3.4.6

    Not sure what you're doing wrong, works fine on 11.10
    (the command above from deadflower is good though for this you should have all needed already installed. I'd still do that so you can get any build related packages that aren;t default installed

    Ex. - on a live cd of 11.10 amd64
    ubuntu@ubuntu:/media/0a803857-8b6f-4332-82b4-85ebf8283805/home/doug/Desktop/gcc-3.4$ sudo dpkg -i *.deb
    Selecting previously deselected package cpp-3.4.
    (Reading database ... 130325 files and directories currently installed.)
    Unpacking cpp-3.4 (from cpp-3.4_3.4.6-6ubuntu5_amd64.deb) ...
    Selecting previously deselected package g++-3.4.
    Unpacking g++-3.4 (from g++-3.4_3.4.6-6ubuntu5_amd64.deb) ...
    Selecting previously deselected package gcc-3.4.
    Unpacking gcc-3.4 (from gcc-3.4_3.4.6-6ubuntu5_amd64.deb) ...
    Selecting previously deselected package gcc-3.4-base.
    Unpacking gcc-3.4-base (from gcc-3.4-base_3.4.6-6ubuntu5_amd64.deb) ...
    Selecting previously deselected package libstdc++6-dev.
    Unpacking libstdc++6-dev (from libstdc++6-dev_3.4.6-6ubuntu5_amd64.deb) ...
    Setting up gcc-3.4-base (3.4.6-6ubuntu5) ...
    Setting up cpp-3.4 (3.4.6-6ubuntu5) ...
    Processing triggers for man-db ...
    Setting up gcc-3.4 (3.4.6-6ubuntu5) ...
    Setting up g++-3.4 (3.4.6-6ubuntu5) ...
    Setting up libstdc++6-dev (3.4.6-6ubuntu5) ...
    ubuntu@ubuntu:/media/0a803857-8b6f-4332-82b4-85ebf8283805/home/doug/Desktop/gcc-3.4$ /usr/bin/gcc-3.4 -v
    Reading specs from /usr/lib/gcc/x86_64-linux-gnu/3.4.6/specs
    Configured with: ../src/configure -v --enable-languages=c,c++,f77,pascal --prefix=/usr --libexecdir=/usr/lib --with-gxx-include-dir=/usr/include/c++/3.4 --enable-shared --with-system-zlib --enable-nls --without-included-gettext --program-suffix=-3.4 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug x86_64-linux-gnu
    Thread model: posix
    gcc version 3.4.6 (Ubuntu 3.4.6-6ubuntu5)
    Note: after running deadflowers command & updating sources

    sudo apt-get update
    Ign http://old-releases.ubuntu.com oneiric InRelease
    Ign http://old-releases.ubuntu.com oneiric-security InRelease
    Ign http://old-releases.ubuntu.com oneiric-updates InRelease
    Hit http://old-releases.ubuntu.com oneiric Release.gpg
    Hit http://old-releases.ubuntu.com oneiric-security Release.gpg
    Hit http://old-releases.ubuntu.com oneiric-updates Release.gpg
    Hit http://old-releases.ubuntu.com oneiric Release
    Hit http://old-releases.ubuntu.com oneiric-security Release
    Hit http://old-releases.ubuntu.com oneiric-updates Release
    Hit http://old-releases.ubuntu.com oneiric/main amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric/restricted amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric/main i386 Packages
    Hit http://old-releases.ubuntu.com oneiric/restricted i386 Packages
    Hit http://old-releases.ubuntu.com oneiric/main TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric/restricted TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric-security/main amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric-security/restricted amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric-security/main i386 Packages
    Hit http://old-releases.ubuntu.com oneiric-security/restricted i386 Packages
    Hit http://old-releases.ubuntu.com oneiric-security/main TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric-security/restricted TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric/main Translation-en
    Hit http://old-releases.ubuntu.com oneiric-updates/main amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric-updates/restricted amd64 Packages
    Hit http://old-releases.ubuntu.com oneiric-updates/main i386 Packages
    Hit http://old-releases.ubuntu.com oneiric-updates/restricted i386 Packages
    Hit http://old-releases.ubuntu.com oneiric-updates/main TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric-updates/restricted TranslationIndex
    Hit http://old-releases.ubuntu.com oneiric/restricted Translation-en
    Hit http://old-releases.ubuntu.com oneiric-security/main Translation-en
    Hit http://old-releases.ubuntu.com oneiric-security/restricted Translation-en
    Hit http://old-releases.ubuntu.com oneiric-updates/main Translation-en
    Hit http://old-releases.ubuntu.com oneiric-updates/restricted Translation-en
    Reading package lists... Done
    Add.
    ubuntu@ubuntu:~$ apt-cache policy gcc
    gcc:
    Installed: 4:4.6.1-2ubuntu5
    Candidate: 4:4.6.1-2ubuntu5
    Version table:
    *** 4:4.6.1-2ubuntu5 0
    500 http://old-releases.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
    100 /var/lib/dpkg/status
    ubuntu@ubuntu:~$ apt-cache policy gcc-3.4
    gcc-3.4:
    Installed: 3.4.6-6ubuntu5
    Candidate: 3.4.6-6ubuntu5
    Version table:
    *** 3.4.6-6ubuntu5 0
    100 /var/lib/dpkg/status
    ubuntu@ubuntu:~$
    Last edited by mc4man; July 3rd, 2013 at 08:20 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •