Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Slow resume from suspend; can't hibernate

  1. #21
    Join Date
    May 2013
    Beans
    24

    Re: Slow resume from suspend; can't hibernate

    Quote Originally Posted by Toz View Post
    Good its working again.

    From your pm-suspend.log file, resume takes 1 second, Not bad, except thats not what you're seeing.
    Code:
    Fri Jul  5 11:00:22 EDT 2013: Awake.
    Fri Jul  5 11:00:22 EDT 2013: Running hooks for resume
    .....
    Fri Jul  5 11:00:23 EDT 2013: Finished.
    When you say 30-45 seconds, are you timing just the resume part, or is this the whole suspend/resume cycle?



    One other thing that I'm noticing is that from your syslog file, there are a boat load of acpi errors:


    Can you post back the results of this command to show which kernel parameters you are using?
    Code:
    cat /proc/cmdline

    Here is the line you're looking for:
    Code:
    BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=438a922f-7bee-4639-8f9d-46c0a0c75115 ro quiet splash vt.handoff=7
    Also, it takes about 25 seconds from the moment I'm attempting the resume. From the moment I attempt to resume on Windows 7, it takes about 3-5 seconds.

  2. #22
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Slow resume from suspend; can't hibernate

    What video card do you have and what driver are you using? This should help:
    Code:
    sudo lspci -vnn | grep -A15 VGA

  3. #23
    Join Date
    May 2013
    Beans
    24

    Re: Slow resume from suspend; can't hibernate

    Quote Originally Posted by Toz View Post
    What video card do you have and what driver are you using? This should help:
    Code:
    sudo lspci -vnn | grep -A15 VGA
    Code:
    inate@Coder ~ $ sudo lspci -vnn | grep -A15 VGA[sudo] password for inate: 
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device [103c:1893]
        Flags: bus master, fast devsel, latency 0, IRQ 47
        Memory at f6400000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915
    
    
    00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04) (prog-if 30 [XHCI])
        Subsystem: Hewlett-Packard Company Device [103c:1893]
        Flags: bus master, medium devsel, latency 0, IRQ 43
    inate@Coder ~ $

  4. #24
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Slow resume from suspend; can't hibernate

    Is it just that the screen stays off, or is the whole system unresponsive during that 25 seconds of resume? Can you go to, and get, a text tty (Ctrl+Alt+F1) anytime during the 25 seconds of resume?

  5. #25
    Join Date
    May 2013
    Beans
    24

    Re: Slow resume from suspend; can't hibernate

    Quote Originally Posted by Toz View Post
    Is it just that the screen stays off, or is the whole system unresponsive during that 25 seconds of resume? Can you go to, and get, a text tty (Ctrl+Alt+F1) anytime during the 25 seconds of resume?
    I cannot.

  6. #26
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Slow resume from suspend; can't hibernate

    Can you post your entire syslog log file so I can have a look to see if there is anything else there that might indicate why the delay?
    Code:
    pastebinit /var/log/syslog

  7. #27
    Join Date
    May 2013
    Beans
    24

    Re: Slow resume from suspend; can't hibernate

    Quote Originally Posted by Toz View Post
    Can you post your entire syslog log file so I can have a look to see if there is anything else there that might indicate why the delay?
    Code:
    pastebinit /var/log/syslog

    I feel like the reason of the slow delay is because I can't hibernate. Wouldn't both states save to the same place? I know when you hibernate, it's all saved to the RAM--but if that were the case, I could hibernate easily. I can't even hibernate--when I do, the screen goes black for about 3 seconds, then resumes back to whatever I was doing before I initiated the command.

  8. #28
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Slow resume from suspend; can't hibernate

    Actually no. Suspend saves to RAM whereas Hibernate saves to disk (swap).

    It might be a good idea to create a bug report on launchpad for your issue.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •